USB 3 port not working with Armbian
#1
I can't get sound to work through HDMI with Manjaro.  To see if it is a hardware or software issue, I put the latest Armbian (23.8 Bookworm Cinnamon) on SD.

The left-side USB-A port doesn't work.  It will provide power, but not recognize anything.  The right-side USB-A still works.  I took a USB stick that has both USB-A and USB-C jacks.  The drive shows up if I stick in the USB-C jack, but not the USB-A.  USB-A seems to work fine with Manjaro, so I doubt it is a hardware issue.

(HDMI also doesn't work.)

Any ideas?

Related threads:

https://forum.pine64.org/showthread.php?tid=8243
https://forum.armbian.com/topic/31416-pr...ebook-pro/
  Reply
#2
I tried Armbian_23.5.1_Pinebook-pro_jammy_current_6.1.30_gnome on SD, and the USB 3 seems to be working fine.  Since it also works with Manjaro, it seems the problem is with 23.8 Bookworm Cinnamon.

(HDMI vis USB-C doesn't work with either the Jammy or Bookworm.  Picture but not sound works with Manjaro.)
  Reply
#3
(11-11-2023, 01:36 PM)zaius Wrote: I tried Armbian_23.5.1_Pinebook-pro_jammy_current_6.1.30_gnome on SD, and the USB 3 seems to be working fine.  Since it also works with Manjaro, it seems the problem is with 23.8 Bookworm Cinnamon.

(HDMI vis USB-C doesn't work with either the Jammy or Bookworm.  Picture but not sound works with Manjaro.)

For HDMI vis USB-C. please using megi build. Please follow this thread: https://forum.pine64.org/showthread.php?tid=18540
  Reply
#4
(11-11-2023, 09:40 PM)tllim Wrote:
(11-11-2023, 01:36 PM)zaius Wrote: I tried Armbian_23.5.1_Pinebook-pro_jammy_current_6.1.30_gnome on SD, and the USB 3 seems to be working fine.  Since it also works with Manjaro, it seems the problem is with 23.8 Bookworm Cinnamon.

(HDMI vis USB-C doesn't work with either the Jammy or Bookworm.  Picture but not sound works with Manjaro.)

For HDMI vis USB-C. please using megi build. Please follow this thread: https://forum.pine64.org/showthread.php?tid=18540

OK, thanks Smile  I have a lot on my plate right now, so unfortunately I don't have the time or attention necessary to modify the boot files.

Curious, though, if these are PBP specific operating systems, and this is a known and solved problem, why aren't they being released as such?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Camera not working with Cheese cypresstwist 1 1,119 08-18-2023, 02:02 AM
Last Post: juliamenendez
  Audio on Armbian Hobbes42 1 725 08-04-2023, 01:18 AM
Last Post: Humid Stylus
  Blank screen after Armbian 20.04 install to emmc? psychoacoustic 3 3,261 04-01-2023, 03:22 PM
Last Post: TRS-80
  Armbian 22.02 release announcement TRS-80 22 13,027 04-01-2023, 03:19 PM
Last Post: TRS-80
  Sound on Armbian Bram 1 781 04-01-2023, 03:16 PM
Last Post: TRS-80
  Fix for Armbian not booting on PBP from eMMC agreenbhm 7 3,503 04-01-2023, 02:58 PM
Last Post: TRS-80
  5GHz wifi not working snorwood 11 5,118 01-16-2023, 03:41 PM
Last Post: ehcorn
  Armbian is [edit: no longer] dropping support for Pinebook Pro TRS-80 4 3,950 12-23-2022, 12:01 AM
Last Post: TRS-80
  Pinebook Pro wifi not working Queliffrel 1 1,189 11-30-2022, 06:30 AM
Last Post: myself600
  Armbian VPU decoding support coming soon LivingLinux 0 726 11-13-2022, 02:32 PM
Last Post: LivingLinux

Forum Jump:


Users browsing this thread: 1 Guest(s)