"failed to start simple desktop display manager" PinePhonePro / Plasma Beta15 RC4
#1
I have a "recent" version of the PinePhonePro (i.e. - there is no RE button.)

Tow-Boot was pre-installed and seems to be working fine.

I don't know what's flashed on the eMMC in the factory, but when I tried to update it, replaced pacman pgp signatures with HTML advertisements for domains for sale (that's a new one.)

But I deleted the .sigs and updated through discovery.

I then got some sort of error on boot, but couldn't quite make it out because I couldn't turn on the backlight.  But the system didn't boot to a graphical screen.

I then downloaded Manjaro-ARM-plasma-mobile-pinephonepro-beta15-rc4.img.xz from https://github.com/manjaro-pinephone/pla...e/releases

Flashed it to eMMC using tow-boot and rebooted.

Other than it setting the backlight to zero on boot, everything was fine. screen worked. audio worked. wifi worked. i was able to activate sshd via systemctl.  I was completely happy.

But I did want to add software and update the device.

So...

sudo rm -r /etc/pacman.d/gnupg
sudo pacman-mirrors --geoip
sudo pacman -Sy gnupg archlinux-keyring archlinuxarm-keyring manjaro-keyring manjaro-arm-keyring
sudo pacman-key --init
sudo pacman-key --populate
sudo pacman-key --refresh-keys
sudo pacman -Sc

and then


sudo pacman -Syyuu

and it downloaded about 900Mb of new packages.  But now when I reboot, it hang w/ a message "failed to start simple desktop display manager" (I figured out that you set the screen dim timeout to never or some large value to avoid having the screen super-dim when it reboots.)

is this the expected behaviour?  are we just not supposed to update?  anyone have references to pages describing how to fix this?
  Reply
#2
I would install Mobian. The mention of ...blk0... should be ...blk1... .

https://wiki.debian.org/InstallingDebian...nePhonePro
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Mobian .desktop file creation MadameMalady 15 2,512 07-27-2023, 04:12 PM
Last Post: MadameMalady
  Manajaro Plasma 6 files break unstable updates, 6-30 mburns 5 1,409 07-20-2023, 11:19 AM
Last Post: mburns
  My Waydroid Manager call for testers / assistance MadameMalady 0 613 07-15-2023, 02:16 PM
Last Post: MadameMalady
  Manjaro Plasma unstable branch glitch mburns 2 958 06-21-2023, 08:03 AM
Last Post: mburns
  Phosh Updating - Battery Charge Indicator - Jittery Settings - Display Usability ArchiMark 4 1,227 05-28-2023, 07:00 AM
Last Post: ArchiMark
  Is Manjaro Plasma stable for anyone? projectcato 120 50,243 04-18-2023, 08:26 PM
Last Post: mburns
  Plasma Mobile Taskbar / Navigation Bar is Missing & Upper Panel X0X0X0X0X0 1 1,216 11-24-2022, 07:19 AM
Last Post: mburns
  PinePhone Pro Manjaro Plasma Mobile Beta 13 & No Audio with Phone Calls X0X0X0X0X0 0 1,027 11-02-2022, 02:09 PM
Last Post: X0X0X0X0X0
  Monjaro Plasma Cell Network and Data not working properly maiyuzhe 2 1,446 09-24-2022, 12:15 AM
Last Post: maiyuzhe
  Waydroid on PinePhone Pro PPP (Stock Manjaro Plasma) mhedhli 7 6,043 09-18-2022, 06:54 PM
Last Post: nroth

Forum Jump:


Users browsing this thread: 1 Guest(s)