Plasma mobile latest stable @pp1.2b voice calling audio issue
#1
When voice call starts, only first 5 secs is with audio, then sound stops, while call is still active.

After this audio is in "Invalid state" as i can see in plasma mobile audio settings, when trying to play test sound.

This "Invalid state" can be fixed by switching audio profile of output from "hi-fi" to "phone call" and vice versa, as i noticed.

Any ideas how to fix? There is no errors in dmesg, but as for me it looks like some buffer issue, or another overflow.
  Reply
#2
(10-02-2023, 01:20 PM)n05ph3r42 Wrote: When voice call starts, only first 5 secs is with audio, then sound stops, while call is still active.

After this audio is in "Invalid state" as i can see in plasma mobile audio settings, when trying to play test sound.

This "Invalid state" can be fixed by switching audio profile of output from "hi-fi" to "phone call" and vice versa, as i noticed.

Any ideas how to fix? There is no errors in dmesg, but as for me it looks like some buffer issue, or another overflow.

pmOS 20230926-1114-postmarketOS-v23.06-plasma-mobile-3.9-pine64-pinephone
  Reply
#3
Just tried voice calling in Phosh. 20230926-1050-postmarketOS-v23.06-phosh-22.2-pine64-pinephone. All works fine. So its a plasma-mobile issue.
  Reply
#4
Do the images use the same sound server? There is the older PulseAudio and the newer Pipewire. You may be running into a bug in one of them.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Gnome mobile user641 1 570 01-06-2024, 11:06 AM
Last Post: Uturn
  NextCloud Gnome Mobile Uturn 4 1,119 12-03-2023, 07:54 AM
Last Post: Uturn
  Firefox Crashes on Start-up (latest installer) & How do I change Default Browser? aLoop100o 1 386 11-22-2023, 10:16 AM
Last Post: zetabeta
  Issues after installing latest PostMarket OS with POSH xen314 4 1,309 08-20-2023, 11:18 PM
Last Post: xen314
  installed postmarketos v23.06 no audio samlo 1 751 07-14-2023, 12:53 AM
Last Post: samlo
Question Always Use Mobile Data DingDangDoong 4 1,827 04-20-2023, 06:18 AM
Last Post: DingDangDoong
  Pinephone 64 PostMarketOS edition Battery Issues, Not Hardware Issue X0X0X0X0X0 1 1,340 02-11-2023, 08:19 AM
Last Post: acid andy
  PostmarketOS v22.06 Plasma Mobile on PinePhone Pro & No MMS X0X0X0X0X0 1 1,357 11-07-2022, 10:34 PM
Last Post: X0X0X0X0X0
  PostmarketOS v22.06 Plasma Mobile on PinePhone Pro & WiFi Connect to SSID X0X0X0X0X0 1 1,126 11-06-2022, 06:41 PM
Last Post: Chief
  Disable mobile data auto-enable on boot 64_Tesseract 3 2,238 08-11-2022, 02:48 AM
Last Post: 64_Tesseract

Forum Jump:


Users browsing this thread: 1 Guest(s)