wasp-os status
I'm trying to install wasp-os without much success. It doesn't look like the project is very current, but it's an attractive alternative because everything is written in Python. I'm going to detail the steps I've taken and where it's going wrong.

I installed watchmate on my Linux system from the repositories. The repository version seems to be current. It works great, and I updated InfiniTime to version 1.13 without incident. Such an intuitive and easy to use program.

I installed the latest ARM gnu toolchain and added the 'bin' directory to my PATH environment variable.

I also used the following steps to download and build wasp-os. This is exactly what's shown in the installation guide and it works fine.

$ sudo apt install \
  wget git build-essential libsdl2-2.0-0 python3-click python3-gi \
  python3-numpy python3-pexpect python3-pil python3-pip python3-pydbus \
  python3-serial unzip
$ pip3 install --user cbor pysdl2 tomli
$ sudo apt install sphinx graphviz python3-recommonmark
# next step is redundant but I did it anyway
$ pip3 install --user -r wasp/requirements.txt

$ git clone https://github.com/wasp-os/wasp-os.git
$ cd wasp-os
$ make sim
$ make check
$ make submodules
$ make softdevice
$ make -j `nproc` BOARD=pinetime all
$ make docs

Everything so far works as advertised.

Then when I use watchmate to update the firmware (installing micropython.zip from the 'build-pinetime' directory) it uploads seamlessly. (This step doesn't work when I try to update the firmware with wasp-os-0.4.1.zip from the official distribution).

But now I still have InfiniTime and there is no sign of wasp-os on my PineTime watch!

Does anyone have advice about what I might be missing here? I've stumbled at the goal-line, and I assume I'm missing something obvious.
Did you follow the instructions installing Wasp-os from Infinitime?

(08-24-2023, 09:46 PM)GaryM Wrote: Did you follow the instructions installing Wasp-os from Infinitime?


Thanks for the advice. Unfortunately I haven't gotten a good outcome so far. This is a factory sealed watch, so I'm afraid I might be stuck for good.

That video doesn't work for me as advertised. The blue pinecone slowly turning white is replaced by a white pinecone that only stays for a second. 

The first time I tried to do this, the watch kept boot looping and the nrf connect process kept restarting. I tried to use watchmate to upload reloader-mcuboot.zip and it sort of seemed to work.

Then I could connect with nrfConnect, but the results are still not good.

I can upload reloader-mcuboot.zip and micropython.zip, but then it hangs at 100% and the watch is left in an unusable state. I wait a very long time at 100%, and nothing happens. The last message in the log says "[DFU] Uploading firmware..."

Eventually I have to exit. I see a pinecone with an arrow labeled Start. I click the watch button. The white pinecone appears for one second and I'm back to the start arrow. I can keep pushing the button and the same thing repeats.

I exit and relaunch nrf Connect. I re-connect to PineDFU in order to install reloader-factory.zip, when the process once again hangs at 100%. It sits there with the pinecone/bluetooth screen and nothing happens for a long time. nRF Connect says "uploading..." and the upload status is at 100% (5.5kb/s) even though it doesn't seem to be doing anything.

Eventually I get sick of waiting and disconnect. The watch is now in an unusable state with the Pinecone logo and a bluetooth icon next to it.

I can upload anything with nrf Connect but the upload always freezes at 100% and the result is no change to the watch.

I'm afraid this may have cost me my PineTime watch.
Don't loose hope yet...What version of nRF Connect are you using? The current versions like version 0.7.1 do not work. Try using an older version of nrf connect like this one specifically, https://github.com/NordicSemiconductor/A...ag/v4.24.3

I am using version 4.26.1.

I will try the version you suggest. Thanks so much for the tip!

Possibly Related Threads…
Thread Author Replies Views Last Post
  Wasp-os editing main.py Mpoint 4 2,301 08-07-2021, 02:34 PM
Last Post: danielt
Sad wasp simulation error pratyush049 1 2,748 06-24-2020, 06:51 AM
Last Post: danielt

Forum Jump:

Users browsing this thread: 1 Guest(s)