PD resets during heat up tip [Pinecil V2]
#1
Strange power behaviour of chain: Baseus 100W GAN Charger + Pinecil V2(+short tip).
After pressing button to heat up the solder tip, Pinecil starts heating, and in some moment Charger resets TypeC output, I press again it tries to heat up again and resets again, and after several tries, it reach threshold temperature and after that I can solder easily. Seems not enough power, and charger detects power peaks and resets output.
This is 100W charger from Baseus:  https://www.aliexpress.com/item/1005003117435688.html , I am using 100W TypeC cable.
I tried other cables, doesnt help. I tried to limit power in Pinecil's "advanced seting" to 65 to 50 W to 40W - doesnt help.
I tried to disconnect all other consumers, and remain only Pinecil connected to this Charger - doesnt help.
This Baseus charges my 65W Lenovo laptop easily.

Is there ideas what to check? Maybe some other advanced settings to try? Huh
  Reply
#2
If charger drops to 15V PD mode, it works stable.
  Reply
#3
Many time passed, but now seems issue is solved. I will share some my findings, can be useful for others, as officials are not active here.

What helps: updated FW to latest and change to another PD charger, another model.

During search a solution found some interesting information:
link - sometimes PD charger's IC can communicate with issues.
link - similar.
link - Pinecill needs PD charger with grounded core. Was old FW, I tried to ground my soldering iron as recomended, but this did not help. But stable work was achieved with another car PD charger connected to 12V battery. Also stable work was with original 65W PD charger with ground cord from my Lenovo laptop.
I would like to mention here, that most of the PD chargers have not ground core, they are wall chargers with 2 lines.
link - as we can see now, Pinecil is very dependent from type of PD charger conditions. Some PD chargers can refuse to support 20V PD mode for soldering iron, while they perfectly works with another devices.

In my case, I bought new cheap PD 65W GaN charger from Asometech at Aliexpress (6.08$), and it works fine with latest FW in Pinecill V2: link
Rolleyes
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinecil on Amazon? WEF 4 695 06-03-2024, 01:42 PM
Last Post: tllim
Question Can Pinecil Read USB-C Cable E-Marker Chips? Garywoo 1 409 05-13-2024, 01:31 PM
Last Post: tllim
  Connecting a power supply to the Pinecil jon_bondy 1 665 02-29-2024, 07:37 PM
Last Post: Okedokey
  Crippling noise from inside pinecil during a few minutes high power soldering. dreieck 2 1,116 01-31-2024, 12:34 AM
Last Post: suga7
Question Pinecil Tempaerature Reading jumps to Y400°C when active but stays normal when cold H3wastooshort 0 533 12-24-2023, 05:45 PM
Last Post: H3wastooshort
  Asus laptop power supply can also power Pinecil biketool 9 9,067 11-17-2023, 12:57 PM
Last Post: killingmesmalls
  Mass problem Pinecil V2 Harrysteed 0 889 11-02-2023, 09:11 AM
Last Post: Harrysteed
Question Pinecil v2 power cycles at higher voltages? clemon79 2 1,604 10-09-2023, 10:10 PM
Last Post: clemon79
  [Hackaday Article] All About USB-C: Pinecil Soldering Iron vajak 1 1,733 02-02-2023, 11:45 AM
Last Post: VaZso
  Brand new Pinecil v2 won't boot on PD jhutch 1 2,547 12-14-2022, 01:03 AM
Last Post: River

Forum Jump:


Users browsing this thread: 1 Guest(s)