UART connection when booting?
#1
Shocked 
I have connected the headphone-to-UART adapter to the PinePhone Pro, flipped the privacy switch #6 down and started the phone.




To my surprise, the only nessages I see are some sellected messages from the Linux kernel:




Code:
[    1.065868] OF: graph: no port node found in /i2c@ff3d0000/typec-portc@22
[    4.575898] pinephone-keyboard 5-0015: error -ENXIO: Failed to read device ID
[    4.592797] gpio gpiochip4: (gpio4): gpiochip_lock_as_irq: tried to flag a GPIO set as output for IRQ
[    4.593652] gpio gpiochip4: (gpio4): unable to lock HW IRQ 27 for IRQ
[    4.594346] genirq: Failed to request resources for stk3310_event (irq 100) on irqchip rockchip_gpio_irq
[    4.595374] stk3310 3-0048: request irq 100 failed
[    4.685972] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    4.839273] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    4.847959] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Jan  4 2021 19:56:29 version 7.45.229 (617f1f5 CY) FWID 01-2dbd9d2e

Manjaro Linux 5.18.0-2-MANJARO-ARM (ttyS2)

manjaro-arm login:




It seem that the "UART" facility is connected to





GPIO4_C3/UART2C_RX_u


GPIO4_C4/UART2C_TX_u




I'd expect to get the primary UART getting Boot ROM and bootloader messages. Any (hope fully easy) way to get those signals out?




Edit: How to get bootloader messages: Use 115200 bps speed on the UART port to see bootloader messages. 1500000 bps are needed later for the kernel.




Code:
connected

U-Boot TPL 2021.10 (Oct 04 2021 - 15:09:26)
Channel 0: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
Channel 1: LPDDR4, 50MHz
BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB
256B stride
lpddr4_set_rate: change freq to 400000000 mhz 0, 1
lpddr4_set_rate: change freq to 800000000 mhz 1, 0
Trying to boot from BOOTROM
Returning to boot ROM...

U-Boot SPL 2021.10 (Oct 04 2021 - 15:09:26 +0000)
Trying to boot from SPI
NOTICE:  BL31: v2.6(release):
NOTICE:  BL31: Built : 00:00:00, Jan  1 1980


Tow-Boot 2021.10 (Oct 04 2021 - 15:09:26 +0000)004 [variant: spi]

SoC: Rockchip rk3399
Reset cause: POR
Model: Pine64 PinePhonePro
DRAM:  3.9 GiB
PMIC:  RK8180 (on=0x80, off=0x00)
MMC:   mmc@fe310000: 3, mmc@fe320000: 1, mmc@fe330000: 0
Loading Environment from SPIFlash... SF: Detected gd25lq128e with page size 256 Bytes, erase size 4 KiB, total 16 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Model: Pine64 PinePhonePro
Net:   No ethernet found.
starting USB...
Bus usb@fe380000: USB EHCI 1.00
Bus usb@fe3a0000: USB OHCI 1.0
Bus usb@fe3c0000: USB EHCI 1.00
Bus usb@fe3e0000: USB OHCI 1.0
scanning bus usb@fe380000 for devices... 1 USB Device(s) found
scanning bus usb@fe3a0000 for devices... 1 USB Device(s) found
scanning bus usb@fe3c0000 for devices... 1 USB Device(s) found
scanning bus usb@fe3e0000 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Please press [ESCAPE] or [CTRL+C] to enter the boot menu.
off
off
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr
1513 bytes read in 14 ms (105.5 KiB/s)
## Executing script at 00500000
gpio: pin 105 (gpio 105) value is 1
gpio: pin 154 (gpio 154) value is 1
20785160 bytes read in 913 ms (21.7 MiB/s)
gpio: pin 105 (gpio 105) value is 0
89899 bytes read in 36 ms (2.4 MiB/s)
7656782 bytes read in 347 ms (21 MiB/s)
gpio: pin 157 (gpio 157) value is 1
Moving Image from 0x2080000 to 0x2200000, end=3640000
## Flattened Device Tree blob at 01f00000
   Booting using the fdt blob at 0x1f00000
   Loading Ramdisk to f47a4000, end f4ef154e ... OK
   Loading Device Tree to 00000000f478b000, end 00000000f47a3f2a ... OK

Starting kernel ...

¯ÎÜV.ÿYQøéðå³uÎAqO³uÎS¸þ»·¹¹xeª%²é»q»Íλގ<Uz´Ȋõ٦åíÙñj½íùý
Manjaro Linux 5.18.0-2-MANJARO-ARM (ttyS2)

manjaro-arm login:



i wonder if BOOTROM prints anything to that serial port?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Screen turning off and booting problems with the Pinephone Pro xnZwJR6vys9a2wm7yWE4 0 265 01-16-2024, 02:38 PM
Last Post: xnZwJR6vys9a2wm7yWE4
  PPP not booting/starting anymore JonnJonz 1 644 08-09-2023, 01:53 AM
Last Post: alaraajavamma
  USB to PC connection not charging PPP tckosvic 0 921 02-01-2022, 05:40 PM
Last Post: tckosvic

Forum Jump:


Users browsing this thread: 1 Guest(s)