Need Help Recovering Manjaro /boot Contents on Pinebook Pro
#6
(03-21-2023, 02:13 AM)KC9UDX Wrote: Cal
I don't use Tow-Boot (yet) but my U-Boot always says something just like "WARNING: Bad CRC. Using default environment." when it reads the SPI ROM (because mine is uninitialized).  I don't know which device yours is referencing, but it's just saying that there's no U-Boot or Tow-Boot there, so its going to continue booting.

As far as the rest, hopefully someone else can comment; I'm not that familiar with Manjaru (or Linux actually, I use NetBSD). It sounds like you're deep in Manjaru territory (blank screen with no cursor is very common).

73 KC9UDX Matt

Thanks for the info, Matt. I found this thread. Apparently, the warning is common to U-Boot and Tow-Boot but, if Strit isn't concerned about it, I guess I'll not worry either. My Tow-Boot is on SPI and I don't think there's a boot loader on my eMMC, though I'd need to double check to see if the Manjaro Image put one there but I don't think Manjaro supplies a boot loader these days in a Manjaro image. When I installed Manjaro to my eMMC after my NVMe quit booting, I had to remove my eMMC module and use another computer and my eMMC USB adapter to flash the eMMC with the Manjaro image. I could not get an SD card to boot Manjaro either, like I've done in the past. I've never had to use the USB adapter and another computer in the past.

https://forum.manjaro.org/t/u-boot-warni...up/96980/3

I still haven't found a solution to my NVMe drive not booting. I tried chroot and re-installed linux-image, which created the Image and initram files on the boot partition that I need, but I still can't get it to boot. There's a another thing that's really weird. My new Manjaro installation on my eMMC has an extlinux.conf file with a root UUID that doesn't even match the UUID on the root partition. I don't know how it can even boot. When I changed the UUID in the extlinux.conf file to match the partition, it failed to boot.

I borrowed another NVMe drive that's identical to my drive. I'll try installing a fresh system on it and see what happens. I'll be out of town for about 2 weeks though and probably won't get to it until I return home. At least I've not lost any data. The drive and /home directory are intact. I just won't boot.

Maybe I'll try NetBSD sometime. I haven't used it in years.

73
Cal -- AD8Q
  Reply


Messages In This Thread
RE: Need Help Recovering Manjaro /boot Contents on Pinebook Pro - by calinb - 03-21-2023, 11:21 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  [Pinebook Pro/Mobian/XFCE4] can fix touch or screen in greeter not both SynthGal 0 174 05-31-2024, 09:42 AM
Last Post: SynthGal
  Debian on Pinebook Pro u974615 7 1,975 03-31-2024, 10:11 AM
Last Post: u974615
  Manjaro Sway Theme Broken Eighty8 1 551 03-08-2024, 08:41 AM
Last Post: tophneal
  Pinebook Pro upgrading from the factory image yamsoup 12 2,742 02-22-2024, 04:02 PM
Last Post: tllim
Question Manjaro with Full Disk Encryption and GRUB dumetrulo 1 1,981 02-02-2024, 02:45 AM
Last Post: frankkinney
  Manjaro network problem late 2023 acruhl 1 578 01-19-2024, 11:32 PM
Last Post: Kevin Kofler
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 4 2,619 12-13-2023, 07:22 PM
Last Post: trillobite
  Gentoo on Pinebook Pro RELEASE jannik2099 54 94,353 12-08-2023, 11:25 PM
Last Post: tllim
  Manjaro 20.04 not loading from SD (with Manjaro on eMMC) zaius 1 635 12-07-2023, 03:11 PM
Last Post: wdt
  Boot Order in Pinebook Pro food 8 1,905 11-23-2023, 07:37 AM
Last Post: KC9UDX

Forum Jump:


Users browsing this thread: 1 Guest(s)