Need Help Recovering Manjaro /boot Contents on Pinebook Pro
#3
(03-20-2023, 10:31 AM)KC9UDX Wrote: It's probably telling you that your SPI ROM is uninitialized.  What device does it say that about?

As far as /boot, Manjaru is weird so it'll probably make me look stupid saying this, but you shouldn't have anything "installed" there.  Just copy the one from the eMMC.

Thanks, KC9IUDX!

Yes--the Tow-Boot message is from the SPI, and that's where Tow-Boot is located. I've never installed Tow-Boot until now so it only exists on SPI.

I followed these Tow-Boot instructions and used Etcher to image spi.installer.img to an SD card.
https://wiki.manjaro.org/index.php/Manja...ptional.29

The SPI installer booted and seemed to work perfectly. Actually, except for the Tow-Boot boot message now, it seems to work perfectly to boot my eMMC Manjaro OS too! I could try flashing SPI again but, if it works (message notwithstanding), don't fix it (perhaps).

I'm doing a pacman -Syu to my eMMC system right now and then I'll try copying its /boot files to my NVMe and see if NVMe will boot. I've previously tried modifying the extlinux files to point to root on NVMe but had no luck. I have plenty of experience switching /boot and / pairings from the last two years running U-boot and a system on my NVMe. In fact, at one time I ran /boot and / from NVMe and it worked, but was not stable.

U-boot, root on NVMe and /boot on eMMC has worked for me for almost two years now. I have almost two years of history on my NVMe. I won't lose important stuff, because the / partition is still readable. I'll just have to reconfigure and system how I like it and copy /home over to it. I'd rather get the old system to boot!

73
Cal (AD8Q)

Okay. After doing pacman -Syu, my eMMC and old NVMe system appear to be on the same kernel revision. I copied the eMMC /boot files to NVMe and changed /boot/extlinux/extlinux.conf file on the NVMe PARTUUID to match the NVMe root UUID. I also made sure the NVMe /etc/fstab file pointed to the NVMe root and boot partitions.

The old system that I'm trying to recover has symptoms similar to what's reported here, except I don't recall it happening after an upgrade and I no longer see the cursor on an otherwise black screen.

I think I need to boot to eMMC and chroot to the old system on NVMe and start reinstalling things but I don't know where to start. Probably building a new initframfs would be a good place. Will reinstalling the kernel under chroot, do that?

73
Cal (AD8Q)
  Reply


Messages In This Thread
RE: Need Help Recovering Manjaro /boot Contents on Pinebook Pro - by calinb - 03-20-2023, 11:35 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  [Pinebook Pro/Mobian/XFCE4] can fix touch or screen in greeter not both SynthGal 0 173 05-31-2024, 09:42 AM
Last Post: SynthGal
  Debian on Pinebook Pro u974615 7 1,974 03-31-2024, 10:11 AM
Last Post: u974615
  Manjaro Sway Theme Broken Eighty8 1 551 03-08-2024, 08:41 AM
Last Post: tophneal
  Pinebook Pro upgrading from the factory image yamsoup 12 2,740 02-22-2024, 04:02 PM
Last Post: tllim
Question Manjaro with Full Disk Encryption and GRUB dumetrulo 1 1,981 02-02-2024, 02:45 AM
Last Post: frankkinney
  Manjaro network problem late 2023 acruhl 1 577 01-19-2024, 11:32 PM
Last Post: Kevin Kofler
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 4 2,618 12-13-2023, 07:22 PM
Last Post: trillobite
  Gentoo on Pinebook Pro RELEASE jannik2099 54 94,343 12-08-2023, 11:25 PM
Last Post: tllim
  Manjaro 20.04 not loading from SD (with Manjaro on eMMC) zaius 1 635 12-07-2023, 03:11 PM
Last Post: wdt
  Boot Order in Pinebook Pro food 8 1,905 11-23-2023, 07:37 AM
Last Post: KC9UDX

Forum Jump:


Users browsing this thread: 1 Guest(s)