[Megapixels] Flash strobe, pictures viewer and MPCamera error 22
#1
Hi all,

I'm in bookworm mobian and do all latest available updates/upgrades on repo.

I have megapixels with 1.6.0-1+b1 version.

As suggest, i have installed necessary packages "dcraw" and "imagemagick".

In log, flash strobe is not openned.

Code:
Failed to open /sys/class/leds/white:flash/flash_strobe


And when i clicked on picture small icon to launch the picture viewer, it returned to me this error.

Code:
display-im6.q16: unable to open X server `' @ error/display.c/DisplayImageCommand/412.


Moreover, some camera log give error 22 as described follow.


Code:
MPCamera: VIDIOC_SUBDEV_S_FRAME_INTERVAL error 22, Argument invalide
MPCamera: VIDIOC_QBUF error 22, Argument invalide

Thanks a lot for your feedback.


All log megapixels from term are here.


Code:
megapixels
Found config file at /usr/share/megapixels/config/pine64,pinephone-1.2.ini
Adding camera rear from config
Adding camera front from config
Failed to open /sys/class/leds/white:flash/flash_strobe
MPCamera: VIDIOC_SUBDEV_S_FRAME_INTERVAL error 22, Argument invalide
Initialized OpenGL ES 2.0
TIFF version 20221213
Writing frame to /tmp/megapixels.SXpdil/0.dng
TIFF version 20221213
Writing frame to /tmp/megapixels.SXpdil/1.dng
TIFF version 20221213
Writing frame to /tmp/megapixels.SXpdil/2.dng
Making thumbnail
TIFF version 20221213
Writing frame to /tmp/megapixels.SXpdil/3.dng
Post process /tmp/megapixels.SXpdil to /home/home/Images/IMG20230317080048.ext (save-dng 1)
MPCamera: VIDIOC_SUBDEV_S_FRAME_INTERVAL error 22, Argument invalide
MPCamera: VIDIOC_QBUF error 22, Argument invalide
display-im6.q16: unable to open X server `' @ error/display.c/DisplayImageCommand/412.
display-im6.q16: unable to open X server `' @ error/display.c/DisplayImageCommand/412.
  Reply
#2
(03-17-2023, 07:27 AM)freelectro Wrote:
Code:
MPCamera: VIDIOC_SUBDEV_S_FRAME_INTERVAL error 22, Argument invalide
MPCamera: VIDIOC_QBUF error 22, Argument invalide

I had this error with megapixels as well.

Some searching led me to this thread, https://forum.pine64.org/showthread.php?...OC_REQBUFS

And I did have the mesa 22.3.3 packages that don't work correctly.

I downgraded, to the 22.3.2 packages and was able to take pictures with megapixels without it crashing.

Using the list of packages from the other thread I used this list of curl commands to download replacement packages from snapshot.debian.org, I installed those and megapixels worked. (Also some other graphical glitches got better as well)

Code:
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libgbm1_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libegl-mesa0_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/mesa-va-drivers_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libglapi-mesa_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libglx-mesa0_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libgl1-mesa-dri_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/mesa-vdpau-drivers_22.3.2-1_arm64.deb
  Reply
#3
(03-18-2023, 07:18 PM)detrout Wrote:
(03-17-2023, 07:27 AM)freelectro Wrote:
Code:
MPCamera: VIDIOC_SUBDEV_S_FRAME_INTERVAL error 22, Argument invalide
MPCamera: VIDIOC_QBUF error 22, Argument invalide

I had this error with megapixels as well.

Some searching led me to this thread, https://forum.pine64.org/showthread.php?...OC_REQBUFS

And I did have the mesa 22.3.3 packages that don't work correctly.

I downgraded, to the 22.3.2 packages and was able to take pictures with megapixels without it crashing.

Using the list of packages from the other thread I used this list of curl commands to download replacement packages from snapshot.debian.org, I installed those and megapixels worked. (Also some other graphical glitches got better as well)

Code:
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libgbm1_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libegl-mesa0_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/mesa-va-drivers_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libglapi-mesa_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libglx-mesa0_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libgl1-mesa-dri_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/mesa-vdpau-drivers_22.3.2-1_arm64.deb


I have installed all dependencies mesa in 22.3.2-1 version but maybe with apt reinstall libglapi-mesa_22.3.2-1.

I will check this, thanks a lot
  Reply
#4
(03-21-2023, 04:34 AM)freelectro Wrote:
(03-18-2023, 07:18 PM)detrout Wrote:
(03-17-2023, 07:27 AM)freelectro Wrote:
Code:
MPCamera: VIDIOC_SUBDEV_S_FRAME_INTERVAL error 22, Argument invalide
MPCamera: VIDIOC_QBUF error 22, Argument invalide

I had this error with megapixels as well.

Some searching led me to this thread, https://forum.pine64.org/showthread.php?...OC_REQBUFS

And I did have the mesa 22.3.3 packages that don't work correctly.

I downgraded, to the 22.3.2 packages and was able to take pictures with megapixels without it crashing.

Using the list of packages from the other thread I used this list of curl commands to download replacement packages from snapshot.debian.org, I installed those and megapixels worked. (Also some other graphical glitches got better as well)

Code:
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libgbm1_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libegl-mesa0_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/mesa-va-drivers_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libglapi-mesa_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libglx-mesa0_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/libgl1-mesa-dri_22.3.2-1_arm64.deb
curl -L -O https://snapshot.debian.org/archive/debian/20230112T090754Z/pool/main/m/mesa/mesa-vdpau-drivers_22.3.2-1_arm64.deb


I have installed all dependencies mesa in 22.3.2-1 version but maybe with apt reinstall libglapi-mesa_22.3.2-1.

I will check this, thanks a lot

Be appear, it's better with this package version 20230112T090754Z
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  PinePhone Pro not booting (Cap error!, pctl timeout) jealda 2 1,056 11-16-2023, 05:03 AM
Last Post: DrYak
Photo Can no longer take pictures, /dev/video* not recognized as video devices 64_Tesseract 0 531 01-26-2023, 10:19 AM
Last Post: 64_Tesseract
  Error Vandal187UM 0 1,093 03-13-2021, 11:06 PM
Last Post: Vandal187UM
  New motherboard - ANX firmware won't flash. --- 17 12,486 12-26-2020, 01:53 PM
Last Post: p1x3l3d
  eMMC won't flash RodMyers 3 4,581 09-12-2020, 06:38 PM
Last Post: SwordfishII
  Avoiding modem flash-memory corruption? msquared 6 6,849 06-16-2020, 06:05 AM
Last Post: ---
  Error in the spec of the pinephone someGermanGuy 1 3,025 02-18-2020, 03:29 PM
Last Post: dukla2000
  Camera/Flash Protector kuro 0 1,823 01-16-2020, 09:47 AM
Last Post: kuro

Forum Jump:


Users browsing this thread: 1 Guest(s)