Pinebook Pro won't turn on after flashing image
#1
Hi folks

I think I messed up pretty bad after trying install the latest version of Manjaro to my laptop, I downloaded the latest generic image from the website, I flashed it onto my SD card I did the setup and then flashed the image to emmc with the following command:

Code:
xzcat Manjaro-ARM-kde-plasma-generic-22.12.img.xz | dd of=/dev/mmcblk2 bs=1M status=progress conv=fsync

After turning off the pinebook pro and removing the sd to boot from the emmc, it would just not turn on again, the LED does not even blink red or green...

Is there anyone around who knows if I did anything wrong and if there is some way to fix it?

Thanks in advance for your answers  Big Grin
  Reply
#2
>Manjaro-ARM-kde-plasma-generic
generic? ?? There is no such thing in the ARM world, at least with respect to uboot
Every different cpu family has a different uboot layout, and there are more than a dozen familys,
and some are 32bit and some 64 bit
Do not confuse pinebook with pinebookpro, different cpus
Maybe it doesn't have a uboot in the first bit and ONLY the OS ??? (+ maybe a separate boot partition ??)
---
Anyway, take off back, disable emmc with switch near hinge line,
find a SD that boots OK, then do the switch dance,, lsblk to see if successful and what emmc is
ie /dev/mmcblkX,, what is X (emmc device has also boot0, boot1 on it, ignore them)
Then (as root) dd /dev/zero to first 32M of emmc (bs=1M count=32)
Then, effectively the emmc will be blank
Why 32M ?? So 1st partition start is also blanked, manjaro starts 1st part at 62500 sectors
(switch dance, make sure powered off, press pwr button 1s, 2s later flip emmc switch to enable)
If it doesn't work, force hard poweroff, press and hold pwr ~8s
  Reply
#3
Thank your for your answer, I'm sorry i didn't update my topic but I could solve my problem, I just had to install tow-boot correctly, I think there should be a note somewhere on the wiki or on manjaro's website indicating you need to separately install tow-boot to get anything working, this wasn't the case before and this is why I got confused but once this was done it just booted as it should...
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinebook Pro Initial Impressions kunger 443 621,929 04-16-2024, 07:29 PM
Last Post: KC9UDX
  looking to buy one pinebook pro (mainland China) duanduan 3 2,653 03-21-2024, 07:44 PM
Last Post: wangyukunshan
  Cellular module for Pinebook Pro Lotech 1 686 03-05-2024, 05:40 AM
Last Post: KC9UDX
  Screen on pinebook stays black but can ssh into machine tuxxpine 0 516 02-23-2024, 04:22 PM
Last Post: tuxxpine
  Sale my ANSI PineBook Pro cuthbertdavies 0 504 02-14-2024, 09:12 PM
Last Post: cuthbertdavies
  Compiling with -j6 on the Pinebook Pro (Overheat) KC9UDX 0 428 02-14-2024, 09:01 AM
Last Post: KC9UDX
  Pinebook Pro in EU for Sale - €90 jan_vdk 2 1,003 02-07-2024, 02:12 AM
Last Post: 23Ro
  Pinebook Pro for sale tomekdev 2 1,105 02-01-2024, 11:35 AM
Last Post: tomekdev
  Video Flashing/adjusting on boot and reboot jbradley419 0 482 01-16-2024, 09:17 AM
Last Post: jbradley419
  Video Editing Is Possible On The PineBook Pro! ImmyChan 10 8,484 12-17-2023, 09:29 PM
Last Post: insideau786

Forum Jump:


Users browsing this thread: 1 Guest(s)