Issue with booting Manjaro from encrypted NVMe drive on pbp
#1
I am trying to operating a pbp with a system booted from an encrypted NVMe drive, but I stuck at the same step and would appreciate any help:
  •  I use an unencrypted partition on the eMMC acting as boot partition that holds the kernel and an initramfs. The latter was build taking among others the hooks `plymouth`, `plymouth-encrypt` and `lvm2` into account.
  • I am trying to boot a Manjaro (22.12) system which is located on a btrfs filesystem within the encrypted container on the NVMe.
  • As bootloader I use Two-Boot (on 1st partition of eMMC), which works and allows me to interrupt the foreseen boot process in order to boot from SD. If I do not interrupt it and try to boot via eMMC from the NVMe, the image file is provided (which is the only thing I get since a dialogue is shown just very shortly). Then it stucks with a black screen and a green power led.

I append the following options via the `extlinux.conf` file:

Code:
cryptdevice=UUID=<ID-OF-NVME-DEV>:<LABEL-AS-APPEARS-IN-MAPPER>:allow-discards root=/mnt/mapper/<LABEL-AS-APPEARS-IN-MAPPER>/ rootflags=subvol=@ rw rootwait audit=0 plymouth.ignore-serial-consoles

The ID, label and subvolume I use is the correct one, but I have to admit that I am unexperienced so far regarding btrfs.

The fact that I am not prompted for the passphrase indicates me that the hook is either not implemented correctly in the initramfs, or not called correctly.`mkinitcpio` did not show an irregular behaviour during the creation of the initramfs (build via chroot from within the system I try to boot). In another approach I tried the `enrcypt` hook instead of `plymouth-encrypt` which did also not succeed. Moreover, I read here that one should use`plymouth-encrypt` if plymouth is in use, which is the case for Manjaro.

Something that I recognised is that the initramfs is not build using the kernel sources of the system:
Code:
mkinitcpio -p linux
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k 6.0.12-1-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
...

Code:
cat proc/version
Linux version 6.1.2-1-MANJARO-ARM ...

I would be happy for any hint that might be helpful to solve my issue.
  Reply
#2
I think you should check the initramfs hooks: Confirm that the necessary hooks
Code:
plymouth, plymouth-encrypt, and lvm2
pizza tower
are correctly included in the initramfs. You mentioned that you built the initramfs using mkinitcpio from within the system. Make sure that the hooks are specified in the /etc/mkinitcpio.conf file. You can check the contents of this file to ensure that the hooks are listed correctly.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro Sway Theme Broken Eighty8 1 348 03-08-2024, 08:41 AM
Last Post: tophneal
Question Manjaro with Full Disk Encryption and GRUB dumetrulo 1 1,821 02-02-2024, 02:45 AM
Last Post: frankkinney
  Manjaro network problem late 2023 acruhl 1 392 01-19-2024, 11:32 PM
Last Post: Kevin Kofler
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 4 2,279 12-13-2023, 07:22 PM
Last Post: trillobite
  Need Help Recovering Manjaro /boot Contents on Pinebook Pro calinb 6 2,378 12-11-2023, 03:47 AM
Last Post: calinb
  Manjaro 20.04 not loading from SD (with Manjaro on eMMC) zaius 1 468 12-07-2023, 03:11 PM
Last Post: wdt
  Manjaro ARM: enabling external monitors & fixing Broadcom WiFi after updating trifleneurotic 2 981 11-14-2023, 10:57 AM
Last Post: trifleneurotic
  Manjaro [ARM Stable Update] 2021-07-23 issues Bocanila 1 2,074 08-21-2023, 09:10 PM
Last Post: vanessadonald
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 1 2,045 08-21-2023, 09:08 PM
Last Post: vanessadonald
  Manjaro - HIbernate - brcmfmac clk issue pompeyPinePro 1 820 08-18-2023, 02:06 AM
Last Post: juliamenendez

Forum Jump:


Users browsing this thread: 1 Guest(s)