eMMC problem with Tow-Boot/u-boot on SPI
#1
I have a 2022 (July?) Pinebook pro.

I installed the latest Tow-Boot on the SPI, that works, but won't boot the eMMC, SD card booting works, haven't tried NVME.

The current Tow-Boot is based on the 2021.10 u-boot, so I think the problems are common to both.

I also successfully re-built Tow-Boot myself, and was able to add a patch with some debugging statements.

The problem seems to start when Tow-Boot tries to read multiple blocks off the eMMC, and the eMMC returns timeout in response to the stop transmission command that is supposed to close off the read command, in u-boot file drivers/mmc/mmc.c / mmc_read_blocks:

My (patched) version
Code:
    if (blkcnt > 1) {
        cmd.cmdidx = MMC_CMD_STOP_TRANSMISSION;
        cmd.cmdarg = 0;
        cmd.resp_type = MMC_RSP_R1b;
        if (mmc_send_cmd_quirks(mmc, &cmd, NULL,
                    MMC_QUIRK_RETRY_STOP_CMD, 4)) {
#if !defined(CONFIG_SPL_BUILD) || defined(CONFIG_SPL_LIBCOMMON_SUPPORT)
            pr_err("mmc fail to send stop cmd\n");
#endif
            return 0;
        }
    }

After this, the emmc is unusable, also from an os successfully booted from the sd card (Debian 11).

If I avoid writing to the emmc with Tow-Boot/u-boot, the emmc is readable and writeable from a Linux booted from the SD card. Both Linux and u-boot seem to access the eMMC with the DW drivers.

Any ideas/suggestions appreciated.
  Reply
#2
Replying to my own message:

Some progress, I enabled debug messages in dw_mmc.c

That resulted in something unexpected;
- when interacting with the sd, the messages from dw_mmc.c show up
- when interacting with the mmc, they don't show up, apparently another driver is being used for the emmc, if the Linux selection is anything to go by, it must be sdhci
  Reply
#3
I'm curious if you've made any progress with this. I'm seeing the same problem and it's really impacting the usefulness of the laptop for me.
  Reply
#4
No, still stuck on this, I am using an sd card in the meantime, and haven't had too much time to work on this.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  uboot wont boot to SD card after upgrade jbradley419 7 407 01-19-2024, 02:29 PM
Last Post: wdt
  Video Flashing/adjusting on boot and reboot jbradley419 0 169 01-16-2024, 09:17 AM
Last Post: jbradley419
  Brand new Pinebook Pro doesn't boot after Manjaro update johnboiles 8 1,838 12-15-2023, 02:11 PM
Last Post: wdt
  PBP won't boot after trying to reinstall Manjaro ARM soupgirl 3 474 12-13-2023, 08:17 PM
Last Post: trillobite
  Various freezes during boot & while running several Linux distros - hardware error? donuts 1 430 11-22-2023, 11:47 AM
Last Post: fxc
  Happy eMMC and SDcard OS usage for Pinebook Pro Newbies... Paulie420 42 58,413 11-20-2023, 06:22 PM
Last Post: wdt
  Cannot boot to Kali SD card after uboot upgrade jbradley419 4 967 09-19-2023, 08:48 AM
Last Post: dachalife
  Does latest Tow-Boot install/work correctly for everyone? tophneal 4 1,531 08-03-2023, 03:30 PM
Last Post: tophneal
  Boot into NVME drive, no wifi, sound, buttons... PaulQ 0 721 07-13-2023, 01:50 PM
Last Post: PaulQ
  New Pinebook pro won’t boot Generaltuxenburg 4 1,755 06-14-2023, 07:20 AM
Last Post: KC9UDX

Forum Jump:


Users browsing this thread: 1 Guest(s)