No audio on calls after using wired headset
#1
I noticed today that when using a wired headset, after making the first call with it all audio stops working on calls both incoming and outgoing. When this happens there are no audio devices listed in the sound section of settings, everything is just greyed out. Rebooting the phone fixes it until you use the headset again. (This is Arch+Phosh running from an SD card, updated as of yesterday.)
  Reply
#2
(12-06-2022, 07:33 AM)Zebulon Walton Wrote: I noticed today that when using a wired headset, after making the first call with it all audio stops working on calls both incoming and outgoing. When this happens there are no audio devices listed in the sound section of settings, everything is just greyed out. Rebooting the phone fixes it until you use the headset again. (This is Arch+Phosh running from an SD card, updated as of yesterday.)

This issue is a major pain in the butt. I get it regularly after making or receiving a call.

You can issue...

Code:
pulseaudio -k && pulseaudio --start


to reset it, rather than rebooting. I did try a cron job with this in but using 'pulseaudio --check' still returns '0', even when it's messed up and assigned the 'dummy' audio device.

I've never used PA in 16 years of using Linux, just ALSA, so if there's a PA user out there who could please advise on the correct method for checking when this happens, then please do! I'll try and find some time to investigate further myself.
Arch Phosh (PP); firmware: 0.7.1; ADSP: 003
  Reply
#3
(12-07-2022, 08:01 AM)cone99 Wrote: You can issue...

Code:
pulseaudio -k && pulseaudio --start

to reset it, rather than rebooting. I did try a cron job with this in but using 'pulseaudio --check' still returns '0', even when it's messed up and assigned the 'dummy' audio device.

Thanks, that pulseaudio reset sounds like the best approach for now. It would be easy enough to run a script from an icon on the screen to do that.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Phone calls with no sound user641 14 7,452 03-12-2023, 11:43 AM
Last Post: alpineduck
  Still No Calls or SMS AndyM 3 2,005 03-10-2023, 05:27 AM
Last Post: AndyM
  no audio ring on non chatty calls nemsys 0 856 08-14-2022, 03:23 PM
Last Post: nemsys
  Incoming calls only vibrate, phone is not ringing lacriz 4 3,731 05-31-2022, 11:40 PM
Last Post: hannescam
  audio services shut down after short time on arch-phosh pineuser0 3 2,818 01-22-2022, 01:14 PM
Last Post: elagost
  2 weeks after installation during calls people hear me but i don`t hear anyone 7horns7eyes 10 7,612 01-22-2022, 08:16 AM
Last Post: kmsgli
  Call audio not routing through headphones fzfddv 1 2,138 04-29-2021, 08:54 PM
Last Post: mikehenson

Forum Jump:


Users browsing this thread: 1 Guest(s)