Install OpenBSD 7.2 on Pine64+ (2Gb)
#1
Hey there,

anyone managed that ?
My Pine64 was taking dust in a box with an old debian distro on it.
Then I decided I could maybe use it if I could put an OpenBSD on it, to replace another machine I have.

Unfortunately it keeps hanging at different points in the install process and is left in such a way that I have to reflash everything again.

To reach that point I overcame the hurdle of using screen appropriately on my mac (found the best info here and here). In short identifying correctly the serial device to use Smile)

Then I was able to check that that page (explaining how to do with an LTS version) applied easily enough to the Pine64+ if taking appropriate files (not those of the LTS Smile)

And now, I'm kinda stuck and it's bugging me.

Note : I tried to follow the instructions from OpenBSD.org for the PIne64+ but did not quite understand, or they don't work Smile
That paragraph of the arm64 install page :
Code:
Firmware which provides an UEFI interface with a Device Tree Blob
(DTB) file or ACPI support is required to boot.  In most cases this is
provided by images of U-Boot 2016.07 or newer on SD/MMC devices or in
SPI flash.  If the miniroot or install images are used, U-Boot and
DTB files are distributed as part of the images.
turned out to be optimistic for example.


Anyway, any help would be appreciated.
That being said I see this section of the forum is very quiet since 2019 Smile
  Reply
#2
I just installed OpenBSD to my 2GB Pine64+ (that was also collecting dust Smile)

I simply used the stock install72.img written to an SD card but in order for the installer to boot, the device had to be connected to a monitor via HDMI  even though, immediately after the boot loader ran, the HDMI goes blank (it still had to be connected though.)  I was then able to complete the install via serial port, specifically using the EXP pins. No other serial ports worked for me and they all leaked power to the board as mentioned here.

I then used HTTP to install the sets onto the SD card.

Oddly enough after installing and rebooting, the board didn't boot. This could have just been due to my monitor going to sleep (I'm going to see if a HDMI dummy plug solves this issue.)
  Reply
#3
(03-26-2023, 08:22 AM)tpaul Wrote: ... the device had to be connected to a monitor via HDMI
...
I'm going to see if a HDMI dummy plug solves this issue.

Dummy plug seems to have worked, though I had to reboot the board three times to get it to boot successfully... not sure what is going on with that.

First time boot failed before it got to the OpenBSD bootloader.

Second time OpenBSD boot loader failed.

Third time OpenBSD boot loader succeeded.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  NetBSD will does not install to eMMC ronverbs 3 8,131 06-24-2020, 01:07 AM
Last Post: KC9UDX
  FreeBSD on pine64 e-minguez 12 22,903 06-04-2019, 07:44 AM
Last Post: rob933a
  OpenBSD on Pine64 e-minguez 5 10,097 05-24-2019, 03:11 AM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)