Not connecting to cellular network
#11
(11-17-2022, 12:29 AM)shulamy Wrote: i don't recommend but i use this

https://github.com/the-modem-distro/pine...k/releases

i installed firmware updater and this is the latest option

ezik

i'm sorry , i installed "firmware"  not "firmware updater"

ezik

I used the firmware app to upgrade the modem firmware to Biktorgj firmware (V 0.7.0). It was weird in that the first attempt failed, and it said the modem was an Google Android modem after the failure.

I re-attempted the update, and it succeeded. But the current behavior is the same as before.

I did call PureTalk yesterday and they said my IMEI for the PP is okay for the network.

Getting ready to try an old Verizon SIM I have.

Similiarish behavior with the Verizon SIM (not sure how valid of a test it is since it is old, and has no service). With the Version SIM it started out showing searching under the modem menu, then went to "Not Registered". Then it said no SIM after a short period.

Thinking I might try changing my IMEI.
  Reply
#12
Quick update on my issue, I got a new SIM card and the behavior is the same as previous. (Old SIM went bad, I suspect it was due to how hard it is to remove from the PinePhone and my technique).

I did some APN testing with my Motorolla phone, and the APN must be set for voice,text, data to work. But it only requires that the APN entry have a name and that the APN block be set to RESELLER. I was checking this since my Moto has many more APN setting options.

I never did try changing the IMEI, as Mobain does not have the ATINOUT package and mmcli commands return that the modem must be in debug mode.

Debating to try a different OS? Which OS comes with ATINOUT, or can I install it in Mobain? 

Any other thoughts or suggestions?
  Reply
#13
A sticky tape 'handle' stuck to the back of the SIM makes changes easy.

It's modemmanaget that needs to be in debug mode for atinout to work. However you can just stop modemmanager and use a terminal like picocom to connect to the modem's serial interface and send the necessary AT commands. I haven't used it forIMEI changes, but have for experimenting with the GPS whcih needs other AT commands to control it.
  Reply
#14
(11-24-2022, 11:44 AM)wibble Wrote: A sticky tape 'handle' stuck to the back of the SIM makes changes easy.

It's modemmanaget that needs to be in debug mode for atinout to work. However you can just stop modemmanager and use a terminal like picocom to connect to the modem's serial interface and send the necessary AT commands. I haven't used it forIMEI changes, but have for experimenting with the GPS whcih needs other AT commands to control it.
Good call on the tape handle, I will give that a shot.

I will give killing modemmanger and try the AT commands.
  Reply
#15
Just got done changing the IMEI to one I know would not be an issue with Puretalk, and it still will not connect (Mobian).
After that I tried it on Manjero booting from an SD, and the result was the same as previous attempts.
Also booted Arch on an SD, same behavior. But it did at least indicate "Network type": LTE, gsm or unknown. I think in that order

Also booted the test OS and all the tests passed on it. Does that check definitively rule out the possibility of a hardware issue?

So high level recap:
  • Updated modem firmware using community varient, using the "firmware" app: version is now 0.7.0
  • Verified APN settings
  • Changed IMEI
  • Tried Manjero (sdcard) and Mobian (clean installed Mobian at leaset once)
  • Booted the test OS, passes all tests

It still will not connect to cellular network. 

Carrier (blank)
Network Type - Unknown
Signal - 20-70%
Network Status - Searching, Not registered, or unknown


Any suggestions would be appreciated.
  Reply
#16
I went and bought a few other SIM cards tonight, tried the Mint mobile one first and it recognized the carrier, network type, and registered shortly after logging into the phone. 

So the issue is PureTalk. 

Does anyone know how to get this phone to register on PureTalk? I am not really wanting to change carriers at the moment.

Thanks.
  Reply
#17
(12-01-2022, 10:45 PM)car46999 Wrote: I went and bought a few other SIM cards tonight, tried the Mint mobile one first and it recognized the carrier, network type, and registered shortly after logging into the phone. 

So the issue is PureTalk. 

Does anyone know how to get this phone to register on PureTalk? I am not really wanting to change carriers at the moment.

Thanks.

I don't.

The carrier issues has been long in the tooth on this forum and others.  Here is Biktor's latest work on handling multiple carrier profiles: https://github.com/the-modem-distro/pine...1232456448

Puretalk is never even seen by the PP's modem?  One of the mmcli commands will list out all the results of a tower search: 

Code:
mmcli -m 1 --3gpp-scan

or similar

I also went through trying different carrier SIMs and flashing different OSes like you've done.  My takeaway was: if I lived in a major city (lots of towers), I'd probably have my pick of carriers to use with my PP.  My partner won't be moving anytime soon  Big Grin so I went with another carrier that mostly works with local towers (USMobile).
PPv1.2a running PMOS ... almost a daily driver!
  Reply
#18
(12-04-2022, 09:20 AM)vap0rtranz Wrote:
(12-01-2022, 10:45 PM)car46999 Wrote: I went and bought a few other SIM cards tonight, tried the Mint mobile one first and it recognized the carrier, network type, and registered shortly after logging into the phone. 

So the issue is PureTalk. 

Does anyone know how to get this phone to register on PureTalk? I am not really wanting to change carriers at the moment.

Thanks.

I don't.

The carrier issues has been long in the tooth on this forum and others.  Here is Biktor's latest work on handling multiple carrier profiles: https://github.com/the-modem-distro/pine...1232456448

Puretalk is never even seen by the PP's modem?  One of the mmcli commands will list out all the results of a tower search: 

Code:
mmcli -m 1 --3gpp-scan

or similar

I also went through trying different carrier SIMs and flashing different OSes like you've done.  My takeaway was: if I lived in a major city (lots of towers), I'd probably have my pick of carriers to use with my PP.  My partner won't be moving anytime soon  Big Grin so I went with another carrier that mostly works with local towers (USMobile).

Cool thanks for the suggestion, I'm not giving up. Just need a good time to dig into this, hopefully I will get it figured out and post back with the solution.
  Reply
#19
I finally got my Pinephone working!! It did turn out to be an issue with the APN settings.

Running the following command got me a working phone: voice, cellular data, sent and received messages and SMS/MMS all tested to work.

mmcli -m 0 --3gpp-set-initial-eps-bearer-settings="apn=RESELLER,ip-type=ipv4"

As soon as I entered that command 4G showed up by the cell signal icon. Under modem status: carrier now shows AT&T, network type is lte, network status is registered.



This drove me crazy, glad I finally figured it out hope this helps someone else.

This is on Manjaro  6.0.3-1, which IIRC I used this OS to have working AT modem commands. I assume I could have gotten other OS(s) to work the same way. Gonna try out Manjaro for the time being.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Mobile internet via cellular network mostly not working Anna 18 10,211 01-19-2024, 02:59 AM
Last Post: anonymous
  need help with downgradin network-manager Ferriah 0 637 11-07-2022, 04:51 PM
Last Post: Ferriah
  Exclamation point in cellular icon after update Zebulon Walton 8 4,674 06-22-2022, 05:57 PM
Last Post: albafrati
  Blueman GUI Bluetooth Network Access Point - fixing Bridging biketool 12 8,039 05-26-2022, 05:56 AM
Last Post: biketool
  Cellular data is working! drh 0 850 05-15-2022, 09:02 AM
Last Post: drh
  Mobile network mode setting not saved Zebulon Walton 3 3,041 12-05-2021, 12:12 AM
Last Post: bcnaz
  Telegram not connecting anymore? SocialNetworkingWasAMistake 1 1,672 09-17-2021, 11:35 AM
Last Post: ragreenburg
  Mobile network is not working tlo 11 13,740 12-15-2020, 02:49 PM
Last Post: jim.uren@gmail.com

Forum Jump:


Users browsing this thread: 1 Guest(s)