Brand new Pinecil v2 won't boot on PD
#1
G'day folks.  I was excited to receive the pinecil v2 (direct from main store) and it will start on a 5V source but I can't get it to start at all on higher voltage PD supplies.

I've got a pinecil v2 that I expect to support "USB type C: PD and QC 3.0 12V-20V 3A" running v2.18 (I can see a 2.19 but the changelog doesn't reference PD fixes)

The main one I expected it to work with is a Zendure Supertank which has USB C ports that supply 5V/9V/12V/15V/20V @3A (for 60W) or 20V @5A (for 100W) and works well with my laptop.    I've also tried a Dell D6000 dociking station that supports PD up to 65W  (5V/9V/15V@3A and 19.5V@3.25A).  No sign of life from the pinecil on either.

I've tried using both the red usb-c cable I bought with the pinecil and an existing high quality one I bought for 100W PD charging of my laptop from the supertank.

I've tried changing the "PD Timeout" right up to 50.   

Any suggestions on what I haven't tried?   Maybe I've got a dud?

Thanks.
J.
  Reply
#2
Zendure battery most likely does not work with Pinecil V2.
Other people have posted in live community discord before that Zendure battery power bank does not work on the USB-C ports with Pinecil V2.

See Pinecil Wiki for list of Not-compatible chargers/devices (https://wiki.pine64.org/wiki/Pinecil_Pow...compatible).
PD timeout is not going to help, it is there to accomodate for poorly made QC chargers that need the PD timeout to be very low . Github IRonOS documents has details on what the PD timeout does, it is there for people with problematic QC chargers.

Other people that tested Zendure in live discord chat said that it's just the Zendure that does not work. Pinecil V2 works fine, and cable works fine with a normal USB-C charger and USB C to C cable. But the Zendure battery does not work on Usb-C ports correctly. There are other batteries that will work look for ones that say PD3.0 or PD3.1 compliant. PD3.1 is backwards compatible. They can get the Zendure to work with Pinecil only using a USB-A cable and QC voltage settings in power section (QC has to be manually configured unlike PD usb-C). Zendure is basically a dud.

Pinecil wiki is here with directions for updating to V2, 2.20 firmware : https://wiki.pine64.org/wiki/Pinecil
wiki also has links to join Live support chat.

I don't see any proof on the Zendure listing at all that they are PD 3.0 compliant (usb-C side). They only mention they are QC3.0 but that is not the part we care about. Meaning it will work on QC, but you will have to manually set the QC voltage which is "not smart" and not fun. I think it's odd that no where on the Amazon listing do they state they are PD 3.0 protocol compliant and this is what you need. Other people who confirmed Zendure does not work and Zendure is a dud said that it just shows black screen on Pinecil.

Connect Pinecil V2 to a normal PD USB-C power supply (not a zendure which other people already reported doesn't work, and not a dock). but a real Power charger, there are a bunch from amazon low cost listed on Pinecil Wiki.

Is your dock and actual USB-C PD 3.0 Compliant charger? I rarely check these forums usually so I might not see any responses for over 2 weeks. the Live discord channel is the best bet for live support .

It does not seem like you tried it yet with actual charger like a USB-C PD65W 3.25 amp 20V charger and so far just a power bank Zendure (known to not work). and a dock?
Pinecil Wiki also has a link of known working chargers. https://wiki.pine64.org/wiki/Pinecil_Power_Supplies

If it works on 5V to Computer, and you can find a DC barrel in house or a real usb-C charger, check that. It is known that zendure powerbanks don't work for others.
Could you confiorm with Dell or dell listing on the Dock to be sure it is providing compliant PD3.0 Protocol on that output port?

bunch of chargers on Pinecil Wiki in that are compliant PD 65W 3.25Amps 20V, and ~$15-$25 on both Pine Store website and Amazon and often on sale for less if you keep eye out. i got some of the listed $20 and $25 ones on sale on Amazon for only $10-$15.99 by watching for them.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  [Hackaday Article] All About USB-C: Pinecil Soldering Iron vajak 1 80 02-02-2023, 11:45 AM
Last Post: VaZso
  Survey on Pinecil Tips, Please fill out River 0 371 11-06-2022, 02:43 AM
Last Post: River
  [available again] When will the Pinecil be available again? dreieck 10 2,918 11-05-2022, 01:48 PM
Last Post: River
  Real/Usable USB-C battery pods for Pinecil? (9-12v mode minimum) biketool 18 6,485 11-05-2022, 01:42 PM
Last Post: River
  Use pinecil (V1) as a high temp thermoemter? Ko1 2 615 11-05-2022, 01:39 PM
Last Post: River
  Brand new Pinecil worked for 30mins - now screen dead and glows red hot! clipclop 3 1,505 11-05-2022, 01:37 PM
Last Post: River
Question Pinecil authenticity checker just reports "Invalid data": What does it mean? dreieck 1 372 11-05-2022, 01:36 PM
Last Post: River
  !! Pinecil is dead after 3 times using it, don't buy this crap... bbeeast 2 1,593 11-05-2022, 01:29 PM
Last Post: River
Big Grin Automate checking whether the Pinecil is still in stock Julius_GU 5 5,063 08-23-2022, 12:54 PM
Last Post: ender__exe
  Asus laptop power supply can also power Pinecil biketool 8 4,934 05-21-2022, 05:56 AM
Last Post: lozza_c

Forum Jump:


Users browsing this thread: 1 Guest(s)