Need to re-write U-boot from Pinephone pro currently in mass rom mode
#1
Hi All;
I was trying to flash my emmc on Pinephone Pro and by mistake I erased instead my U-boot. I used an sd-card for the day and once the battery was drained the phone went into mass rom mode and I can no longer power it on.
After recharging the battery from a power station I tried to switch it on unsuccessfully. I tried as well the recovery mode (using the RE button on the back and it would work).
I can no longer see the device when running the lsblk command. However I see the rockship in mass rom mode when I run the lsusb command from my linux labtop.

I read few instruction and a script provided by the rkdeveloptool-master to flash the memory and see if I can copy across a new bin file (rk3399_loader_spinor_v1.15.114.bin) and from there being able to move out of the mass rom mode and use again the sd card. It was not successful.

I was wondering if there is U-boot image available that I can use and how can I copy it across to my phone memory since I am still on mass rom mode. I guess there are 2 questions in 1:
a) how to move out of the mass rom mode
b) How to reinstall the Uboot in my Pinephone Pro

Thank you.
  Reply


Messages In This Thread
Need to re-write U-boot from Pinephone pro currently in mass rom mode - by wolverine1 - 10-30-2022, 06:22 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  upgrading u-boot--what version? where to get it? bsammon 6 130 Less than 1 minute ago
Last Post: bsammon
  uboot wont boot to SD card after upgrade jbradley419 7 1,026 01-19-2024, 02:29 PM
Last Post: wdt
  Video Flashing/adjusting on boot and reboot jbradley419 0 335 01-16-2024, 09:17 AM
Last Post: jbradley419
  Brand new Pinebook Pro doesn't boot after Manjaro update johnboiles 8 2,437 12-15-2023, 02:11 PM
Last Post: wdt
  PBP won't boot after trying to reinstall Manjaro ARM soupgirl 3 796 12-13-2023, 08:17 PM
Last Post: trillobite
  Various freezes during boot & while running several Linux distros - hardware error? donuts 1 655 11-22-2023, 11:47 AM
Last Post: fxc
  Cannot boot to Kali SD card after uboot upgrade jbradley419 4 1,295 09-19-2023, 08:48 AM
Last Post: dachalife
  Does latest Tow-Boot install/work correctly for everyone? tophneal 4 2,023 08-03-2023, 03:30 PM
Last Post: tophneal
  Boot into NVME drive, no wifi, sound, buttons... PaulQ 0 838 07-13-2023, 01:50 PM
Last Post: PaulQ
  Pinebook Pro (+ Pinephone) for sale (UK, London) chaoskampf 8 4,137 07-10-2023, 10:29 AM
Last Post: dachalife

Forum Jump:


Users browsing this thread: 1 Guest(s)