Mobian external display woes
#1
I replaced the faulty motherboard on my pinephone with a new one, and it seems to be running Mobian fine...
I got a USB hub, with 3 USB 3.0 ports and an HDMI port, so I could connect a keyboard, mouse and external display to the phone, using it as a computer when at my desk.
But now whenever I start using it, the external display will blank almost every second.. sometimes it will go into sleep mode. Sometimes it's so bad that I have to disconnect the HDMI to get it back. the USB Hub is powered externally.
The external

Does this happen to anyone else? Does anyone have a clue why this might be happening?

It makes it really frustrating to use.

ps - it seems like every time it writes anything to the external display, it blanks until its done. And for some reason sometimes it just goes into power-saving.
  Reply
#2
(10-21-2022, 04:39 PM)Hiraghm Wrote: I replaced the faulty motherboard on my pinephone with a new one, and it seems to be running Mobian fine...
I got a USB hub, with 3 USB 3.0 ports and an HDMI port, so I could connect a keyboard, mouse and external display to the phone, using it as a computer when at my desk.
But now whenever I start using it, the external display will blank almost every second.. sometimes it will go into sleep mode. Sometimes it's so bad that I have to disconnect the HDMI to get it back. the USB Hub is powered externally.
The external

Does this happen to anyone else? Does anyone have a clue why this might be happening?

It makes it really frustrating to use.

ps - it seems like every time it writes anything to the external display, it blanks until its done. And for some reason sometimes it just goes into power-saving.

Are you using mobile broadband at the same time?

This exact thing happens when you are using the mobile broadband at certain frequency (it sends a "pulse" that interference the hdmi connection and the screen flashes like crazy). For me that frequency is 4G but your carrier might use different frequency.
It might not happen if you use some offline app like gedit and there is minimal data transfer but if you try to load website or send email it is most of the time useless.
  Reply
#3
(10-21-2022, 04:39 PM)Hiraghm Wrote: I replaced the faulty motherboard on my pinephone with a new one, and it seems to be running Mobian fine...
I got a USB hub, with 3 USB 3.0 ports and an HDMI port, so I could connect a keyboard, mouse and external display to the phone, using it as a computer when at my desk.
But now whenever I start using it, the external display will blank almost every second.. sometimes it will go into sleep mode. Sometimes it's so bad that I have to disconnect the HDMI to get it back. the USB Hub is powered externally.
The external

Does this happen to anyone else? Does anyone have a clue why this might be happening?

It makes it really frustrating to use.

ps - it seems like every time it writes anything to the external display, it blanks until its done. And for some reason sometimes it just goes into power-saving.

Not all docks are compatible. Try using a Pine dock and see if the issue clears up. I also have another brand of dock and it doesn't work that well. The display is intermittenet at best.
----------------------------------------------------------------------------------------------------------
TESTED: Arch Plasma, Arch Phosh , Manjaro Phosh, Manjaro Plasma
Fedora, Mobian, Postmarket Plasma, Postmarket Phosh, Kali, SXMO.
  Reply
#4
thanks for the info. when they get one in stock, I'll get one.

(10-22-2022, 01:50 AM)alaraajavamma Wrote:
(10-21-2022, 04:39 PM)Hiraghm Wrote: I replaced the faulty motherboard on my pinephone with a new one, and it seems to be running Mobian fine...
I got a USB hub, with 3 USB 3.0 ports and an HDMI port, so I could connect a keyboard, mouse and external display to the phone, using it as a computer when at my desk.
But now whenever I start using it, the external display will blank almost every second.. sometimes it will go into sleep mode. Sometimes it's so bad that I have to disconnect the HDMI to get it back. the USB Hub is powered externally.
The external

Does this happen to anyone else? Does anyone have a clue why this might be happening?

It makes it really frustrating to use.

ps - it seems like every time it writes anything to the external display, it blanks until its done. And for some reason sometimes it just goes into power-saving.

Are you using mobile broadband at the same time?

This exact thing happens when you are using the mobile broadband at certain frequency (it sends a "pulse" that interference the hdmi connection and the screen flashes like crazy). For me that frequency is 4G but your carrier might use different frequency.
It might not happen if you use some offline app like gedit and there is minimal data transfer but if you try to load website or send email it is most of the time useless.

(10-22-2022, 09:52 AM)Chief Wrote:
(10-21-2022, 04:39 PM)Hiraghm Wrote: I replaced the faulty motherboard on my pinephone with a new one, and it seems to be running Mobian fine...
I got a USB hub, with 3 USB 3.0 ports and an HDMI port, so I could connect a keyboard, mouse and external display to the phone, using it as a computer when at my desk.
But now whenever I start using it, the external display will blank almost every second.. sometimes it will go into sleep mode. Sometimes it's so bad that I have to disconnect the HDMI to get it back. the USB Hub is powered externally.
The external

Does this happen to anyone else? Does anyone have a clue why this might be happening?

It makes it really frustrating to use.

ps - it seems like every time it writes anything to the external display, it blanks until its done. And for some reason sometimes it just goes into power-saving.

Not all docks are compatible. Try using a Pine dock and see if the issue clears up. I also have another brand of dock and it doesn't work that well. The display is intermittenet at best.

Thanks for the info. Of course I had my 4G on at the time, but I was connected to my network via wifi, I wasn't using it... I'll try it again with 4G turned off and see what happens.
  Reply
#5
That was the problem. I turned off 4G and it stopped doing that.
So I'll pick up a convergence as soon as I can.
  Reply
#6
I can confirm that. I bought a:

"USB C Hub Type C Hub Adapter, Ablewe 5 in 1 Aluminum USB C to HDMI 4K Adapter with 3 USB 3.0 Ports,87W Power Deliver(PD) for MacBook Pro 2017/2018, XPS and More USB C Devices"

from Amazon. I get no HDMI output at all with my PinePhone.
PinePhone Beta 2GB/16GB Postmarket OS v23.06.1 Phosh 0.30.0 (not in use)

PineTab2 Arch Danctnix 6.4.2
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  bookworm vs trixie discussion for mobian in pinephone regular. zetabeta 27 2,880 05-17-2024, 07:58 AM
Last Post: treebeard
  atinout binaries for mobian/debian? NeutralGrey 2 140 05-13-2024, 02:42 PM
Last Post: Gumur
  Mobian repository status henrythemouse 16 9,180 04-10-2024, 10:02 AM
Last Post: diederik
  cant verify mobian image at website gnugpg penguins_rule 0 179 03-18-2024, 08:54 PM
Last Post: penguins_rule
  mobian installed to eMMC - how to install tow-boot grump_fiddle_reinstall 6 2,155 11-22-2023, 11:46 AM
Last Post: aLoop100o
  What actions needed to keep on mobian testing user641 3 1,907 09-05-2023, 06:44 AM
Last Post: Zebulon Walton
  Mobian boot failed with zstd message after upgrade. Mahgue 0 670 09-01-2023, 11:29 AM
Last Post: Mahgue
  how to update mobian over tor vusra 13 7,196 07-09-2023, 08:57 PM
Last Post: vusra
  opensnitch outbound firewall now works on mobian vusra 2 1,969 07-09-2023, 01:37 AM
Last Post: vusra
  Using Nativefier on PP64 with Mobian paulcarton 0 666 07-05-2023, 03:57 AM
Last Post: paulcarton

Forum Jump:


Users browsing this thread: 1 Guest(s)