I got it to do something
I have been trying to get the any of the BSP images to boot on the SOEDGE. I made some discoveries along the way I thought I would share. I did not see these posted anywhere else so hopefully this will help someone else.

I could not use rkflashtool on linux. It would not detect the SOEDGE while in maskrom mode. I did not troubleshoot this very far, but I think it's because it USB PID is not what rkflashtool expects. Maybe there are some udev rules that could fix this.

I tried several combinations of drivers and software on Windows 10. I eventually got the BSP image to work with the usb A to A cable.

The Rockchip tools download links in the wiki no longer work at the time I tried them. I did find a version of AndroidTool (RKDevTool) elsewhere that works. The exact version was labeled AndroidTool_Release_v2.71.zip. I used the drivers from DriverAssistant v4.5. I used the links from the Firefly Core-1808-JD4 download page.

With this combination, Androidtool was able to detect the board and flash it with the BSP images in the wiki. If you flash the Factory Test Build by Gamiee and have the touchscreen attached to the baseboard, it will boot up with a splash screen and then load a simple touch interface.

Also, like other have stated, I was not able to get the serial console working. However, adb will work. If you keep AndroidTool open and leave the usb A to A cable plugged in. It will change the detected board status from maskrom to adb after the board boots up. I used the adb_tools.zip for Radxa. With a adb start-server and adb shell, I was greeted with a prompt that was clearly the SOEDGE running.

After reading about the SOEDGE on the forum, I consider this a win as I never thought I would see this thing run code.
Hello, all!

@HalideGlow - I managed to get mine to do something, too, using a similar method!  Huzzah!  Thanks for sharing your notes!

I used this USB A to A cable (https://smile.amazon.com/dp/B0B2KCKDFK?p...ct_details) with Windows 10 PC, a 16GB emmc, and drivers / AndroidTool from the Linux BSP on the wiki.  I loaded it with the "BSP Linux ver 1.1 Build from SDK" image, also from the wiki (it took a rather long time to boot, but eventually showed up as a ADB device).  The image doesn't seem to do all that much, but does have some board tests, demo apps, and a daemon to support the NPU, so thats pretty cool.

Does anyone know the source of the Linux BSP from the wiki?  It might be good to
  1) update it
  2) remove the repo history so the download is a _lot_ smaller

Keep hacking, y'all!  Looks like there is hope for this platform yet!  :-)
Any update?

Forum Jump:

Users browsing this thread: 1 Guest(s)