6/22 run of PBPs - is reimaging eMMC with new OS possible still?
#21
(08-30-2022, 06:53 PM)wdt Wrote: YES, use tune2fs (-U) to change UUID to what it is looking for
man tune2fs

How do I change the UUID from initramfs/Busybox? Fsck is missing from Kali's Busybox configuration. I use Tow-Boot.

fstab is empty. tried to unlock root using cryptroot-unlock, root directory is empty.
  Reply
#22
You don't seem to understand, change UUID of filesystem to match initrd
(from a SD card boot OR emmc in adapter)
OR
make a new initrd
initrd is a gzipped cpio
some useful commands
zcat $1 | cpio --extract --verbose --quiet --list
echo "========================================================================"
zcat $1 | cpio --extract --verbose --quiet --to-stdout init

these from lsinitrd, but what you want to do is expand it to a temp directory,
that contains ONLY expanded contents, edit and then repack
  Reply
#23
I just wanted to add that I've been flashing a LOT of images over the last few days on a brand new Pinebook Pro (the newer re-designed model, which also doesn't appear to have a functional eMMC-disable switch) and I've found that pretty much every image I flash using macOS will refuse to boot with flashing power light (kernel panic), with the sole exception of Armbian (which is much smaller than all the other images, which is what I imagine the difference is.)

However, booting into Armbian and flashing with `sudo dd if=/path/to/*.img of=/dev/mmcblk* bs=1M status=progress` has worked very consistently. Loading all of the WiFi firmware after the fact is a pain and the Debian install script requires a lot of modifications to work, but ultimately I've ended with an encrypted Debian installation on my eMMC with functional sleep and WiFi loading up with Tow-Boot.
  Reply
#24
(08-20-2022, 02:44 PM)elitegamercody Wrote: Hi,

I have flashed multiple OS images available from the wiki (besides Manjaro) to the eMMC but consistently get stuck at the Manjaro logo/boot screen without getting to set up the prebuilt armbian, or DietPi, or Kali, but have been hesitant to overwrite the boot partition on the eMMC itself due to the news regarding the bootloader.

Is it possible to install anything but Manjaro on the new runs of the PBP now?

(08-22-2022, 02:16 AM)KC9UDX Wrote: It should be.  But most of the official images that worked are just not available anymore.  Unless you can find a copy of one of those, you may have to cook your own.

What is this news regarding the bootloader?
Same here!  I had absolutely no difficulty with booting from SD on my first early production (2021) Pro, but this one is acting about a "proprietary" as a Mac!  Using Baleenttcher to flash Armbian_22.05.1_Pinebook-pro_jammy_edge_5.18.0_xfce_desktop.img.xz, I get a perfect, uncompressed copy on the SD card.  But when I try to boot from the card, all I get is a totally blank screen and a slowly blinking green power light. I can even remove the card, hot, and the Pinebook pro will immediately boot Manjaro, so t's fairly obvious that their Uboot is proprietary as hell.

While I have long Linux experience (going back to Yggdrasil), I make no claims to being a developer or much more than a F77 and C patch programmer.  But while I find Manjaro reliable enough, I have never been able to stand KDE, ever since its beginning, considering it bloatware.  All that I, and apparently other users as well, am asking for is a simple uboot or towboot file with simple instructions about how to flash it.  This really is the Achilles heel of the Pinebook Pro and, for that mater, the entire Pine64 program, and it's a shame.
 while(!(succeed=try()));
  Reply
#25
I came to the same conclusion about the U-Boot that comes with the new Manjaru. I could not boot anything but Manjaru until I got rid of it. However I didn't actually isolate it as the problem.

I wonder if the U-boot that comes with the latest NetBSD images will boot Linux; because it's pretty awesome.
:wq



[ SRA accepts you ]
  Reply
#26
Well there is ,,, uboot-pinebookpro-bsp,,,, the 3 files are copied to /boot
and then you are supposed to use the dd commands to get them into the 1st 16M
This is an offshoot from mrfixit's version
  Reply
#27
Hi,

After multiple renamings of the UUID of armbian_root, I still don't understand what's going on.

Upon boot into the eMMC I reach the "Begin: Running /scripts/local-block ... done." loop.

I have renamed the UUID of the eMMC root partition to fit what was in fstab, but then get ALERT! UUID=the_uuid_of_the_armbian_root_partition_on_the_eMMC_card does not exist, which is not true.

I don't understand why this is so hard! I even have a RESUME=UUID=the_uuid_of_the_armbian_root_partition_on_the_eMMC_card in the initramfs-tools conf.d.

This just doesn't make sense - are pinebook pros unable to read UUIDs properly?

                       

Can someone help? Btw WDT temp2fs is not usually in PATH you have to use /sbin/temp2fs.

Also WDT please be mindful that a lot of people don't even have a bootable system or are able to boot but not enter their root partition, so they might be in a busybox/initramfs shell instead of a full Linux shell
  Reply
#28
It is quite important that you have a bootable SD, when ALL other media are removed/disabled
OR a emmc carrier
tune2fs, your typo made a bit confused, even tho permissions are 755 it is sort of a root operation, so /sbin
maybe it is the quotes ("), it is not clear to me where they are required/mandatory
  Reply
#29
(10-04-2022, 09:31 AM)wdt Wrote: It is quite important that you have a bootable SD, when ALL other media are removed/disabled
OR a emmc carrier
tune2fs, your typo made a bit confused, even tho permissions are 755 it is sort of a root operation, so /sbin
maybe it is the quotes ("), it is not clear to me where they are required/mandatory

I still don’t understand why, even after changing the UUID of the root partition to the one that matches my fstab, I am booting but unable to find root on the installation. Have you experienced this issue? I have installed tow-boot, I do not think I would need a new initrd if I have changed the UUID of the root partition to align with the current initrd.
  Reply
#30
>Have you experienced this issue?
Yes, not with pbp, but also an initrd that could not find root
I never solved it, it might be the very limited shell program in the initrd
I did pull apart and rebuild that initrd 5 or 6 times, spent a few hours googling
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Fix for Armbian not booting on PBP from eMMC agreenbhm 4 895 11-07-2022, 05:43 PM
Last Post: igorp
  newer ""emmc-installer" images (manjaro xfce) magistral 1 277 10-10-2022, 06:22 AM
Last Post: maxjrh
  Debian emmc installer db579 6 800 08-23-2022, 06:13 AM
Last Post: db579
  what is the magic dd incantation to copy the system from the sd card to the emmc? geokon 18 1,994 08-18-2022, 11:26 PM
Last Post: calinb
  Fresh Manjaro does not boot from eMMC pentamassiv 7 2,196 08-18-2022, 11:47 AM
Last Post: Bemo
Big Grin PinephonePro can't Flashing to the eMMC ricardo 1 423 07-31-2022, 04:04 PM
Last Post: wpeckham
  PBP won’t boot from eMMC after Debian update / Tow-Boot installer won’t boot from SD Pino64 21 4,127 05-12-2022, 05:00 AM
Last Post: Pino64
  Broken eMMC boot annahellrothsparent 3 1,030 04-28-2022, 07:31 AM
Last Post: tophneal
  Installing debian on pinebook pro (deb installer/emmc) ljones 14 6,087 02-08-2022, 02:47 AM
Last Post: Humid Stylus
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 0 853 01-10-2022, 03:58 PM
Last Post: zackw

Forum Jump:


Users browsing this thread: 1 Guest(s)