Pine64+ 1GB Ethernet Port spec
#11
Yea, looks like my unit has the same chipset.
  Reply
#12
(08-18-2016, 06:27 PM)woogerboy21 Wrote: The driver being loaded by ubuntu states the following:
[   14.565211] RTL871X: module init start
[   14.575894] RTL871X: rtl8723bs v4.3.16_13854.20150410_BTCOEX20150119-5844
[   14.589926] RTL871X: build time: Jul 16 2016 11:00:09
[   14.602062] RTL871X: rtl8723bs BT-Coex version = BTCOEX20150119-5844
[   14.749480] RTL871X: module init ret=0

But I'll have to take the case its in apart and see if the chips model matches yours.  @MarkHaysHarris777 Did you purchase your's from the store in the more recent months?


I've a similar output on debian, BUT that is the module/driver for the wifi, not the ethernet!! (which is a RTL8723BS chip on my pine64). On an early kickstarter board. 
Code:
[   12.958692] RTL871X: module init start
[   12.968042] RTL871X: rtl8723bs v4.3.16_13854.20150410_BTCOEX20150119-5844
[   12.980728] RTL871X: build time: May 26 2016 18:35:23
[   12.991474] RTL871X: rtl8723bs BT-Coex version = BTCOEX20150119-5844
[   13.161934] RTL871X: module init ret=0


The only ethernet specific lines I can place atm are these:
Code:
[ 1650.374748] libphy: 1c30000.eth: probed
[ 1650.379157] sunxi-gmac 1c30000.eth eth0: eth0: PHY ID 001cc915 at 0 IRQ poll (1c30000.eth-0:00)
[ 1656.281411] libphy: 1c30000.eth-0:00 - Link is Up - 1000/Full
  Reply
#13
(08-19-2016, 09:07 PM)pfeerick Wrote: I've a similar output on debian, BUT that is the module/driver for the wifi, not the ethernet!! (which is a RTL8723BS chip on my pine64). On an early kickstarter board. 

But I don't have a wifi module with my unit. Unless your telling me that the actual wifi adapter is built onto the pine64 board? But I don't think that is the case.

So does the 2GB model have a different network adapter? And is there confirmed success with network speeds of 1Gbe on the model?
  Reply
#14
(08-19-2016, 11:20 PM)woogerboy21 Wrote:
(08-19-2016, 09:07 PM)pfeerick Wrote: I've a similar output on debian, BUT that is the module/driver for the wifi, not the ethernet!! (which is a RTL8723BS chip on my pine64). On an early kickstarter board. 

But I don't have a wifi module with my unit.  Unless your telling me that the actual wifi adapter is built onto the pine64 board?  But I don't think that is the case.

So does the 2GB model have a different network adapter?  And is there confirmed success with network speeds of 1Gbe on the model?

So you don't have a module plugged in near the 2 USB ports (where it says Wifi-BT), with a wire coming off of it? If you don't have a module plugged in there, then no, no wireless.  Regardless of that, the default configuration is to try to load the wifi if present (and load the binary blobs it needs, etc) - as per /etc/modules-load.d/pine64-wifi.conf. So if you have the wifi/bt module and remove it, you will get the same log message in dmesg, until you comment out "8723bs" in that file, or delete it... but there is no reason to do so. 

As per tllim's reply earlier, both the 1G and 2G pine64+ boards have to same chip, which supports GbE (the 512MB pine64 is the only non-GbE board at present). However, as per the ongoing discussion in another thread, there seem to be issues with some network configurations. Where this is a hardware conflict with the pine64, or a configuration problem of some sort is yet to be determined. I have no issues with GbE-like speeds, so can't really help on that front. However, since it seems like GbE isn't working for you, make sure you vote in the poll (vote, and post your setup details there) to help better understand what could be the source of the problem.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Ethernet port down afert 1 day jeda 0 180 11-12-2022, 06:48 AM
Last Post: jeda
  Ethernet --> Causing boot loop podtofs 3 4,396 05-16-2017, 03:41 AM
Last Post: m17
  GbE Ethernet Port Issue Data Gathering Statistics Intel MarkHaysHarris777 19 20,263 01-17-2017, 01:17 AM
Last Post: DrunkTank
  What will it take to get the Ethernet port working? clarkss12 10 13,196 10-17-2016, 03:42 PM
Last Post: waldo
  Ethernet Slow Download Ascotg 89 88,875 09-08-2016, 01:50 PM
Last Post: MarkHaysHarris777
Question no permanent MAC address? need it to give Pine64 a reserved IP. faddah 14 18,906 08-24-2016, 03:25 PM
Last Post: MarkHaysHarris777
  If you have had difficulty with the GbE ethernet please take the poll MarkHaysHarris777 0 2,010 08-17-2016, 05:44 PM
Last Post: MarkHaysHarris777
  Ethernet works on Arch Linux. Nothing elese pfunk237 4 5,026 07-23-2016, 03:07 PM
Last Post: SuperArmySoldiers

Forum Jump:


Users browsing this thread: 1 Guest(s)