Lost my second display
#1
Hi,
Just updated (Shipped Manjaro, Firefox, etc.) and now my second display is not seen in display configuration and does not work anymore. It was working and had been for months. Set up is through the pbp docking station. Was working with HDMI (except no sound), now does not work through HDMI or serial cable. Anyone know how i can get this working again? Display configuration settings are totally greyed out as if there is only a laptop screen.

Like i said this was working literally 15 minutes ago before i did the update (that came out on 5/31/2022 i believe).
I have rebooted and plugged and unplugged and any simple things i could think of.

Thanks in advance for any ideas-
  Reply
#2
I don't currently use manjaro at the moment but I did in the past, here's what I think happened.

Manjaro uses a patched kernel for the pinebook pro in order to get DP over USB C working, this is the protocol which allows for the dock to work (even if the dock has hdmi instead of display port).

This means that the new kernel is probably missing the patch.
You can try looking in you package cache for pacman if you still have the old kernel laying around
(the cache should be at /var/cache/pacman if memory serves me right).

You should also look at which kernel you have installed exactly.
Run 
Code:
pacman -Qq | grep linux
If you see something like linux-pinebookpro, then you are using the pinebook pro specific kernel (this may also be called linux-pbp or similar).
If the installed package is just "linux" (followed by a version) then try looking for a pinebook pro specific kernel in the manjaro repository.

Hope that helps,
User
  Reply
#3
I am running the stock linux that came with the device.
Here is the output of the command:
archlinux-appstream-data
archlinux-keyring
archlinuxarm-keyring
linux
linux-api-headers
linux-firmware
linux-firmware-whence
util-linux
util-linux-libs
I expect you are right, i must be mising the patch to make it work now.
  Reply
#4
(06-04-2022, 09:20 AM)WEF Wrote: I am running the stock linux that came with the device.
Here is the output of the command:
linux

Right so that is "upstream" linux package. The "linux-pinebookpro" package is avaible in manjaro's core repo but it is an older version.
I believe the main manjaro linux kernel (the one you have) SHOULD work with your external display.

Check the pacman cache for an older version.

Otherwise, this repo: https://pacman.kiljan.org/archlinuxarm-pbp/os/aarch64/ Contains linux-manjaro-5.18.1-3 which should work with e-DP1.
  Reply
#5
(06-04-2022, 09:32 AM)user18130814200115 Wrote:
(06-04-2022, 09:20 AM)WEF Wrote: I am running the stock linux that came with the device.
Here is the output of the command:
linux

Right so that is "upstream" linux package. The "linux-pinebookpro" package is avaible in manjaro's core repo but it is an older version.
I believe the main manjaro linux kernel (the one you have) SHOULD work with your external display.

Check the pacman cache for an older version.

Otherwise, this repo: https://pacman.kiljan.org/archlinuxarm-pbp/os/aarch64/zameenContains linux-manjaro-5.18.1-3 which should work with e-DP1.

Yes I also used the same repo you mentioned and it has worked for me, I hope it will also work for him too. I was also searching for it and then found it in some other forum here.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Issues with External Display After Recent Update reundo 0 622 11-18-2021, 06:37 PM
Last Post: reundo
  No Display on PBP PitCritter 2 1,125 09-04-2021, 12:05 AM
Last Post: lot378
  Pinebook Pro - Display cable broken? snokis 0 823 08-17-2021, 11:30 AM
Last Post: snokis
  pinebook pro dock display out mamboman777 0 890 07-29-2021, 10:41 AM
Last Post: mamboman777
  USB C dock with internal display mirrored to projector and one extended display jbrock 4 1,156 07-19-2021, 04:00 PM
Last Post: jbrock
  [split] U-Boot with NVMe support, keyboard & display working as400 83 50,671 01-27-2021, 12:48 AM
Last Post: as400
  No keyboard & trackpad leads to no display. RMA from the US. Free parts in Seattle BitterPine 4 4,661 12-30-2020, 06:14 AM
Last Post: BetteHoward
Exclamation Seemingly lost power permanently now /cry jimsurvak 2 2,073 11-16-2020, 06:22 PM
Last Post: jimsurvak
Shocked flickering vignette display? plarkinjr 4 3,575 07-06-2020, 04:16 PM
Last Post: Alstroplane
  Garbled Video Display With Multiple Operating Systems rbma 5 4,877 06-29-2020, 07:19 PM
Last Post: rbma

Forum Jump:


Users browsing this thread: 1 Guest(s)