PinePhone Pro working on Lapdock using Arch Plasma
Just wanted to  add some information  for those that are looking to  delve into the  phone lapdock  realm.   As many have asked about  does it work for PinePhone Pro.  and had many mixed reports of  usb-c docks  work and not work and Nexdock and Uperfect lapdock owners asking does it work and seeing it mostly not work  etc...  

the following is the current state i have working....  noting that things are fluid with rolling distro's so  it may break for a while in the future.... but usually it only gets better....

I am using the DanctNix  arch plasma for pinephone pro  then updated to the latest... 
data from  information panel on plasma:

Operating System: Arch Linux ARM
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Kernel Version: 5.17.6-1-danctnix
OS-Type: 64
Processor: 4 × ARM Cortex-A53, 2 × ARM Cortex-A72
Memory: 3.8 GiB

for the lapdock i am using the Uperfect X lapdock  its practically the nexdock 360 minus one usbc port. the cables that came with the lapdock are from ugreen.

and the biggest thing is that cable orientation matters....  so once i  got the cables at each end in an orientation that worked. i added a simple dab of nail polish.  as to reduce future setup frustrations...

I also tried a Satechi brand short cable and it worked as well but only when the satechi logo is facing "out/towards the user"...

also i found that if things were not looking right after plugging in the cables  pressing the power button quickly to lock the phone, then entering back in via the login screen  usually fixed things....   for the most part i did not have to play with screen display settings just let plasma work it out..

like all things on the pinephone pro  its beta... 

I will update this post with images soon   also  this setup works even when the Pine Keyboard is attached to the PPP...   but power drain is still a thing so until charging works better   it appears  even if plugged int  still drains down ever slowly 10-20% per hour whilst using it.....

regarding the  default image that comes with the  PPP  as it is Manjaro KDE...   even in its  most up to date form as in a good old pacman -Syu ...   using the default package stream etc...  it  does not work  for me in  this  phone lapdock setup.....    thats not to say  that if you switch to testing repo  or even get a different beta image from the manjaro forums  that it might work.....  im just  not into that....  i think the whole walled garden thing of manjaro at least in regards to pinephone pro simply slows down and over complicates  the   what works on PPP during its very beta existence.....   as for Phosh i have had no luck with it so far in relation to Lapdock setup...  though i remain hopefull as i would like to use both to see the merits of both via my setup....

before playing with other distro's  id advise to get a working setup as a base line so when you delve into other Os's  then you at least know that your setup works... even though that is easier said then done.....  Idea

Attached Files Thumbnail(s)
Just a further observation. in relation to once you get it working then you shutdown then want to set it back up again... i found it can be a bit of an art .... essentially if i run into any issue getting the lapdock to detect the signal / send one to the pinphone.... i usually find it comes down to having the phone at the lock screen "number pad" then i plug the cable in enter the lock screen code and wait to see if all is good. if it is not, then i change the cable orientation and rinse repeat usually within 2-3 tries ...

in reading through the pinebook forum for those that used external monitors it seems to be a thing that is experienced... from what i can gather, each device is setting which lane it is setting usb on and alt DP on and that can be the opposite between the devices, hence the changing the orientation of the cable until they are using the same lane etc.... it gets a little confusing because usb-c isnt meant to have superposition issues but the reality is different....

KDE could also do a better job on its side "how it detects and reacts to external monitor input" especially after more then one plugin event during the same session (as would happen when working out cable orientation) but that usually isn't the problem but would be "icing on the cake"

As for why the drivers do not do a better job of detecting and changing i do not know.... maybe someone with the skills can come up with a widget that allows for a software switch for alt dp orientation for the output port....
to also make things a little easier, for those using docks /  SSH or lapdocks  if you find the device goes into suspend mode while its attached to power....  there is a widget  that might work for you.

sourced from

I happened to long-press the desktop, and "Add Widgets" appeared
I pressed this, and tried adding the "Display Configuration" widget.
It had something called "Enable Presentation Mode", which I tried.

if instead your looking to change the timings then JasonG-FR in a post in the above mentioned thread explains what to change in the ~/.config/powermanagementprofilesrc file...

Attached Files Thumbnail(s)
Thanks for the great information.

I have the same lapdock, Uperfect X. I tried the latest DanctNix arch plasma and after trying several cable orientations, I confirmed the video output.

Unfortunately, I cannot get keyboard and mouse input. Do you get HID input?
Hi, I tried different cable and I got keyboard and touch-pad inputs correctly. It's nice!.

And I have two other lapdocks, HP's (optional device for Windows 10 mobile device,Elite x3) and Mirabook.
Mirabook dose not work, but HP's lapdock also works fine.
Only problem is tapping on the touch pad is not recognized as left button.
(05-27-2022, 02:05 AM)u-kidjp Wrote: Hi, I tried different cable and I got keyboard and touch-pad inputs correctly. It's nice!.

And I have two other lapdocks, HP's (optional device for Windows 10 mobile device,Elite x3) and Mirabook.
Mirabook dose not work, but HP's lapdock also works fine.
Only problem is tapping on the touch pad is not recognized as left button.

 Yea keyboard works... but it really comes down to  doing a magic dance with cables and orientations....    essentially  many protocols on usb lanes   and its a bit of a lottery  on how they land.... a bit like musical chairs....  i hope someone with dev skills might put a widget together to help in the future...

I turn the touch pad off  and use a logitech anywhere mouse...     once i can get waydroid working better   as in  gpu support without  high idle cpu usage etc...  then  it will be a  good  phone and  desktop like setup....   the waydroid part is only for  things like banking apps and things that simply have no linux good equivalent...

but overall  its getting closer to  the  One device to rule them all  scenario id like to see....

Possibly Related Threads…
Thread Author Replies Views Last Post
Question Pinephone Pro for a Debian user? primesocial 2 183 04-15-2024, 03:01 AM
Last Post: zetabeta
  PinePhone Pro silver lining, it’s fast, real damn fast ashoka232 0 498 03-20-2024, 01:45 AM
Last Post: ashoka232
  PinePhone Pro Black Screen CrimsenRaven 2 383 03-16-2024, 11:40 AM
Last Post: tmoj
  PinePhone Pro Review tmoj 2 669 03-14-2024, 07:14 AM
Last Post: tmoj
  Can't boot Pinephone Pro into Factory Test Build for Hardware Checking jydoxcen 3 729 02-17-2024, 04:04 AM
Last Post: fxc
Question Phone call with the pinephone pro dfs 5 4,250 02-10-2024, 09:54 PM
Last Post: Kevin Kofler
  Average Joe review of Pinephone Pro (March 2023) alaraajavamma 6 10,313 01-06-2024, 11:32 AM
Last Post: mikehenson
Question T-Mobile and Pinephone Pro in the US jydoxcen 4 847 01-02-2024, 09:08 AM
Last Post: mikehenson
  Pinephone Pro Screen Protector jydoxcen 11 1,441 12-21-2023, 07:58 AM
Last Post: zetabeta
  Pinephone Pro does not start with RE button pressed c0ssan 10 5,389 09-28-2023, 09:21 AM
Last Post: R0bbi3Mack

Forum Jump:

Users browsing this thread: 1 Guest(s)