New RockPro64 Power Up Problem
#1
Greetings
Firstly I should explain I have decades of experience building, modding and repairing x86, but almost none with non-x86 so though I've read quite a bit, I have yet to see deep fundamentals that help me troubleshoot my problem.

Problem - Upon PSU Power On the RockPro's green LED and (a bit oddly) both ethernet LEDs light up with no ethernet cable connected.  The RockPro power switch does zero, no matter what is connected or disconnected down to power cable.  The White LED never lights and the CPU Fan never spins.

Possible issues - I'm using a gutted CoolGear dual 3.5" eSATA drive bay enclsurtewhich apparently has a PSU capable of 40-50 watts, so well above the 3A @ 12V required.  Not only did I check docs for proper polarity (+ on center, - on barrel, right?) but no LEDs should light up if polarity is a problem.

I bought the board, hs/fan,  and PCIe > SATA (not yet mounted) from respectech on ebay.  The company seems fine but have others had any difficulties with DOA replacement?

Am I correct in assuming that the board should at least attempt to power up with nothing connected but power? What can I research and check?

I'm a rank newb at SOC/SBC so any help is greatly appreciated.  I'm completely committed to exploring Pine 64 RockPro64
  Reply
#2
TLDR/BOTTOM LINE --- Can I assume that with no other connection than proper power the RockPr64 should power up from the default "power available" state to light up the White LED (Power On) and spin the fan? (No storage of any kind connected} I don't expect it to boot, obviously, but does it indicate in any way it has tried to start?

Thank you in advance for comments
  Reply
#3
(04-09-2022, 12:37 PM)enorbet2 Wrote: Am I correct in assuming that the board should at least attempt to power up with nothing connected but power? What can I research and check?

Your old x86 hardware instincts are serving you well here. In fact I was going to suggest removing everything and trying the board by itself.

Yes it should power up, but without a serial cable, you have no way of really knowing what's going on. Lights are inconsistent between manufacturers and even software implementations. The fan may or may not start to turn.

Unlike x86, on SBC there is no standard hardware interface (like BIOS on mobo). Everything low level is in kernel, bootloader, device tree, etc. Which is totally different from x86 you are used to.

In SBC world, good power and reliable brand name SD card from a reputable source (which do not include eBay nor even Amazon nowadays) are the most common problems. More basics here:

https://docs.armbian.com/User-Guide_Basi...eshooting/

Burn a good copy of a system image (I recommend Armbian) to a good SD card, using exactly the methods proposed there is probably the easiest way. It will either work or it won't. Beyond that, you probably need a serial cable to know more (which you should have anyway (and probably more than one), if you are going to start playing with SBC).

Good luck, and let us know how it goes.
  Reply
#4
(04-30-2022, 06:01 PM)TRS-80 Wrote:
(04-09-2022, 12:37 PM)enorbet2 Wrote: Am I correct in assuming that the board should at least attempt to power up with nothing connected but power? What can I research and check?

Good luck, and let us know how it goes.

Thank you TRS-80, that was very helpful.  As I stated I'm quite unfamiliar with ARM so I took n o chqances, especially since Ameridroid, the company from which I bought is seemed very solid and perfectly willing to RMA the board should it be DOA.    I'm repurposing an old eSATA dual bay  external standalone enclosure as it has adequate size is ruggedly built and has a sizable fan as well as a hard-switched AT type PSU providing both 12v and 5v at roughly 50-60 watts.  Being unsure of ARM requirements and the actual specs on the PSU (almost no info on it) I bought the recommended power brick (5A, so I could use it generally on other projects) as well as an eMMC and a MicroSD.  After flashing they both booted just fine! fan spins, LEDs light up, all is well.

In fact,  being a 20+ years Slackware devotee I even flashed SPl (to boot from SATA) and installed full Aarch-Slackware-Current.  I'm still learning the differences but I am making some progress.  I'm trying to get a web-based login going something like Cockpit or Webmin... wish me luck.  Initially I wanted to enable dual boot so I could choose between different distros at boot time but apparently some bug required disabling USB in Uboot, so a SDerial Console is required and I haven't messed with those since DOS Laplink days so I'm holding off on that and just using the eMMC for alternates.

I'm very impressed with RockPro64 performance and this is a very fun learning experience.  Thanks again for your considered and helpful response.

BTW the onboard AT PSU works a treat powering the board, the 80mm case fan, 1 SSD and 2 x 2TB Seagate spinners in RAID 1. Even with the tiny Pine hs/fan on CPU, the sheer air volume moving inside that case keeps the CPU below 46C. It runs great!
  Reply
#5
Yeah, a PC power supply is surely overkill (and less efficient) but if you have them laying around...  I have had several SBCs since years now, and I progressed from using high efficiency Mean Well power bricks, to more recently using (still high efficiency) Mean Well DIN rail mounted power supplies to mount SBCs (mainly to get them out of the way, but also so far they are actually cheaper, and much higher MTBF).

If you are old Slackware guy, you probably enjoy tinkering with the lower level stuff.  Personally, I want something that 'just works' (and I am Debian guy) so I use Armbian.  And they can always use more guys like you who know what they are doing with the low level stuff.  OTOH I think there is at least one person trying to get a Slackware based distro going on SBC, I am sure you could find them with a forum search here.

Next time you get stuck on something, you may find the answer browsing Armbian source code / docs / forum in fact. I'm pretty sure that's how I originally found them, there are tons of great info there going back years. PostMarketOS also has a lot of good documentation, but they are more focused on phones (Armbian is more about SBCs). PMOS is also Alpine based (which is a bit strange, to me anyway).

Glad to hear you are having fun. Smile These are such cool little devices.
  Reply
#6
Hello again TRS-80
Speaking of which while I never owned a "Trash-80", my very first PC was a Tandy 8086 with an ancient WD IDE 20MB hard drive on an ISA card and one of my favorite memories is the day I removed it while starting up and was messing with it when to my amazement the CGA screen lit up and there was...a.. desktop! in ROM!! Visions of a subconscious filled my imagination LOL

Anyway, I'm awaiting delivery on a high quality nibbler to finish out my case shroud, but as it is my temps drop by almost 10C with the case shroud installed. It's a tornado in there. So far I've played with 7 distros, 2 different (Leap and Tumbleweed) from OpenSuse, 2 diffewrent Armbian and OpenMediaVault (which is also Armbian IIRC), Manjaro, NEMS and NetBSD. The only one that supported all my hardware was Aarch Slackware64 probably due to the 5.17.4 kernel especially since I'm using BTRFS on my RAID and those modules need constant updating as it is being developed so aggressively. 4X kernels just don't cut it. Thankfully I learned how to apt and zypper search and force an update so I could get newer kernels on the others. They don't all still work audio but that's a minor issue.

Brent, one of the Aarch Slackware devs rebuilt the SPI image at my behest to enable USB very early and now everything boots and I can even select multiboot items whether extlinux.conf, UBoot, or Grub. I like OpenMediaVault's web admin but I have yet to identify what it is, and OpenSuse's Cockpit is quite close so I'm hoping to repackage all of the rpms to slackpackages so I can install it on Aarch Slackware. In that same form I'm, learning what is required to build packages from source on ARM because as badly as Suse's conky package runs (I think it leaves out important dependencies like luajit or imblib2) it is still great to be able to monitor exactly what I want to see, no more, no less so hopefully I can improve it in Slack.

At the same time I'm working to understand NetBSD better 'cuz ZFS is terrific! That said BTRFS is rapidly evolving so maybe it will catch up.

Best wishes, mate and just FTR Slackware is not maintenance intensive. In fact, it can be sort of boring it is so stable and solid but it does exactly what it's told and nothing behind my back. I like that.
  Reply
#7
(05-15-2022, 03:25 PM)enorbet2 Wrote: Speaking of which while I never owned a "Trash-80", my very first PC was a Tandy 8086 with an ancient WD IDE 20MB hard drive on an ISA card and one of my favorite memories is the day I removed it while starting up and was messing with it when to my amazement the CGA screen lit up and there was...a.. desktop!  in ROM!!  Visions of a subconscious filled my imagination LOL

I, too, have many fond memories of writing Mad Libs in BASIC with my brother and friends, as well as old dial up BBS pre-Internet days, etc.  I used a TRS-80 at school, but we had a Tandy 1000EX at home, actually.  Due to 'life', I veered away from my natural interests in tech for a long time, but the last several years I have been making up for that now.

(05-15-2022, 03:25 PM)enorbet2 Wrote: So far I've played with 7 distros, 2 different (Leap and Tumbleweed) from OpenSuse, 2 diffewrent Armbian and OpenMediaVault (which is also Armbian IIRC), Manjaro, NEMS and NetBSD.  The only one that supported all my hardware was Aarch Slackware64 probably due to the 5.17.4 kernel especially since I'm using BTRFS on my RAID and those modules need constant updating as it is being developed so aggressively.

Wow, you have been busy!  Personally, my interests lie more in things 'just working' so I can self-host my own services (to stay away from 'The Cloud' and predatory big tech).

And yes, OMV is in fact derived from Armbian.  There are some other distros which are, as well.  Armbian provides a nice reliable base for things like this.

All these distros need constant upgrading, and therein lie the rub.  Armbian have done an amazing job for years now supporting over 100 boards, but had to scale back more recently as they are after all only a few guys working on nights and weekends.  In fact I have always been amazed they were able to do so much for so long.  So at some point I started helping them out around the forums, docs, etc. a bit (as I am sure no kernel hacker).

(05-15-2022, 03:25 PM)enorbet2 Wrote: In that same form I'm, learning what is required to build packages from source on ARM because as badly as Suse's conky package runs (I think it leaves out important dependencies like luajit or imblib2) it is still great to be able to monitor exactly what I want to see, no more, no less so hopefully I can improve it in Slack.

Armbian does a lot of cross-compilation, but they are only building kernel and u-boot, etc.  Almost all userspace packages simply come from upstream Debian (or Ubuntu).  But maybe there is something there in the CI pipeline which might be useful for you.

(05-15-2022, 03:25 PM)enorbet2 Wrote: At the same time I'm working to understand NetBSD better 'cuz ZFS is terrific!  That said BTRFS is rapidly evolving so maybe it will catch up.

Using BSD is no longer necessary to use ZFS (that used to be recommended, but that was years ago now).  In fact, The ZFS on Linux project (now OpenZFS) received a tremendous amount of development effort since years now to get ZFS running well on Linux.

I am running ZFS on ROCKPro64, with a standard PCIe to SATA adapter and it works well.  All you really need is 64-bit Linux.  Even those high RAM recommendations are not really usually necessary (well, depending).

I actually had a lengthy debate with a very knowledgeable guy (tkaiser) about ZFS and BTRFS a while back, it's long but maybe you find some of it interesting: Why I prefer ZFS over btrfs

(05-15-2022, 03:25 PM)enorbet2 Wrote: Best wishes, mate

Same to you!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  RockPro64 ethernet issues: DMA engine initialization failed slowcamp 1 1,767 04-26-2021, 06:03 AM
Last Post: slowcamp
  First Boot HDMI/USB problem reefer 1 3,698 11-18-2018, 10:32 PM
Last Post: tllim
  ethernet lan speed problem android fulltone 0 1,883 04-23-2018, 01:47 AM
Last Post: fulltone
  Boot problem AdamK 1 3,455 12-15-2016, 06:51 PM
Last Post: tllim
  Image Burn Issue and Power Auto Off Issue Mohit B 3 4,109 08-02-2016, 09:35 AM
Last Post: MarkHaysHarris777
  Boot Up Problem - Red LED goes Out hay.barry 6 8,333 07-28-2016, 02:48 PM
Last Post: Ghost
  Problem with setting up SD Card Win10 montyflange 8 7,504 04-05-2016, 03:15 PM
Last Post: jbritt

Forum Jump:


Users browsing this thread: 1 Guest(s)