wwan0 (cellular data) ip configuration is POINTTOPOINT not BROADCAST
#1
Carrier: ATT prepaid (US)
APN: NXTGENPHONE

I use Settings -> Mobile Network screen and slide the switch icon to on. Makes a connection to my carrier but no Internet access (I can ping att.com but that's it).

ip link show wwan0
4: wwan0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1430 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/[65534]



"POINTTOPOINT" makes me think of a PPP connection; compare to my Wifi settings:

ip link show wlan0
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 02:ba:93:10:c9:af brd ff:ff:ff:ff:ff:ff


Is there a command (like an option to ip) that I can configure wwan0 as BROADCAST? Where in the NetworkManager startup sequence, or elsewhere in the postmarketOS networking configuration, would I be able to find/change the settings for wwan0?

Surely I'm not expected to make a PPP connection?

Thanks
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  No Application Data PMOS 21.12.1 Captain1ndustry 4 2,055 08-12-2022, 07:42 AM
Last Post: Gon
  Disable mobile data auto-enable on boot 64_Tesseract 3 965 08-11-2022, 02:48 AM
Last Post: 64_Tesseract
  Calls don't work on Softbank. Cellular data & SMS work. yasmi 1 938 03-24-2022, 04:10 AM
Last Post: yasmi
  Backup user data and settings kratz00 4 4,037 02-28-2021, 03:39 PM
Last Post: kuleszdl
  mobile data - always in use? someGermanGuy 13 11,707 04-03-2020, 02:32 PM
Last Post: janw

Forum Jump:


Users browsing this thread: 1 Guest(s)