WiFi dongle MediaTek mt7601u
#11
(07-04-2016, 12:46 PM)xalius Wrote: Hi, can you paste the output of 'dmesg'  after you loaded the module? Did you have to supply a firmware image for the stick to load on module insertion?

Dmesg output can be found here.

As per supplying firmware, I know that dkms (and all other driver sources, e.g. this) installs 'RT2870STA.dat' into '/etc/Wireless/RT2870STA/' but this seems to be only some kind of config file with plain text settings. There are also some binaries inside driver sources 'src/mcu/bin/' folder, such as 'MT7601.bin'. Previously, I had that bin file placed in '/lib/firmware' but deleted it and rebooted before getting `dmesg`output. It was there from previous tests but it didn't look like it was doing anything so I better removed it.

Other than that, there was no prompt or whatsoever to supply firmware. Again, I'm currently using the dkms package from PPA but I have once tried `rmmod` and `insmod` manually from built source and no firmware was asked for.
  Reply
#12
Mmmh, https://gist.github.com/tegila/497fd36bae7fd262a00b suggests that firmware has to be in /lib/firmware (see line 28)...
Come have a chat in the Pine A64 IRC channel >>
  Reply
#13
(07-04-2016, 03:04 PM)xalius Wrote: Mmmh, https://gist.github.com/tegila/497fd36bae7fd262a00b suggests that firmware has to be in /lib/firmware (see line 28)...

Thanks, I couldn't find this information anymore when I was looking for it while writing previous post.
Ok, I will try to place it there again and will update this reply with new dmesg tomorrow as I already removed display from the setup.

Edit:
I have actually saved some time to test it today. Here is the new dmesg log.
I think of particular interest is this line as it refers to usb port in which the dongle is:
Code:
rt2870: probe of 2-1:1.0 failed with error -1


I have tried googling around but there is little information about this. One post suggested to add something to uEnv.txt, but it didn't fix the issue after rebooting (still no interface and still same dmesg).
  Reply
#14
(07-04-2016, 03:38 PM)Beta_Ravener Wrote:
(07-04-2016, 03:04 PM)xalius Wrote: Mmmh, https://gist.github.com/tegila/497fd36bae7fd262a00b suggests that firmware has to be in /lib/firmware (see line 28)...

Thanks, I couldn't find this information anymore when I was looking for it while writing previous post.
Ok, I will try to place it there again and will update this reply with new dmesg tomorrow as I already removed display from the setup.

Edit:
I have actually saved some time to test it today. Here is the new dmesg log.
I think of particular interest is this line as it refers to usb port in which the dongle is:
Code:
rt2870: probe of 2-1:1.0 failed with error -1


I have tried googling around but there is little information about this. One post suggested to add something to uEnv.txt, but it didn't fix the issue after rebooting (still no interface and still same dmesg).

Followed this page and got this working
https://ubuntuforums.org/showthread.php?t=2300091
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Pre-Configure Wifi on Pine64 without Keyboard/mouse bortek 4 1,569 01-23-2017, 02:04 PM
Last Post: bortek
  Pine64+Ubuntu+Tvheadend+DVBT Dongle Shai 3 1,567 10-03-2016, 04:23 AM
Last Post: Shai
  WiFi PineA64 Pineapple Ghelorn 2 2,088 09-25-2016, 03:05 AM
Last Post: Ghelorn
Question Driver usb wifi dongle 8192eu Pander 8 2,874 07-16-2016, 04:03 PM
Last Post: CaptainZalo
  third party wifi rahlquist 3 792 04-27-2016, 02:39 PM
Last Post: baryluk

Forum Jump:


Users browsing this thread: 1 Guest(s)