Tow-Boot, a new U-Boot option for Pinephone Pro and other devices
#48
Since the title of this thread is “...and other devices”, I thought I’d describe my experience using Tow-Boot on my OG PP BE and seek advice for resolving a rather frustrating issue.

First: before I started using Tow-Boot, I had successfully installed Megi’s most recent multiboot image to the eMMC and Mobian to the microSD card. I also used that Mobian install to expand the btrfs partition of the multiboot image to make maximum possible use of the eMMC and I was able to access the different distros and OSes on the eMMC. Booting the PP from the eMMC required first turning the phone off and removing the microSD card. Obviously not ideal from a UX perspective - or from the risk of losing the microSD card.

Second: since following the instructions for installing Tow-Boot to the eMMC’s boot sector, I have not succeeded in getting Tow-Boot to boot the multiboot image on the eMMC.

I know Tow-Boot works because I can get it to boot its blue LED “Jumpdrive” equivalent mode and access the eMMC from a PC as if it was a USB device by holding the Up volume button as Tow-Boot starts. I can also get Tow-Boot to boot Mobian from the aqua LED microSD card mode by holding the Down volume button as Tow-Boot starts.

IIUC, holding neither volume button as Tow-Boot starts is supposed to boot from an image installed on the eMMC. However, in my case, if I don’t touch either volume button as Tow-Boot starts the LED goes from red to yellow and
- either switches back to a red LED which flashes 10 times before the PP turns off (if there is no microSD installed)
- or if the microSD card is installed, Mobian is booted from the microSD card after a short wait on the yellow LED.

The only way I have found to boot the multiboot image from the eMMC is to flash the multiboot image to a spare microSD card as well and get Tow-Boot to boot from that by holding the Down volume button, which then takes me to the familiar multiboot menu Megi created - familiar, except for now every available distro/OS is displayed twice:
once beneath an entry for images installed on the microSD card and
once beneath an entry for images installed on the eMMC (i.e. the multiboot image I had previously flashed to the eMMC before ever using Tow-Boot). I checked that booting any of those distros/OSes worked, both from the microSD card entries and from the eMMC entries displayed, and they did. Changes I had made to those on the eMMC before ever using Tow-Boot remained in place.

I decided to reflash everything:
- Tow-Boot to a spare microSD card in order to wipe and then reflash the eMMC’s boot sector with it
- use “Jumpdrive” equivalent mode to wipe the non-boot partitions of the eMMC and then reflash them with a freshly downloaded image of Megi’s multiboot
- Mobian to the original microSD card that I had it on

I repeated the steps I had on the first attempt with Tow-Boot (as described above) but received the same result.

Mobian’s Troubleshooting guide mentions that the U-boot sector of existing images on the microSD needs to be removed, however it also states that their images from the 03rd of April 2022 won’t include such a sector as a result of their policy on moving to Tow-Boot. The first Mobian image I was using in my first Tow-Boot attempt was a 10th of April 2022 image and in my second attempt I used the most recent 17th of April 2022 image so neither of those should have needed me to remove a U-boot sector in order to prevent the microSD from always dominating the boot choices.

I’m inclined to think that this is further ruled out as the source of my problem by the fact that Tow-Boot won’t boot from the eMMC even when there is no microSD card inserted.

The multiboot image is definitely still present on the eMMC as I was able to verify with lsblk and apply the same expansion to the btrfs partition from Mobian as before I’d ever used Tow-Boot.

I would be grateful for anyone’s suggestions that fix this issue!
  Reply


Messages In This Thread
RE: Tow-Boot, a new U-Boot option for Pinephone Pro and other devices - by 3460p - 04-20-2022, 11:33 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  bookworm vs trixie discussion for mobian in pinephone pro. zetabeta 16 2,891 04-28-2024, 01:52 AM
Last Post: diederik
  Connect external devices via USB martin@h4ck1ng.me 5 1,028 02-15-2024, 10:23 PM
Last Post: u-kidjp
Brick Recovery without Tow Boot b34ux 10 1,856 02-02-2024, 07:07 PM
Last Post: reky
  A Btrfs Image for Arch SXMO on the Pinephone Pro mburns 2 994 11-23-2023, 08:44 AM
Last Post: mburns
  Rhino Linux does not seem ready for the PinePhone Pro. mburns 2 1,105 11-23-2023, 08:39 AM
Last Post: mburns
  Megapixels on Mobian Bookworm on PinePhone Pro - Not Launching X0X0X0X0X0 1 815 11-07-2023, 09:44 AM
Last Post: mburns
  Seeking Contributors: Apache NuttX Real-Time Operating System for PinePhone Pro lupyuen 2 1,884 09-14-2023, 07:23 PM
Last Post: lupyuen
  What to do if your PinePhone Pro does not boot fxc 19 20,666 09-10-2023, 03:19 AM
Last Post: fxc
  Pinephone(pro) modem bug / shortcomings MadameMalady 2 2,584 06-19-2023, 03:40 PM
Last Post: MadameMalady
  Cannot update new PinePhone Pro bent 6 3,781 05-15-2023, 02:43 PM
Last Post: alaraajavamma

Forum Jump:


Users browsing this thread: 1 Guest(s)