DisplayPort Out question
#41
(03-20-2022, 11:42 AM)scoulber@protonmail.com Wrote: So I finally got some video out via one of my hubs!
But...
Only when I had the USB-C cable in a certain way. When I inverted the orientation of the cable into the PPP, the functionality went away. That was repeatable multiple times.

I am pretty sure I also read early on in one of these forums, that charging had a similar issue.
Now, I thought that USB-C should work right side up and upside down, equally. But this seems not to be the case.

Does this make sense to anyone, or am I off base?

Thanks

I should expand:
I was talking to one of the hardware guys at work, as we are moving to USB-C hubs for the Hotel stations, and he told me that when the peripheral devices, specifically, display devices were connected or disconnected from a plugged in hub, things got problematic, but if the peripheral devices stayed connected to the hub, and just the hub was connected / disconnected from the computer things were far more stable.. I got similar info from one of the hub manufacturers. This is what I was testing with a few different hubs, and finally got one of them to mostly work.

Glad you got it to work!

The USB-C cable orientation definitely matters.

Now, since I got the latest update to:

Manjaro KDE Plasma version 5.24.3
KDE Frameworks version 5.92.0
Qt version 5.15.3
Kernel version 5.16.16.1-MANJARO-ARM

the Desktop Mode screen turns white, and I can't access any regular programs.
If I drag from the top of the screen with the mouse, it brings up the quick settings but nothing else works.
So the latest update killed the working Desktop Mode for me.
  Reply
#42
With recent updates to Arch Linux ARM/Phosh running on the PPP desktop mode is working much better for me. 

PPP is driving a Lenovo m14t at 1920x1080 resolution via a single usb-c cable (and is also charging from the M14t with PD pass thru from a usb-c charger) with a lenovo  bluetooth keyboard and trackpoint. 

Feels like using a laptop or Raspberry Pi... lots of Linux desktop software just works.
  Reply
#43
No matter what I do with my PPP the screen output is black even though the phone detects it. I am using the old PPs convergance dock, does anyone know if its a dock type issue? dock works with the PP and a samsung phone.
  Reply
#44
After the last few updates to the PPP, mine hasn't displayed anything on the external monitor, using the old PP convergence dock, a J5Create dock, or a NexDock 360 lapdock. Incredibly disappointing. I'm not experienced enough to try installing other operating systems, so it sits in my closet. I check for and install updates hoping it will start working again.
  Reply
#45
(09-01-2022, 08:32 AM)frankt Wrote: After the last few updates to the PPP, mine hasn't displayed anything on the external monitor, using the old PP convergence dock, a J5Create dock, or a NexDock 360 lapdock. Incredibly disappointing. I'm not experienced enough to try installing other operating systems, so it sits in my closet. I check for and install updates hoping it will start working again.

Mine works on the nexdock 360 but you need to charge the phone from the nexdock then go to display settings, press on the nexdock monitor and then on refresh rate set it to 30 hz and apply settings, it will revert back to 60 and you will have video out and keyboard and touchpad.

If charging is not enabled keyboard and touchpad wont work
  Reply
#46
(09-02-2022, 02:49 PM)uzanto Wrote: Mine works on the nexdock 360 but you need to charge the phone from the nexdock then go to display settings, press on the nexdock monitor and then on refresh rate set it to 30 hz and apply settings, it will revert back to 60 and you will have video out and keyboard and touchpad.

If charging is not enabled keyboard and touchpad wont work

Got mine working with a satechi 7 ports USB-C hub on arch linux (danctnix) with phosh. Monitor, keyboard and mouse are all working (typing this from this combo now Smile ). Only thing that needs to be done is set the resolution to 1920x1080 to avoid seeing garbage on the right side of the screen.

The 4K monitor is connected through a KVM switch and I will lose the connection now and then when switching between my different PCs (work/private/pinephonepro).

If I lose the connection and manage to get re-connect I also lose all the settings I applied.
Anybody has a clue on how  to preserve the settings?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Battery Life is it possible?? Tech Question (sort of) scrwbigtek 4 1,105 05-11-2022, 06:01 AM
Last Post: danimations
Question Possibly dumb question For_lack_of_a_better_name 1 578 03-06-2022, 04:54 AM
Last Post: fxc

Forum Jump:


Users browsing this thread: 1 Guest(s)