Guide: Recovering from not being able to boot to eMMC or working sdcard
#1
(This guide assumes you've written a working Pinephone Pro image to an sdcard.)

Note: I own both a Pro and an older PostmarketOS edition Pinephone, both won't recognize USB-C power unless the cable is the "right way up" (this is with multiple Anker and Tripp-Lite high quality USB-C cables using the Pine64 power brick, a laptop and a desktop as a source). You may need to rotate the cable till you can determine which way is considered "up" for method A:

Method A. Boot to sdcard using the reset method:
1. Open the backplate and hold reset (pinhole top left) while inserting USB-C power.
2. Release reset after 4 seconds.
Note: If you hold reset till the sdcard boots it won't be able to see the eMMC.

Method B. Boot to sdcard using the power drain method:
1. Remove USB-C power and the battery.
2. Hold down the power button for 10 seconds, release for 3 seconds, hold down the power for 10 seconds, release the power button.
3. Re-insert the battery and follow steps from method A above.

Background:
Method A worked for me when Plasma Mobile was installed but after I wrote the Pro edition of Mobian-installer to the eMMC it bricked my phone. Through trial and error I discovered method B which worked 100% of the time where method A would always fail. It's an old trick I picked up flashing Android phones a long time ago, sometimes there's residual power hanging around that can prevent the chips from resetting properly. I performed a lot of tests (~20+) using method A vs B in different scenarios, orders and duplications to make sure it wasn't a fluke or something else that was allowing Method B to work over A.

Automatically booting to sdcard
Follow this guide: https://forum.pine64.org/showthread.php?tid=15879
Note: The dd command didn't work for me till I removed "count=4" and I pressed ctrl+c on the virtual keyboard about a minute in. That's extremely crude, no doubt there's a better way but that's what worked from me.

Just for reference (READ THE GUIDE FROM THE LINK FIRST) the command I used in Mobian (running on the sdcard) was:
sudo dd if=/dev/zero of=/dev/mmcblk2 bs=8k # Wait 1 minute, ctrl+c
  Reply
#2
Thanks for the effort, but this does not work.. I seemed to have bricked my by simply turning it on with a SD card w Mobian on it.. saw the splash screen 'resizing partition' since then only black screen, regardless of trying to do your options A or B, , with or without SD Card inside... any thoughts are appreciated. I'll keep on trying tomorrow with another USB-C cable.. ta
  Reply
#3
I am on my Explorer phone now, Bookworm on sd card.
even using cell data to access the forum.

Currently with the latest download of Mobian PRO image,

......> the Boot indicator light is not functioning..! <

So the image does actually "Boot" it is just not seen as it IS booting.

Hope that info helps

*****
Seems some have had different experiences getting or not getting their Pro
to boot to the sd card.

a 5+ second power button press worked for me.

First thing I did when I booted to my sd card ---> Nuke the factory installation.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Tow-Boot, a new U-Boot option for Pinephone Pro and other devices Ulfnic 57 16,592 07-14-2022, 10:36 PM
Last Post: shulamy
  No display on early boot after Manjaro update robocone 0 151 07-07-2022, 05:47 AM
Last Post: robocone
  Latest Manjaro-Phosh and Arch-Phosh won't boot grinzie 6 615 07-01-2022, 02:01 PM
Last Post: Chief
  Flashing to the eMMC prairie33 4 450 06-18-2022, 04:49 PM
Last Post: fxc
  Manjaro 5.17.5-1 Keyboard stopped working Yst 7 885 06-09-2022, 11:12 AM
Last Post: graphicpanda444
  Manjaro update, no boot, just noise. wilmarcdw 2 372 05-09-2022, 07:24 AM
Last Post: wilmarcdw
  Plasma Mobile navigation bar scaling is not working Yst 0 219 05-09-2022, 05:10 AM
Last Post: Yst
  Guide to Suitable Phone State Borealid 18 2,605 05-08-2022, 08:46 AM
Last Post: mburns
  Convergence Working on PPP? joshndroid 3 794 04-27-2022, 01:30 PM
Last Post: TheBlindEarthican
  Can't boot from a microSD card WhyNotHugo 5 643 04-10-2022, 09:15 AM
Last Post: WhyNotHugo

Forum Jump:


Users browsing this thread: 1 Guest(s)