2022 01 28 Updates Break Chatty
Last night (2022 Jan 28) the rolling arch updates break chatty.
I updated these apps:

[alarm@danctnix pkg]$ find | grep -r "2022-01-29" /var/log/pacman.log
[2022-01-29T00:04:58-0600] [ALPM] transaction started
[2022-01-29T00:04:59-0600] [ALPM] upgraded glib2 (2.70.2-2 -> 2.70.3-1)
[2022-01-29T00:04:59-0600] [ALPM] warning: directory permissions differ on /var/lib/AccountsService/
[2022-01-29T00:04:59-0600] [ALPM] upgraded accountsservice (0.6.55-3 -> 22.04.62-2)
[2022-01-29T00:05:00-0600] [ALPM] upgraded alsa-card-profiles (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-29T00:05:06-0600] [ALPM] upgraded mesa-git (22.0.0_devel.148909.e4c582ee71e-1 -> 22.0.0_devel.149430.ae32c6229e5-1)
[2022-01-29T00:05:21-0600] [ALPM] upgraded firefox (96.0.2-1 -> 96.0.3-1)
[2022-01-29T00:05:22-0600] [ALPM] upgraded pipewire (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-29T00:05:22-0600] [ALPM] upgraded gst-plugin-pipewire (1:0.3.43-5 -> 1:0.3.44-1)
[2022-01-29T00:05:39-0600] [ALPM] upgraded linux-megi (5.16.2-2 -> 5.16.3-2)
[2022-01-29T00:05:46-0600] [ALPM] upgraded qt5-base (5.15.2+kde+r294-1 -> 5.15.2+kde+r295-1)

Chatty was complaining that all the spelling apps were not installed.

I installed these apps:
[2022-01-29T08:40:16-0600] [PACMAN] Running 'pacman -S hunspell'
[2022-01-29T08:40:22-0600] [ALPM] installed hunspell (1.7.0-3)

[2022-01-29T08:41:34-0600] [PACMAN] Running 'pacman -S nuspell'
[2022-01-29T08:41:40-0600] [ALPM] installed nuspell (5.0.1-2)

[2022-01-29T08:42:33-0600] [PACMAN] Running 'pacman -S hspell'
[2022-01-29T08:42:42-0600] [ALPM] installed hspell (1.4-4)

[2022-01-29T08:43:37-0600] [PACMAN] Running 'pacman -S libvoikko'
[2022-01-29T08:43:43-0600] [ALPM] installed libvoikko (4.3.1-2)

Chatty launches for about 1 minute then "Segmentation fault (core dumped)"

I have a feeling that it is AccountsService the last release was 2 years ago. 

Any recommendations?
I wasn't able to reproduce this segmentation fault (with the system fully updated), is it possible for you to recompile chatty with debug symbols?
Find me in the forest, when I'm at my lowest. I don't really think you should continue..

Thank you for the quick reply. Here is an update.

To be clear, I have 2 PinePhones.
16Gig version that I use to build packages
32Gig version that I use for a daily driver. The daily driver is the one I am having issues with.

=ON the 16Gig Build Phone=

I tried to add "options+=(debug !strip)" to your chatty package build. 

prepare() {
    cd $pkgname
    git submodule update --init

options+=(debug !strip)

build() {
    arch-meson $pkgname output
    ninja -C output

It builds and installs, but I do not know where the debug information is...

=One the 32Gig daily driver=

I stopped the mmsd-tng service and chatty opened right up and I got a bunch of text messages. No crashing.
systemctl --user stop mmsd-tng

So, I started the mmsd-tng service and saw under the status that I at least 5 MMS waiting. Chatty crashed. 
systemctl --user start mmsd-tng
systemctl --user status mmsd-tng
Chatty needs to be run with gdb, but I think journalctl of the crash should also give enough information.
Find me in the forest, when I'm at my lowest. I don't really think you should continue..

I am going to mark this as solved now.

I think my issue was a bunch of MMS that mmsd-tng v1.7 could not process because I was using AT&T.
There was a fix included in mmsd-tng v1.8 that should work with AT&T.
I did not have a chance to test this, because AT&T stopped supporting my PinePhone.

I am now on Patriot Mobile (T-Mobile) and I am sending and receiving MMS with chatty v0.6.1
Sad to hear you can't test on AT&T, but good to hear that you got it working now.
Find me in the forest, when I'm at my lowest. I don't really think you should continue..


Possibly Related Threads…
Thread Author Replies Views Last Post
  Chatty not receiving encrypted xmpp messages on suspend mode user641 0 698 11-17-2022, 05:16 AM
Last Post: user641
  Chatty and OMEMO user641 1 1,081 09-27-2022, 12:47 PM
Last Post: user641
  no audio ring on non chatty calls nemsys 0 720 08-14-2022, 03:23 PM
Last Post: nemsys
  Howto enable MMS support in Chatty on Phosh? (PinePhone) ramona.fulton 2 2,687 11-18-2021, 02:58 PM
Last Post: Danct12
  Discover does not show any updates firefox-58 0 1,240 07-16-2021, 12:21 PM
Last Post: firefox-58
  2021 Jun 23 Updates breaks chatty [solved] mikehenson 2 2,534 06-27-2021, 04:41 AM
Last Post: AndyM

Forum Jump:

Users browsing this thread: 1 Guest(s)