Did i break my wifi with the keyboard?
Hello dear fellow pinephonians.

I recently got my pinephone keyboard and was too excited to search for proper instructions,
so i connected the keyboard, while the pinephone was running. I have no idea, if this was the
problem, or if i created the damage on some other way, but my wifi (also bluetooth) does not work anymore.

I am running arch linux with phosh. The wifi card is properly detected and can be disabled/enabled via phosh ui or nmcli,
but whatever i try, i can't seem to find any networks.
I also tried searching from the terminal, using
sudo iw dev wlan0 scan
but so far no luck.

I also tried disabling/enabling wifi with the tiny switch on the back on the pinephone. No luck as well.
Has this happened to anyone else and has anyone an idea, if this is fixable?

I am currently downloading megis multi-distro image, to see, if this still happens, when i use another system.
WiFi did not work in Mobian, PostmarketOS and SailfishOS as well.
Did you find a fix for this? I'm having the same issue on my UBports CE Pinephone running Mobian Bookworm from eMMC and the latest (from late january) multiboot image from uSD.

Wireless and bluetooth show as on and can be toggled off from both graphical and terminal interfaces but scanning for devices show no networks in any of the OS images I've tried.

The same happens with the phone removed from the keyboard cover. Both wifi/bt were fine yesterday in the eMMC Mobian install.
I don't know if you damaged it, but I’m on Mobian’s weekly build; WiFi, Bluetooth and the keyboard are working fine with the PinePhone.
(Bluetooth connected to my JBL Speaker with no problems & it even picked up my neighbor’s T.V.)

Here’s a link:
Satisfied PinePhone, Pinebook Pro & PineTab2 owner; Thank you Pine64Team for your work!  Smile
I'm also running the latest Mobian build from eMMC, but just to be sure I flashed a fresh uSD card with the latest weekly (2022-01-16): same result. All hardware toggles are on, and I get no wifi networks found standing right next to my router (though the wifi chip seems to be found by the os, as it is toggleable in the settings). Bluetooth seems to not even be found, as the settings page just says "no bluetooth device present".

This happens with the keyboard cover, with the stock cover and with no cover at all.
I found the wifi to be working strangely in general. The message I get in wpa_supplicant.service is "nl80211: kernel reports: Authentication algorithm number required'" and then it won't do anything until I suspend and resume, get lucky directly or not, maybe reboot. I bet the driver is has just too many issues, it's not in Linux mainlin for reasons.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Updated Physical Keyboard? jakfish 8 752 06-22-2024, 11:05 PM
Last Post: zetabeta
  power circuit can't charge battery and can't supply enough power for modem or wifi vortex 2 720 02-17-2024, 04:15 PM
Last Post: vortex
  pinephone keyboard + dock question tuxcall 7 3,176 02-05-2024, 03:17 PM
Last Post: wigan
  bluetooth wifi bugs aular 6 1,798 08-27-2023, 07:53 AM
Last Post: aular
  PinePhone Keyboard KJ6OHG 11 8,555 08-23-2023, 03:25 AM
Last Post: Kali
  PinePhone keyboard layout with manjaro plasma daemonbsd 0 1,013 03-02-2023, 05:01 AM
Last Post: daemonbsd
  Pine phone USB keyboard connection CleanEnergyCleanEnvironment 1 1,224 02-20-2023, 12:14 AM
Last Post: Kevin Kofler
  No wifi/bluetooth on multiple OS's Xxancap15 1 1,216 10-28-2022, 12:10 PM
Last Post: fxc
  Wifi no scan results - Bluetooth adapter not available emsyr 1 1,504 08-29-2022, 02:46 PM
Last Post: emsyr
  Why not Atheros ath9k_htc for wifi? altulke 13 7,208 08-11-2022, 01:01 PM
Last Post: auanta

Forum Jump:

Users browsing this thread: 1 Guest(s)