"no network devices available"
#1
Wifi was working a few months ago on Debian 9, but then I didn't use it for a few months.  The wifi was connecting but not getting any IP address (no other issues for other devices), and it was so out of date that I wanted to flash anyway.  I booted to Kali via USB a week ago, and the wifi worked fine.

Today I started trying to flash SD > EMMC and had a few images fail to boot from SD.  Now I'm using a validated image from [Kali](https://www.kali.org/get-kali/#kali-arm). I'm not sure what I changed to make this happen, unfortunately, but now I don't have any network devices via boot to EMMC or SD/USB.

Not sure what other info is needed to help troubleshoot this.  TIA!
  Reply
#2
So you have Kali installed on the eMMC?
Which version?
Can you still boot some other distro (like Manjaro) from SD?

Can you try to install something else on the eMMC?
  Reply
#3
I had Debian 9 installed on the eMMC and Kali on USB and SD.  I'd also tried the ARM version from debian.org.  In one last ditch attempt I tried mrfixit's Debian image on SD…and wifi worked.  I installed the same Debian image on eMMC and wifi is also working.  So it seems like Debian 9 was just way too out of date, still no idea what's up with Kali (as it worked fine with wifi last week), but I'm finally out of my loop.

mrfixit's image is only Debian 9 - is there a way to update to Debian 10 or 11 from it?  (If this should be in a new thread let me know).  I use Linux at work, but it's all managed for me - I'm new to trying to configure the OS myself.
  Reply
#4
There is a thread for Debian on the Pinebook Pro.
https://forum.pine64.org/showthread.php?tid=14109
At a first glance it all doesn't look that simple.

Is there a specific reason you want to stick with Debian?
I think Manjaro is a good alternative on the Pinebook Pro, as it is actively maintained.
  Reply
#5
I've only used Debian-based systems so I'm just much more comfortable with it. That thread was indeed way too complicated for me but mrfixit's image was much easier. Also, I was able to upgrade to Debian 11, it was just a matter of editing my sources.list stretch>buster and then buster>bullseye (updating and rebooting in between).
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Network connection question??? davehetfield 1 1,899 03-11-2021, 07:31 AM
Last Post: tkudog
  No WIFI network discovery in any manjaro installation (but works on fedora) pineitup 1 1,755 02-05-2021, 09:10 AM
Last Post: BlueJayLinux
  Does Fastboot Devices tools work on Pinebook Pro? pinejolla 6 4,653 06-16-2020, 03:14 AM
Last Post: FeMike
  Can't find Wifi network GloriousCoffee 21 11,901 04-04-2020, 06:06 AM
Last Post: GloriousCoffee
  Wi-fi: "Device not managed" in Network Manager gfoty 5 3,837 03-26-2020, 07:57 AM
Last Post: gfoty
  SSD NVME and Network connection guilain.houze 0 1,187 01-01-2020, 06:01 AM
Last Post: guilain.houze

Forum Jump:


Users browsing this thread: 1 Guest(s)