Android 7.1 (Pinebook) 0.3.10-66 [Sep 19] | Android 7.1 (PINE A64(+)) 0.3.10-66 [Sep 19] | Android 7.1 (SOPINE) 0.3.10-66 [Sep 19] | Linux Images (ROCK64) 0.5.9-104 [Sep 13] | Android Images (ROCK64) 0.3.4-86 [Sep 13] | PINE64 Installer v2.0.0-beta.3 [Sep 12] | Android Images (ROCK64) 20170809 [Aug 24] | Debian Jessie LXDE (ROCK64) 20170809 [Aug 16]

Getting Started | Visit the WIKI | IRC Logs | Forum Rules/Policy


Enabling wifi
#11
(08-02-2016, 02:36 AM)pfeerick Wrote:
(06-30-2016, 05:20 AM)c4tich Wrote: I made the proposed changes and it doesn't work, the command sudo iwconfig wlan0 gives the following output

Code:
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.

Sorry for not getting back to you sooner c4tich. I'm assuming you didn't make any progress as you didn't come back with a suitably joyous response Wink

Sounds more like it's something wrong with the /etc/wpa_supplicant/wpa_supplicant.conf file. Double check that it is formatted correct, and there aren't any missing quotation marks or braces - they are always in matching pairs - one to open and one to close. 

Otherwise, try a simpler version of it with just the network ssid and psk.

Code:
network={
ssid="Wireless Network Name"
psk="network-password"
}

Also, so you get any response'sudo iwconfig'? Does it at least indicate that the wireless module is functioning?

@hawk: Glad you got your wireless up and running, it certainly makes life easier when you can use wifi instead of wired connections!

Hey,

I'm not the OP but I am someone who is experiencing the same exact problem! I did your changes and I'm still failing here. Sudo iwconfig shows "no wireless extensions" for eth0, dummy0, sit0, and lo...

What should my next steps here be?

Also, I've attached an image just to verify that I in fact plugged in the wifi chip to the appropriate place, lol. All pins are in, but it does feel loose....
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Create a WiFi hotspot on Debian 8 JulianM 1 2,602 09-11-2017, 12:53 AM
Last Post: alex17pat
  Pine64 doesn't recognize Wifi/BT Module clobeca 3 131 07-13-2017, 08:58 PM
Last Post: MarkHaysHarris777
  Better WiFi/BT module? fonix232 17 1,053 02-13-2017, 04:38 AM
Last Post: xalius
Sad wifi direct bj_jung 2 704 12-29-2016, 10:26 AM
Last Post: happytuna
  WIFI & Bluetooth? 7777777 14 5,661 12-24-2016, 05:01 AM
Last Post: Toriless
  RF connector on wifi\bt board kb1qzh 1 343 12-15-2016, 06:36 PM
Last Post: tllim
  Wifi module able to share ethernet connection? Connection is unstable! cr2016 12 1,051 10-12-2016, 04:16 AM
Last Post: cr2016
  Losing WiFi Connection on Android Everytime mribunal 4 651 10-10-2016, 06:38 PM
Last Post: mribunal
  Unable to activate wifi on Linux smouton 5 1,444 09-17-2016, 10:35 PM
Last Post: MarkHaysHarris777
  Trouble getting Wifi board to work with Remix OS Seussman71 6 3,278 07-17-2016, 11:47 PM
Last Post: grantos

Forum Jump:


Users browsing this thread: 1 Guest(s)