[Jan 06] Arch Linux (20171225-1) PINE A64(+) Pinebook A64-LTS/SOPINE | [Jan 04] Linux (0.5.15-136) ROCK64 | [Jan 04] Android (20171204) ROCK64 | [Dec 22] Stretch Mate (0.5.15-136-20171222) ROCK64 | [Dec 21] openHAB 2 (v1.4) PINE A64(+) | [Dec 11] Volumio (2.315) PINE A64(+) A64-LTS/SOPINE | [Dec 11] Armbian (5.35) PINE A64(+) Pinebook A64-LTS/SOPINE | [Dec 8] OpenMediaVault (0.5.15-136) ROCK64

Getting Started | Visit the WIKI | IRC Logs | Forum Rules/Policy


Enabling wifi
#11
(08-02-2016, 02:36 AM)pfeerick Wrote:
(06-30-2016, 05:20 AM)c4tich Wrote: I made the proposed changes and it doesn't work, the command sudo iwconfig wlan0 gives the following output

Code:
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.

Sorry for not getting back to you sooner c4tich. I'm assuming you didn't make any progress as you didn't come back with a suitably joyous response Wink

Sounds more like it's something wrong with the /etc/wpa_supplicant/wpa_supplicant.conf file. Double check that it is formatted correct, and there aren't any missing quotation marks or braces - they are always in matching pairs - one to open and one to close. 

Otherwise, try a simpler version of it with just the network ssid and psk.

Code:
network={
ssid="Wireless Network Name"
psk="network-password"
}

Also, so you get any response'sudo iwconfig'? Does it at least indicate that the wireless module is functioning?

@hawk: Glad you got your wireless up and running, it certainly makes life easier when you can use wifi instead of wired connections!

Hey,

I'm not the OP but I am someone who is experiencing the same exact problem! I did your changes and I'm still failing here. Sudo iwconfig shows "no wireless extensions" for eth0, dummy0, sit0, and lo...

What should my next steps here be?

Also, I've attached an image just to verify that I in fact plugged in the wifi chip to the appropriate place, lol. All pins are in, but it does feel loose....
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Schematics of Wifi/BT module gamelaster 1 91 01-22-2018, 03:32 AM
Last Post: xalius
  Create a WiFi hotspot on Debian 8 JulianM 1 5,842 09-11-2017, 12:53 AM
Last Post: alex17pat
  Pine64 doesn't recognize Wifi/BT Module clobeca 3 233 07-13-2017, 08:58 PM
Last Post: MarkHaysHarris777
  Better WiFi/BT module? fonix232 17 1,180 02-13-2017, 04:38 AM
Last Post: xalius
Sad wifi direct bj_jung 2 758 12-29-2016, 10:26 AM
Last Post: happytuna
  WIFI & Bluetooth? 7777777 14 6,000 12-24-2016, 05:01 AM
Last Post: Toriless
  RF connector on wifi\bt board kb1qzh 1 388 12-15-2016, 06:36 PM
Last Post: tllim
  Wifi module able to share ethernet connection? Connection is unstable! cr2016 12 1,121 10-12-2016, 04:16 AM
Last Post: cr2016
  Losing WiFi Connection on Android Everytime mribunal 4 695 10-10-2016, 06:38 PM
Last Post: mribunal
  Unable to activate wifi on Linux smouton 5 1,609 09-17-2016, 10:35 PM
Last Post: MarkHaysHarris777

Forum Jump:


Users browsing this thread: 1 Guest(s)