New user: Booting from emmc
#1
Hello,

My Pinepro64 came in yesterday, and I am having trouble getting it to boot from emmc. I don't have an sd card to test yet.

I would appreciate any help anyone can offer. As I'm brand new to this device I am concerned that I might be making some rookie error.

I have tried three different images: Debian, Armbian Hirsute (5.13 kernel), Armbian Buster Legacy (4.4 kernel).

With all images, the power LED shows solid green, and the ethernet port lights light up.

With both Armbian images, when I plug the power in I get a flashing white LED behind the reset button. With the Debian image I get nothing.

Based on some google searching I found that there might be issues booting newer kernels from emmc. However, in my case the older (4.4) kernel didn't work either.

I flash the emmc using the usb adapter and dd.

I am plugged into an LCD monitor using HDMI. I have a wifi/bluetooth adapter plugged in, and the emmc chip, but no other peripherals.

Thanks in advance.
  Reply
#2
I have also tried the Armbian Debian Buster (5.10 kernel), which a user in this thread https://forum.pine64.org/showthread.php?tid=15285 said they got to boot from emmc. Unfortunately, no such luck for me. Still the flashing white LED behind the reset button that never stops flashing.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Brick Maintained Linux booting from eMMC ootoovak 10 2,893 04-30-2022, 03:57 PM
Last Post: TRS-80
  A Rant About Pine, Other Distros, & Still Trying to Get Fedora Booting From eMMC. whitecat23 8 1,836 01-31-2022, 04:05 PM
Last Post: TRS-80
  How I Got Fedora Linux to Boot From eMMC (or microSD, for that matter) whitecat23 4 1,045 01-03-2022, 10:32 AM
Last Post: whitecat23
Question Booting official Debian on RP64 arteeh 6 3,355 07-06-2021, 10:16 AM
Last Post: TRS-80
  Booting from NVME ilovegentoo 11 6,440 05-10-2021, 02:06 PM
Last Post: rrowles2000
  Booting Linux/Debian from the eMMC linuxha 4 2,663 03-02-2021, 07:01 PM
Last Post: linuxha
Question My Rockpro64 stopped booting with these error messages please help seaurchin 4 2,436 02-18-2021, 04:27 PM
Last Post: TRS-80
  RockPro64 eMMC mrfixit to 5.9 rthorntn 1 1,817 10-27-2020, 07:09 PM
Last Post: rthorntn
  RockPro64 getting started - non-booting images [solved] new-rockpro-user 3 3,841 03-06-2020, 06:31 AM
Last Post: new-rockpro-user
Exclamation eMMC boot issue jwillmer 0 1,338 07-19-2019, 03:16 PM
Last Post: jwillmer

Forum Jump:


Users browsing this thread: 1 Guest(s)