Help! Where's the Modem?
My story begins with noticing: eg25manager[2815]: Rescheduling upload since modem isn't on line yet, in 30s in the log.

Was this caused by not having a SIM installed? No. Was running sxmo, is it distribution related? No.

Looked at other eg25manager log messages, then found these messages in eg25manager source code. Reduced problem by switching to archlinux-pinepone-barebone, disabling eg25manager, and manually executing the power-on/off sequence using the sysfs gpio interface.

A review of the Pinephone schematics and the EG25-G HW Datasheet suggested variations to try. Regardless of these attempts, seems the modem just never boots [as evidenced by gpio233/STATUS always remaining high [the inactive or not-running state].

Next assumption: the modem is bricked. Remove internal cover to gain access to T1500 and T1501 to enable USB_BOOT. Still with eg25manager disabled, bridge test points and boot phone. No sign of the expected usb device in lsusb after numerous attempts. A look at the EG25-G HW Datasheet timing diagram suggests a dependence on PWRKEY, so tried applying a power-on/off sequence while USB_BOOT was active. No diff.

So now, Obi Wan Kenobi, your my only hope. I've exhausted my a ideas and find no other's with a similar problem.

If you've made it this far, thanks much for your interest.
Are you certain that it is not distribution related ?

I would suggest trying Mobian or Post Market from a micro-sd card before stating that.
   Donate to $upport
your favorite OS Team
Is modemmanager install and started?
(11-16-2021, 09:38 PM)bcnaz Wrote: Are you certain that it is not distribution related ?

I would suggest trying Mobian or Post Market from a micro-sd card before stating that.

I've tried manjaro, postmarket, mobian, arch-barebone [which I prefer testing with], and plamo-beta-factorytest. They all appear to be using the same modem stack, so they all give the same symptoms and log file entries.
(11-17-2021, 01:01 AM)Merc Wrote: Is modemmanager install and started?

It's present in some cases, like manjaro, but it never gets started comes into play because eg25manager never gets the modem started.
A follow up: Because I can't force the modem into EDL, I tried to verify some function with a volt meter. Test point T1500 is supposed to be connected to the modems VDD_EXT via a resistor. Thus there should be 1.8VDC on that test point after the modem powers up. That doesn't seem to ever happen. Without VDD_EXT at TP1500, there is no way to put the modem in EDL. So the next question is, Where's the VDD_EXT?

Possibly Related Threads…
Thread Author Replies Views Last Post
  Modem Hardware bad? Not ready for 5g?? linux76 7 960 05-19-2022, 07:33 AM
Last Post: kebab
  Modem in failed state, not sending/receiving SMS brb78 5 564 03-31-2022, 08:37 AM
Last Post: wibble
  Modem Dead? grimlok 5 763 03-12-2022, 04:38 PM
Last Post: bcnaz
  Question regarding modem AntonReiser 21 3,492 02-14-2022, 12:23 PM
Last Post: vap0rtranz
Question Powering the modem after turning off the smartphone Mikoduso 3 760 02-04-2022, 04:06 PM
Last Post: grwlf
Question Modem shield feklee 3 888 12-13-2021, 01:06 PM
Last Post: feklee
  what are these pins above modem chip? zetabeta 1 535 12-13-2021, 04:38 AM
Last Post: kqlnut
  Connect external modem? feklee 7 1,534 12-06-2021, 03:52 AM
Last Post: feklee
Bug [Support Request] Modem is Failing to Be Accessible FriendlyGecko 3 968 11-30-2021, 01:22 PM
Last Post: FriendlyGecko
  Does GPS work on a separate chip or is GPS built into the LTE modem? Mikoduso 7 2,062 11-22-2021, 01:19 PM
Last Post: Mikoduso

Forum Jump:

Users browsing this thread: 1 Guest(s)