Unmet dependencies/held broken packages while trying to install kodi
#1
w'm trying to install Kodi 16, every step up to sudo apt-get install kodi works fine. When I try that step, I get this error:
Code:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi : Depends: kodi-bin (>= 2:16.1~git20160425.1001-final-0xenial) but 15.2+dfsg1-3ubuntu1 is to be installed
       Depends: libshairplay0 but it is not installable
       Recommends: libva-intel-vaapi-driver but it is not installable or
                   i965-va-driver but it is not installable
E: Unable to correct problems, you have held broken packages.
When I try sudo apt-get build-dep kodi, I get the same error with different specified packages:
Code:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
builddeps:kodi : Depends: dcadec-dev but it is not installable
                 Depends: libplatform-dev but it is not installable
                 Depends: libshairplay-dev but it is not installable
E: Unable to correct problems, you have held broken packages.
I can't seem to install any of these packages independently, installer can't locate them, I'm not sure where else I would get them, supposedly they should be in the kodi repository. Tried sudo dpkg --configure -a, sudo apt-get --fix-broken install, sudo apt-get dist-upgrade, at different points . Any ideas?
  Reply
#2
Even if you would be able to install kodi from whatever repository you have added it would not make any sense as you would need accellerated video decoding for Kodi on Pine64 (possible). But as there is no accelerated 3D to render the Kodi UI at any reasonable speed Kodi is useless as of now.
  Reply
#3
(06-25-2016, 06:29 AM)longsleep Wrote: Even if you would be able to install kodi from whatever repository you have added it would not make any sense as you would need accellerated video decoding for Kodi on Pine64 (possible). But as there is no accelerated 3D to render the Kodi UI at any reasonable speed Kodi is useless as of now.

Got it, thank you.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Install Telegram Desktop in KDE Neon podcastlinux 1 384 11-25-2018, 08:27 PM
Last Post: evilbunny
  install lvs jam 2 426 11-30-2016, 01:33 AM
Last Post: jam
Question Step By Step How To Install Ubuntu Image damikeh 47 42,904 10-01-2016, 07:15 PM
Last Post: jkmooney
  How do i install python anaconda on my ubuntu ? quantumfusion 3 1,574 08-22-2016, 08:07 AM
Last Post: martinayotte
Information KODI (XBMC) green176 3 758 05-20-2016, 11:11 AM
Last Post: pinea64.edison
  systen type not detected (config.guess, config.sub, LMS 7.9 install mrpn900 2 460 05-18-2016, 03:56 AM
Last Post: mrpn900
  Can't install plex or chrome Thorzgard 5 1,100 05-03-2016, 03:37 PM
Last Post: eluder
  Ubuntu 16.04 (Xenial Xerus) - Kodi 16 sirhcjw 2 1,842 04-26-2016, 04:49 PM
Last Post: sirhcjw

Forum Jump:


Users browsing this thread: 1 Guest(s)