Chatty, SMS does not work - could hardware be at fault?
#21
(09-21-2021, 01:19 AM)bcnaz Wrote: Strange,
Of the 5 Pine phones I have, *  I have not had to flash even one modem...  I thought I needed to at one point with my original Brave Heart, but a new OS showed that it was not necessary.

Different releases of one operating system,  or using different operating systems have solved any of my problems, from the Brave Heart days to today.

Just for information : i had the same problem with bullseye : no more incoming SMS and sending didn't work too. I installed "Modem Manager GUI", played a little with and... SMS came back again ?! No explanations.
  Reply
#22
I do install Modem Manager GUI on most of the OSes that I use, it is great to clean out the MMS text that tend to get stuck in the Modem.

GREAT to hear it is working for you !
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#23
Thank you all for your advice.

This is what I did:

1. Do a factory reset of the modem. It was difficult to find out how it's done, so for those of you how need to reset the Quectel LTE EG25-G Modem, this is the trick:
Code:
sudo mmcli -m 0 --factory-reset=000000
The phone still would not send SMS text messages.

2. Reinstall the Firmware version 02.002.02.002 according to these instructions.
Still would not send SMS text messages.

3. Install FOSS firmware according to these instructions.
Still would not send SMS text messages.

I am out of ideas.

Is there anything left I could try?
  Reply
#24
Have you tried clearing the modem cache ?

There are instructions elsewhere in the forum for clearing it via terminal.
Myself, I use the 'Modem Manager GUI' App to clear the cache with just a few 'clicks'.

open the app > click on sms messages, delete messages > click on 'actions' > click on quit ... DONE.

At one point back in my Brave Heart days I thought I had a modem problem, but since I started clearing the cache, I have not had any modem problems.

To answer your original question, YES, It is possible it could be a hardware problem in your case,
BUT ... I think it is more likely to be a software or firmware issue.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#25
(09-28-2021, 01:34 PM)bcnaz Wrote: Have you tried clearing the modem cache ?

Thanks! Yes, I had tried that as well, via Modem Manager GUI as well as mmcli -m 0 --messaging-list-sms.
  Reply
#26
Have you tried the most recent Bookworm nightly release ?
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#27
(09-29-2021, 07:25 PM)bcnaz Wrote: Have you tried the most recent Bookworm nightly release ?

Yes. Older Bullseye versions as well.
  Reply
#28
(09-29-2021, 10:41 PM)AntonReiser Wrote:
(09-29-2021, 07:25 PM)bcnaz Wrote: Have you tried the most recent Bookworm nightly release ?

Yes. Older Bullseye versions as well.

Perhaps it is your hardware,  Most of the current and recent Mobian releases I've tried just keep getting better for me. ( an occasional exception )

Some of the other OSes are doing fairly well also,  I just tend to favor Mobian.
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#29
In order to rule out a hardware issue, I had posted the question whether it could be a technical defect in the hardware section.

There dcinoz came up with very helpful suggestions. Here's a brief summary of




+++ THE SOLUTION: How to send SMS text messages (if it does not work on its own) +++

1. Use this command immediately after booting the phone:
Code:
mmcli -m any --command='AT+QCFG="ims",2'

2. Check if it has worked with
Code:
mobian@mobian:~$ mmcli -m any --command='AT+QCFG="ims"'
response: '+QCFG: "ims",2,0'

3. If the response is not 2,0 but 2,1 go back to 1. and try to be quicker after the restart.

4. Once the response is 2,0 you should be able to send SMS text messages.

5. To make the change permanent, open the file pine64,pinephone-1.X.toml (in my case 1.2.toml) in the directory //usr/share/eg25-manager/ and

6. replace the lines
Code:
# Enable VoLTE support
    { cmd = "QCFG", subcmd = "ims", expect = "1" },

with
Code:
# Enable VoLTE support
#    { cmd = "QCFG", subcmd = "ims", expect = "1" },
    { cmd = "QCFG", subcmd = "ims", value = "2" },

7. That's all. Good luck!

8. Apparently there's a better method with VoLTE support. I haven't tested it yet. If VoLTE support is important to you, you might want to look here.
  Reply
#30
(09-19-2021, 12:27 PM)kqlnut Wrote: If you do decide to flash the alternative firmware at some point (which by the way is also safer than the stock firmware as sudden power loss can't corrupt the modem), you can also revert back to the stock firmware later.

Hi kqlnut, do you know how I can revert back to the stock firmware?

I had installed the FOSS firmware, but I must admit that I am not too happy with it, because the modem keeps crashing, which means that I am unavailable for long stretches without even noticing it.

However, after I had followed the instructions to install the FOSS firmware, I cannot reinstall the original firmware following this manual, I only get error messages.

What do I have to do to reinstall the original firmware?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Hardware VIdeo Acceleration on Mobian biketool 3 471 06-21-2022, 01:01 PM
Last Post: biketool
  GPS/location services don't work with Maps after Bookworm upgrade Anna 16 2,905 06-13-2022, 02:37 PM
Last Post: wibble
  Chatty - XMPP receiving photos - inline display doesn't work arkadione 1 131 06-12-2022, 02:39 PM
Last Post: user641
Sad Chatty can no longer start since the last update anonymous 10 689 06-08-2022, 01:03 PM
Last Post: Korac
  chatty v0.6 in Bookworm at last! treebeard 13 2,012 02-13-2022, 05:21 PM
Last Post: treebeard
  Anyone using a hardware token? p121458 13 5,640 01-17-2022, 03:24 AM
Last Post: biketool
  Xbox Series Controller Won't Work beta-user 0 289 01-14-2022, 05:58 AM
Last Post: beta-user
  Recipe for getting OpenVPN to work? county93 1 883 10-04-2021, 12:10 PM
Last Post: county93
  Anyone find a work around for the brightness issues from kernels 5.13/14? ragreenburg 2 1,110 09-01-2021, 08:49 AM
Last Post: ragreenburg
  Kernel fault on adapter connect pinephone.damiano 0 502 08-15-2021, 04:25 AM
Last Post: pinephone.damiano

Forum Jump:


Users browsing this thread: 1 Guest(s)