Megapixels 1.3.0 - colors feels wrong
#1
Hi all,





I'm on Manjaro with Plasma Mobile on a pinephone rev 1.2. Just updated to the latest testing branch and got the Megapixels 1.3.0.

Since then colors in images feel way off.





I dug around a bit to find the difference in the postprocessing script.




The change seems to occur around line 76 of /usr/share/megapixels/postprocess.sh:



Code:
convert "$MAIN_PICTURE.$TIFF_EXT" -sharpen 0x1.0 -sigmoidal-contrast 6,50% "$TARGET_NAME.jpg"


where Martijn added the "-sigmoidal-contrast 6,50%" argument.



The specific git commit (from a day ago) is linked here https://git.sr.ht/~martijnbraam/megapixe...5893c480bd



Unfortunately I cannot understand his reasoning for this as it feels like the images look somewhat worse.



Here is a sample image converted from the raw .dng using the convert command without sigmoidal contrast (as in megapixels 1.2.0):

[Image: IMG-sharpen.jpg]



And here is the same .dng converted using the same arguments as used in 1.3.0:

[Image: IMG-sharpen-sigmoidal.jpg]




If you want to revert the change, I was able to edit the postprocess.sh file and remove the new sigmoidal argument and things are back to normal.



Feel free to edit or mention how I should edit my post, this is my first post here! Big Grin


Hope I was able to help someone!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Bug Wrong Battery Charge Level Displayed - How to Fix acid andy 7 5,860 06-12-2023, 01:04 PM
Last Post: jakfish
Question Pinephone camera & Megapixels - Bug report and question danimations 0 1,393 08-10-2021, 05:43 AM
Last Post: danimations

Forum Jump:


Users browsing this thread: 1 Guest(s)