Changing ringtone on Manjaro Phosh
#1
Music 
For anyone wondering how to change the ringtone on Manjaro Phosh, after having tried everything and changing the source code of feedbackd I have finally figured out what makes it different and not work:

First follow https://forum.pine64.org/showthread.php?tid=11195 or https://sspaeth.de/2021/03/customizing-t...-ringtone/

Now add XDG_CURRENT_DESKTOP=GNOME to your /etc/environment file (this is the important thing)

Without that XDG_CURRENT_DESKTOP environment variable it always ignores sound themes for some reason, see https://source.puri.sm/Librem5/feedbackd...c#L124-130

I don't know why Manjaro Phosh doesn't ship with that environment variable (or at least my install that is kind of old and only updated through pacman doesn't) because there doesn't seem to be a standard for configuring the active sound theme, so it is put inside the org.gnome.desktop.sound gsetting here. I think this also means it's impossible to change the ringtone on non-GNOME environments like KDE unless you override the freedesktop sound files or modify feedbackd.

If you want to setup a proper inherited sound theme just for customizations (which is how helper tools are expected to modify it for you) you need to create a sound theme called __custom, which you can put in ~/.local/share/sounds/__custom/ (or $XDG_DATA_HOME instead of ~/.local/share if that exists)

And in that folder you put an index.theme with the following content:

[Sound Theme]
Name=Custom
Inherits=librem5
Directories=.


(replace librem5 with the theme the user actually wants to use)

Now you can put sound overrides directly in that folder (there must be no stereo/ folder, everything directly in the __custom folder according to the sound theme spec)

I'm not sure what exact format the audio files need to be, but iirc if you choose .oga (ogg) it should be stereo with 48000 Hz

For my conversion I used ffmpeg -i input.wav -filter:a "volume=0.5" -codec:a libvorbis -qscale:a 8 phone-incoming-call.oga

Now change theme by typing gsettings set org.gnome.desktop.sound theme-name __custom

and potentially clear sound cache using rm /home/mobian/.cache/event-sound-cache.tdb.*

Reboot for good measure or at least kill feedbackd to be sure it catches the update. (although it should watch for changes on that gsetting)

Hope this helps
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro: Settings doesnt open nbh 0 652 09-24-2023, 05:25 PM
Last Post: nbh
  Can't get ring on Manjaro Pine Phone thorensjubilee 12 3,991 06-09-2023, 04:40 AM
Last Post: thorensjubilee
  Is Manjaro ARM a Rolling Release? jojuma 4 1,762 05-10-2023, 09:27 PM
Last Post: Kevin Kofler
  Where Does Manjaro Phosh Store Its Custom Keystrokes? jakfish 0 884 04-25-2023, 09:49 AM
Last Post: jakfish
Exclamation My short experience with Manjaro Plasma Mobile anonymous 10 5,231 03-02-2023, 07:25 PM
Last Post: Kevin Kofler
  Backup and Home Screen Tinkering on Phosh jakfish 0 915 02-24-2023, 12:56 PM
Last Post: jakfish
  Can't install Manjaro thorensjubilee 1 1,105 02-09-2023, 08:17 AM
Last Post: thorensjubilee
  Manjaro plasma-mobile Beta 13 Uturn 13 5,343 01-25-2023, 04:15 PM
Last Post: Kevin Kofler
  Manjaro Plasma busted Chief 2 1,682 11-22-2022, 05:00 PM
Last Post: Chief
  MMS workaround for users with separate APN (works atleast on Manjaro Phosh) alaraajavamma 0 1,119 10-10-2022, 12:53 PM
Last Post: alaraajavamma

Forum Jump:


Users browsing this thread: 1 Guest(s)