Icecat on Pine H64
I’m not able to speak with any degree of authority on this so take this with my advice to double check it but so far as I understand from unix and RPi stackexchange discussions on performing the above operation as mentioned by @rgreen, 3Gb is nowhere near enough RAM and even IBM’s machines take ~7H to compile Firefox from source so realistically we’re not going to be able to on the H64, PinePhone, RPi etc.
From my own adventures trying to get Icecat running on the PinePhone, I followed advice given in the stackexchange posts to install GUIX over the OS I’m running on the PinePhone (Mobian), then run “guix install icecat” - this after having already tried the savannah build script route, which also failed - but after a few hours the phone has run out of battery and shutdown, even though it’s charging from the keyboard case. Even after configuring 1.5Gb of ZRAM, it still wouldn’t work - and I monitored the Usage app (scrolled down so that displaying the CPU usage graphs wouldn’t add to the load), which showed both the 2.9Gb RAM and the 1.5Gb ZRAM maxing our after a while and freezing up the system. So this experience at least anecdotally validates the requirements described in the stackexchange posts. That being said, I haven’t tried the compilation varying the ZRAM config between a min. of 10% and a max. of 250% but I figured a more appropriate route might be to see if there was an Icecat package precompiled for aarch64 / arm64.

Varying my DuckDuckGo search terms led me to discover that The Fedora Project has Icecat packages precompiled for aarch64 as RPMs. I installed Alien to enable me to convert from .rpm to .deb, then downloaded the main Icecat package from TFP’s repository, as well as the -X11- and -Wayland- packages (just in case they were also needed). Once converted, I tried installing them and that appeared to work so far as generating the Icecat logo in my apps list (actually three - one for each of the packages). However, tapping on any of the Icecat logos wouldn’t load anything so I tried launching Icecat from the command line, from within the Icecat directory (found at /usr/lib64/icecat), with “./icecat” and “./run-icecat” when that failed.
Both of these attempts failed for ostensibly the same reasons: versions GLIBCXX_3.4.29 and GLIBCXX_3.4.30 were not found but are required versions GLIBC_2.33 and GLIBC_2.34 were not found but are required

Following advice in more stackexchange posts, I tried to locate these libraries on the system with “dpkg -L”, for example, but received the message “package is not installed” - which is strange because when I then double checked by flicking through different directories in the GUI Portfolio app, I found entries for it under /usr/lib/aarch64-linux-gnu/ and under /lib/aarch64-linux-gnu/ . Indeed, when I tried running “sudo apt-get install libstdc++6” and “sudo apt-get install libc6”, both gave me that they were already installed as newest versions (libstdc++6 10.2.1-6 and libc6 2.31-33+deb11u2).
So, further searches seem to indicate that people are resolving similar library issues with symlinks but there was also a suggestion in the Ubuntu forum that this is not the correct way to go about such an issue as it may break some backwards compatibility measures.

Does anyone have any further suggestions? This feels tantalisingly close to working so would really appreciate getting this over the line!

N.B. I’m running a few weeks’ old build of Mobian from a 512Gb microSD card, rather than from the eMMC, don’t know if that’s important to mention.

Messages In This Thread
Icecat on Pine H64 - by armuser97 - 08-04-2021, 02:24 PM
RE: Icecat on Pine H64 - by rgreen - 08-13-2021, 01:35 PM
RE: Icecat on Pine H64 - by 3460p - 03-17-2022, 11:28 AM
RE: Icecat on Pine H64 - by rgreen - 03-18-2022, 10:25 AM
RE: Icecat on Pine H64 - by 3460p - 03-18-2022, 12:03 PM
RE: Icecat on Pine H64 - by rgreen - 03-18-2022, 01:22 PM
RE: Icecat on Pine H64 - by 3460p - 03-19-2022, 11:50 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  DietPi OS for PINE H64 MichaIng 0 3,803 12-16-2020, 07:22 AM
Last Post: MichaIng
  LibreELEC testing image for Pine H64 Luke 7 8,301 06-12-2020, 02:38 AM
Last Post: p1x3l3d
  Some test PINE H64 “Model B”-3GB, please! stslit 1 2,551 08-25-2019, 12:41 PM
Last Post: stslit

Forum Jump:

Users browsing this thread: 1 Guest(s)