Rock64 Android Oreo 8.1 TV-Install adventures (Now Android 9.0)
#1
As it mentions above this was a bit of an adventure. Just a bit of background. I bought my first Rock64 4g a couple of years ago to run as a home automation server. It was pre RPI4 so was way ahead in it's league at the time.I installed Armbian and with the relevant OS updates it's been running 24/7 ever since without any problems.

Fast forward to today. I noticed over the last year interest was waning in this board. Community posts are down to a trickle. I managed to pick up five of these boards for a fraction of what I paid for my original purchase. Now that I needed an Android TV box I decided to give it a go and install Android 8.1 TV on an SD card as per the recommended install image https://files.pine64.org/os/ROCK64/andro...oot.img.xz . The following is how I went about it and the results that followed

I downloaded the image mentioned above.Instead of the recommended install procedure I extracted the downloaded image with Win7zip https://www.7-zip.org/download.html . It's a very stable file extraction utility and the extraction process went fine. I then used Win32 Disk Image https://win32diskimager.download/ to write the extracted image to the SD card. Once that was complete I popped the SD card into the Rock64 and powered it up and to my surprise after 10 minutes the Rock64 splash screen appeared followed shortly after by it the Android splash and finally the Actual Android GUI.

After configuring the usual locales and connecting to wired LAN via the ethernet port and attaching a mouse/keyboard I was ready to go. I started to notice that wired LAN was dropping packets and disconnecting and reconnectiing.After a quick search here with suggestions of changing to shorter ethernet cables, two pair cable instead of four to resolve Gigabit Ethernet resolution issues nothing worked. Of course I was lucky enough to have four other boards to swap in. Well I've discovered that two of the five boards have faulty ethernet connectors and one of them also faulty USB2 connectors. Also it looks like USB2 to external DAC is out owing to cracks and pops during playback.This behaviour is similar to that on the RPI3+ owing to conflict between ethernet and USB2 bus. Obviously I can't confirm this for sure on the Rock64 but I know I am experiencing this.

I finally settled on one board that boots with no issues.Full Gigabit ethernet, USB2 ports working fine. My next problem was low sound. I tried every possible option for sound out including USB to external DAC. You could barely hear a thing. Finally I stumbled on the ADB option to control sound output. I enabled the Developer option on the Rock64. I installed ADB for Linux on a Linux machine and from the Linux machine issued the adb connect command to connect both machines together. I finally found the command to increase the Rock64 built in audio output to maximum adb shell media volume --show --stream 3 --set 15 .I now had perfect audio via HDMI to an amp via coxial or in my case coaxial from TV to external DAC and analogue to the amplifier. Sound is now perfect.

This install did take a little longer than expected. What I have learnt is that it appears quite a lot of those Rock64 boards may have been faulty from day one and only I had spare boards to experiment with I'd never got Android working on my Rock64. I just did a basic outline here.If anyone planning on doing an Android install on the Rock64 has any questions ask away.
  Reply
#2
Just a little update. Followed exactly the same process for installing Android 9.0. Installed with no problems and as soon as it was booted up the full Android GUI in 5 seconds. It’s a rooted version according to the docs and no frills installed either. I prefer it that way. Let ADB do all the heavy lifting installing APK’s.
  Reply
#3
I just installed it. How do you navigate with the keyboard ?. There is n navigation bar.
  Reply
#4
(07-31-2021, 08:20 AM)Vasant Wrote: I just installed it. How do you navigate with the keyboard ?.  There is n navigation bar.

I use a combo keypad/mouse USB device. Otherwise you need a separate USB keyboard and mouse.

Android 9.0. I've no Google apps installed here. I use Opera as a browser and install everything else via ADB. I'm trying to keep this as bloat free as possible. So far this install is working well. No crashes so far.
  Reply
#5
I wanted to install a driver and couldn't find Android 4.4.159 kernel anywhere nor the Android Pie SDK. So went back to Debian console SD card installation.
  Reply
#6
There's very little development work being done on the Rock64. It's a shame really as once you have a board free from physical defects it's performance is up there with the opposition. I'm running one board as a Debian server, one running Android 9.0 rooted and they are very reliable so far. I do know that after my experience with faulty boards I won't be buying any further Pine products. QC has been a major issue certainly with this particular model.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  How do I prepare/put Android on an SD card using etcher cdotsubo3000 3 2,543 06-27-2021, 02:43 PM
Last Post: clach04
  Android and SD Card gigagames 2 1,776 06-27-2021, 02:38 PM
Last Post: clach04
  Android Images (ROCK64) pineadmin 73 94,319 05-04-2021, 01:58 AM
Last Post: zet_lab
  Android 9.0 and Pluto on Rock64-1G missdeenola 1 1,690 03-12-2021, 01:38 PM
Last Post: Wizzard
  broken android microsd images jbach50 1 1,381 01-16-2021, 09:57 PM
Last Post: jimsurvak
  Android on Rock64 SD Problem ElBoluTony 3 2,480 10-07-2020, 12:10 PM
Last Post: ElBoluTony
  Error! Android Rockchip tools method BowerR64 0 1,056 09-18-2020, 08:12 PM
Last Post: BowerR64
Lightbulb Any older versions of Android for the Rock64? BowerR64 2 1,996 09-18-2020, 07:58 PM
Last Post: BowerR64
  Can't boot android 9 on rock64 maks2204 5 3,931 09-09-2020, 08:44 AM
Last Post: BowerR64
  Boot Android from USB? Max_H 3 3,145 09-09-2020, 08:26 AM
Last Post: BowerR64

Forum Jump:


Users browsing this thread: 1 Guest(s)