Intermittent Mobile Data
#1
Greetings:
Just went to T-Mobile in Greece, NY this past Friday to have my new Pine64 phone activated. 

To make a long story short, when you first boot it up, in Cellular Networks tab under settings, it shows APN as fast.t-mobile.com. But when you try to access the internet, it doesn't work (I forget the error message right now). But if I wait long enough it will connect to the internet. HOWEVER if I let it sit long enough, it will lose network connectivity altogether. It will show nothing under Access Points or SIM Cards. It's running Manjaro-ARM that it shipped with. KDE Plasma version 5.21.2. KDE Frameworks Version 5.79.0. Qt version 5.15.2. Kernel 5.11.3-1Majaro-ARM. Not sure which, if any, you needed. I attempted to do an update, but it errored out concerning dependencies. 

I'm new to this. What should I do? 

If it makes a difference, I'm currently in Orangeburg, SC at this time. I drive truck.
  Reply
#2
> if I let it sit long enough, it will lose network connectivity altogether.

That might be unrelated if "sit long enough" includes the phone suspending. IME the closed modem firmware wigs out during suspend.
  Reply
#3
I would advise you to update from the terminal with `sudo pacman -Syu` and reboot or even better flash it with the latest image and set the APN again.

It seems that the phone either loses the communication with the modem or with the SIM, it may be software related or something wrong with the hardware.
  Reply
#4
That sounds like a Crust related issue. It is a known bug being worked on. It can partially be fixed by excecuting the following commands in terminal:

sudo rm /var/lib/pacman/db.lck
sudo pacman -Syyu

Click yes, if prompts show up to replace certain files.
That should fix your dependencies and update your device. But, the crust issue is not yet resolved, only improved.
  Reply
#5
We are not getting Internet anywhere that is out of range of Wi-Fi (work, home, etc.) Is this related to the crust issue?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Lightbulb pinephone mobile dock jasmin763 2 245 06-06-2022, 09:06 AM
Last Post: 98cwitr
Question Mobile data suddenly gone epiii2 1 184 05-23-2022, 04:57 PM
Last Post: epiii2
  likely bug, volte does not work when operator side data blockage is activated zetabeta 1 193 05-21-2022, 03:03 PM
Last Post: zetabeta
  No data access on ATT prepaid but my plan has data dc2daylight 6 1,301 04-03-2022, 02:14 PM
Last Post: dc2daylight
  Mobile case wanted - with wireless charging! thorensjubilee 4 661 03-19-2022, 10:29 AM
Last Post: vap0rtranz
  mobile data jimbusch1 5 891 02-24-2022, 02:41 PM
Last Post: amindfv
Sad LTE data does not work on T-Mobile US with latest postmarketOS 21.06 SP3 PacificSinewave 1 344 11-07-2021, 10:15 AM
Last Post: beta-user
  GCI data on Pine Phone nelstomlinson 0 627 09-26-2021, 04:04 PM
Last Post: nelstomlinson
  How did you get data working on PureTalk? nelstomlinson 2 1,168 09-26-2021, 03:50 PM
Last Post: nelstomlinson
Question Mobile Carriers 67comet 29 15,173 07-14-2021, 11:47 PM
Last Post: rocket2nfinity

Forum Jump:


Users browsing this thread: 1 Guest(s)