Is my VoLTE working?
#1
Hi, I followed all the instructions I could find to get VoLTE working. My carrier "Consumer Cellular" uses AT&T network which is soon totally disabling 3G so I must get VoLTE working. However I'm not sure if it is working. I need help understanding it.

I have Manjaro CE with Phosh.

I reached the carrier support and they succesfuly detected the modem model and enabled something on their end to allow VoLTE.

I followed the VoLTE steps on the main PinePhone wiki page.

Code:
AT+QCFG="ims"
+QCFG: "ims",1,1

OK

The 4G indicator shows in the UI. To test, I called my wife.

Code:
#Start call to my wife:

[root@manjaro-arm ~]# echo 'AT+CLCC' | atinout - /dev/EG25.AT -
+CLCC: 2,1,0,1,0,"",128
+CLCC: 1,1,0,1,0,"",128
+CLCC: 3,0,0,0,0,"4436179824",129,"Andrea"
+CLCC: 4,1,0,1,0,"",128

OK

#Hang up:

[root@manjaro-arm ~]# echo 'AT+CLCC' | atinout - /dev/EG25.AT -
+CLCC: 2,1,0,1,0,"",128
+CLCC: 1,1,0,1,0,"",128

OK

[root@manjaro-arm ~]# echo 'AT+QNWINFO' | atinout - /dev/EG25.AT -
+QNWINFO: "FDD LTE","310410","LTE BAND 2",700

OK



Elsewhere I have read that the fourth value of AT+CLCC tells you whether the voice is carried by VoLTE. The Quectel AT command reference says ony this about it:

<mode>Bearer/tele service
0: Voice
1: Data
2: FAX

However the line with my wife's phone number has a 0 in that position. Still I wonder, with all the other symptoms lining up??
  Reply
#2
This example would suggest so https://forum.pine64.org/showthread.php?...7#pid86137

You're also registered on IMS.

If your phone stays on 4G then yes, it's VoLTE for sure, if it drops to 3G (or 2G) for the call, then no.



You can also check whether or not you're on 4G during the call (rather than after) using

Code:
mmcli -m any --command='AT+QNWINFO'

You might add this to the other thread if it's confirmed.
Pinephone v1.2 UBports CE. Adelaide, Australia using Amaysim SIM (Optus network, non-VoLTE) with Mobian SD card.
Manjaro Plasma Mobile on EMMC.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Instructions to get pinephone working on USA carrier omarcomputing 1 338 10-08-2022, 04:45 PM
Last Post: treebeard
  JumpDrive isn't working phytocube 2 612 06-05-2022, 03:22 PM
Last Post: phytocube
  likely bug, volte does not work when operator side data blockage is activated zetabeta 1 539 05-21-2022, 03:03 PM
Last Post: zetabeta
  voLTE Bell optimus 1 1,167 02-12-2022, 05:40 PM
Last Post: optimus
  SIM card slot not working dekrets 2 1,037 02-12-2022, 11:09 AM
Last Post: dekrets
  Can't get autofocus working duncan_bayne 4 1,511 01-22-2022, 09:17 PM
Last Post: duncan_bayne
  PinePhone Beta 3GB modem not working hannescam 15 4,879 01-19-2022, 02:08 AM
Last Post: bcnaz
  Video Out not working BenniTec 7 2,996 10-21-2021, 11:56 AM
Last Post: BenniTec
  How did you get data working on PureTalk? nelstomlinson 2 1,738 09-26-2021, 03:50 PM
Last Post: nelstomlinson
  JumpDrive not working due to device busy cnxsoft 3 1,838 08-08-2021, 12:18 AM
Last Post: mouffa

Forum Jump:


Users browsing this thread: 1 Guest(s)