Unresponsive after updating Manjaro
#1
I received my Pinephone64 a couple of months ago, and updated without issues.

Today I tried to update the phone using the GUI and got an error regaring dependencies.

THen I SSH'ed into the device, and ran 
Code:
sudo pacman -Syu

and then restarted..

Now the phone shows nothing on the display at all when booting.

I have tried the recovery boot a couple of times, and the LED is always green and then yellow, not the red-yellow-green stated in the documentation.

Going through the logs, I noticed this error:

Code:
(12/25) Updating linux-pinephone initcpios...
Code:
==> Building image from preset: /etc/mkinitcpio.d/linux-pinephone.preset: 'default'
Code:
  -> -k 5.12.11-1-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
Code:
==> Starting build: 5.12.11-1-MANJARO-ARM
Code:
  -> Running build hook: [base]
Code:
  -> Running build hook: [udev]
Code:
  -> Running build hook: [autodetect]
Code:
findmnt: /etc/fstab: parse error at line 5 -- ignored
Code:
  -> Running build hook: [modconf]
Code:
  -> Running build hook: [block]
Code:
  -> Running build hook: [filesystems]
Code:
  -> Running build hook: [keyboard]
Code:
  -> Running build hook: [fsck]
Code:
==> Generating module dependencies
Code:
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
Code:
==> Image generation successful
Code:
(13/25) Updating linux initcpios...
Code:
==> Building image from preset: /etc/mkinitcpio.d/linux-pinephone.preset: 'default'
Code:
  -> -k 5.12.11-1-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
Code:
==> Starting build: 5.12.11-1-MANJARO-ARM
Code:
  -> Running build hook: [base]
Code:
  -> Running build hook: [udev]
Code:
  -> Running build hook: [autodetect]
Code:
findmnt: /etc/fstab: parse error at line 5 -- ignored
Code:
  -> Running build hook: [modconf]
Code:
  -> Running build hook: [block]
Code:
  -> Running build hook: [filesystems]
Code:
  -> Running build hook: [keyboard]
Code:
  -> Running build hook: [fsck]
Code:
==> Generating module dependencies
Code:
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
Code:
==> Image generation successful



So I am worried that this may be a low level issue, so I have ordered a serial console cable to be able to debug any such error.

any advice is appreciated
  Reply
#2
I ran into a similar problem after installing updates tonight via Terminal, my phone crashed and now on restart, the screen is an illuminated black. An incomplete message popped up eventually stating to use a command "loginctl unlock-session cl"

HALP! Confused
  Reply
#3
before some hours came the latest updates of the Qt and now it runs again

log in to console 3 with the keyboard and update and restart

this happens regularly, you can run a distribution from the SD and update the eMMC everyday until it works again, the update can be done either by connecting a keyboard on the dock or via the headphone USB  cable or by running another OS from the SD and doing `chroot` to update the eMMC, look at the following threads

https://forum.pine64.org/showthread.php?tid=14209

https://forum.pine64.org/showthread.php?tid=14166
  Reply
#4
I got the cable and successfully logged in via the UART terminal

Moving Image from 0x40080000 to 0x40200000, end=41560000
## Flattened Device Tree blob at 4fa00000
  Booting using the fdt blob at 0x4fa00000
  Loading Ramdisk to 4993e000, end 49fff295 ... OK
  Loading Device Tree to 000000004992e000, end 000000004993dcf8 ... OK

Starting kernel ...

WARNING: Unimplemented Standard Service Call: 0x84000050
Starting version 248-5-arch
ROOT_MNJRO: recovering journal
ROOT_MNJRO: Clearing orphaned inode 523584 (uid=0, gid=984, mode=0100640, size=8388608)
ROOT_MNJRO: clean, 180354/1896832 files, 1935133/7571419 blocks
[    6.904245] systemd[1]: Failed to start Load Kernel Modules.
[FAILED] Failed to start Load Kernel Modules.
[FAILED] Failed to start Zram-based…compressed RAM block devices).

Manjaro Linux 5.12.2-2-MANJARO-ARM (ttyS0)

plasma-mobile login:

Logging in works, but none of the network stuff works, so updating is out of the question.

Attaching the usb dock registers, but can't log in to the screen. I will try loading an OS from the SD card instead.
  Reply
#5
it seems you have some other problem, reinstall the latest Manjaro image and if it stops in the future do what we have said, I don't know excactly how the UART cable works, I think with telnet, another method would be to download the packages from another OS and install them manually with pacman
  Reply
#6
Exclamation 
I am still having issues... 

I have tried upgrading several times, and using the UART terminal to monitor the phone. but it seems to me that several things are wrong...
I can never see the SD card. if I take the same CD card and put it in a usb card reader and stick it in the dock i can mount it, but `fdisk -l` always only returns the internal eMMC.

Also, it appears that the network card stops working. It flashes a little at boot, but goes completely dark when the rest of the boot starts...

`iw info` just returns "nl80211 not found."
`ip list`  only shows lo, which is not much use...
`ls /sys/class/net` also only shows lo

I have attached a file 
.txt   pinephone_debug.txt (Size: 32.27 KB / Downloads: 110)
with the output of the boot as experienced through the UART 

and recorded a little video here: https://youtu.be/GZ9LcY02cA4
  Reply
#7
it is important to flash the latest Manjaro Plasma to the eMMC to be sure that you are not dealing with software issues
  Reply
#8
This has been resolved. apparently I had stuck the SDcardi in the simcard (lower) slot, which meant that it wasn't working. I got help on the discord server, and now have aworking phone again.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro phosh no screen rotation sandspur 1 227 06-23-2022, 01:02 AM
Last Post: rapp
  Manjaro on Pinephone freezes during startup LasVegasLee 1 472 03-22-2022, 06:48 AM
Last Post: acrux
  Camera on manjaro arm transfer76 7 1,667 03-18-2022, 10:11 PM
Last Post: Ant
Sad write SD with UMS enabler and manjaro graphic bug in configuration John (the 2nd one) 10 2,317 01-11-2022, 04:02 AM
Last Post: John (the 2nd one)
  PinePhone Stuck in landscape (Manjaro Plasma) Ephraimlad 1 621 01-04-2022, 05:41 PM
Last Post: jasonriedy
Wink Manjaro unlock code out of the box Red10Para 3 992 11-29-2021, 09:43 AM
Last Post: Red10Para
  PinePhone to sell ; Community Edition Manjaro + Convergence Package Gribouille 6 2,303 11-28-2021, 06:52 AM
Last Post: Gribouille
  Waydroid on Manjaro 16 - how to launch stozi 4 946 10-08-2021, 07:26 PM
Last Post: pjsf
  Manjaro Edition Pinephone for sale mstevens 5 1,060 09-17-2021, 10:50 AM
Last Post: mstevens
  Which interface was pre-installed on the PinePhone CE: Manjaro? amosbatto 4 2,258 08-17-2021, 12:40 PM
Last Post: marcih

Forum Jump:


Users browsing this thread: 1 Guest(s)