My pbp is a sleek, black, flat brick, and won't boot from any kind of media
#10
No boot SOLVED
My experience for what it's worth:
I went through all the suggested fixes (described in a previous post: flashing zeros to SPI, checking daughterboard cable, etc) and finally started over. I had tried so many approaches, that I was losing track. I used a second computer, a 2gb HP celeron laptop running puppy Easy OS on a usb stick.
I disabled the 64gb emmc and removed it. I had already flashed the SPI with zeros. That left only the sd slot for booting.
I downloaded balena-Etcher on the HP, unzipped it, and changed permissions to allow execution. I downloaded the Manjaro ARM KDE plasma... 21.06 . I put a 32gb Kingston HC1 "Canvas" sd into a usb multipurpose reader from IOGear Model GRR304SD and put reader into a USB 2.0 port. I used Etcher to flash the 21.06 file onto the sd card. After the file was flashed (5 min), Etcher ran a validation check which failed. I redid the flashing, and the validation check said the flashed image was fine.
So, I loaded the Kingston sd card into the bare bones PBP, held the power switch down for a minute, clicked the tiny reset button on the motherboard, pushed the power switch for a few seconds, AND, for the first time in two weeks, the PBP lit up and went into action.
One down, one to go.
I removed the sd card, enabled the emmc , pushed the power switch and got nothing. So:
I loaded the emmc card on to an Ordroid USBEEMMC (Olympian LED) reader that I bought for the purpose, and put it into the 3.0 USB port on the HP. When mounted, I looked at some of the files and found that I had previously flashed the Manjaro KDE plasma...21.07 file, the one meant for intel machines. Using Etcher again, I flashed the ARM 21.06 file that worked on the sd card.
I reinserted the emmc card in the PBP, and it worked fine. Put the sd card in as well; and that worked.
So, it was all my stupidity. I highly recommend Etcher, the Ordroid USB-Emmc reader, and the IOgear USB reader. I used the pricier sd cards to be safe. If I have trouble in the future, I would not flash zeros to the SPI until every other option failed. It took me days to do and I'm not sure that it was needed.
Loving my PBP.
  Reply


Messages In This Thread
RE: My pbp is a sleek, black, flat brick, and won't boot from any kind of media - by straightwalker - 06-21-2021, 09:08 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  3 days in, slow/stuck or no boot. lgmpbp2 4 518 07-01-2024, 09:26 PM
Last Post: wdt
  upgrading u-boot--what version? where to get it? bsammon 11 1,273 05-22-2024, 09:33 AM
Last Post: wdt
  Screen on pinebook stays black but can ssh into machine tuxxpine 0 521 02-23-2024, 04:22 PM
Last Post: tuxxpine
  uboot wont boot to SD card after upgrade jbradley419 7 1,541 01-19-2024, 02:29 PM
Last Post: wdt
  Video Flashing/adjusting on boot and reboot jbradley419 0 488 01-16-2024, 09:17 AM
Last Post: jbradley419
  Brand new Pinebook Pro doesn't boot after Manjaro update johnboiles 8 2,969 12-15-2023, 02:11 PM
Last Post: wdt
  PBP won't boot after trying to reinstall Manjaro ARM soupgirl 3 1,090 12-13-2023, 08:17 PM
Last Post: trillobite
  Various freezes during boot & while running several Linux distros - hardware error? donuts 1 844 11-22-2023, 11:47 AM
Last Post: fxc
  Cannot boot to Kali SD card after uboot upgrade jbradley419 4 1,580 09-19-2023, 08:48 AM
Last Post: dachalife
  Does latest Tow-Boot install/work correctly for everyone? tophneal 4 2,406 08-03-2023, 03:30 PM
Last Post: tophneal

Forum Jump:


Users browsing this thread: 1 Guest(s)