Device unable to boot
Hi everybody, I've just bought a RockPro64.

Yesterday I wanted to try it out and flashed OpenWRT onto a SD card and powered it.
I was getting a white LED almost immediately and I was able to login using SSH and the web GUI.

Today I wanted to actually setup the board, I tried to boot using the same process and using the same working SD card. I couldn't get any LED expect the green power LED.
I tried reflashing the SD card with OpenWRT again, still nothing.
Tried connecting the HDMI, no signal.
Tried to flash Armbian Buster for the RockPro64. Same thing no HDMI signal and no LED.
I also tried to connect to the board using serial. When I'm trying to use 9600,8n1 I'm getting just an infinite number of `?` in the terminal,
when using 1500000,8n1 I'm getting ``

[Image: rock.png]

I tried flashing the OS on two different SD cards.
At first I tried flashing using Etcher on Windows and using PuTTY to connect.

[Image: unknown.png]

Since that wasn't working, I booted into Linux. Redownloaded the OpenWRT version I previously was able to boot.
Flashed a SD card using:
sudo dd if=./openwrt-21.02.0-rc2-rockchip-armv8-pine64_rockpro64-ext4-sysupgrade.img of=/dev/sdb

Powered the device with the freshly flashed OS.
And tried to get the serial monitor to work using
minimon -D /dev/ttyUSB0 -b 1500000

Still nothing except a long line of missing symbol character (same as PuTTY on Windows), and still no white LED.

I've also noticed the Ethernet port LEDs looks really dull for about 5 minutes then brighten.
I'm using a HW-417 Serial to USB, and I keep the TX cable disconnected from the pin 10 of the PI header, since from what I've read the connecting the TX to pin 10 at boot could cause the board not to boot. Still tried with the pin 10 connected just in case but didn't change a thing.
Hi Lunix33 and welcome,
  (with this login I was not expected to see see a windows user Tongue )

If you did not solve yet your problen, you could eventually check :

- for the boot :
     - the sd is properly inserted
     - the power supply is sufficient

- for the UART (but I suppose you are aware of these points and the tuto :
     - 150000 is indeed the appropriate frequency
     - the rx of the uart is linked to the tx and the ground are wired
     - the voltage is 3.3V

- flash the u-boot image in the spi and see if there are some messages sent by UART at power on even without any sd inserted

- if you have the opportunity, try with an emmc (boot method enabled in default) or usb boot (thanks to the u-boot)

good luck !
Thanks for the insight LMM,

With all the boot tries and reflashing I did, I don't expect to have inserted the SD card every single time.

When it comes to the power supply I'm using one of the recommended power supplied. It's a 12v@3A power supply.
I'm trying to boot the device without any accessory attached, so I don't think I'm actually overloading the power supply.

And I've followed the exact same tutorial to try to establish a serial connection.
I've been using the 1.5MBaud rate,
I was connecting the RX lead to the pin 8 and used the ground lead on pin 6 while keeping the TX lead disconnected to make sure I don't impede the boot process.
The serial adapter was set at 3.3v

I haven't tried to flash the SPI with UBoot yet since currently I'm waiting for the Pine support to issue a RMA so I can test if I just received a lemon.
But I still tried to see if I would get anything out of serial connection even without any SD card, and I just get the same goop as when the SD card is in.

And the emmc isn't an option since I didn't buy any emmc modules and prefer to run directly from a SD card for the time being for simplicity.
I saw in this post that all uart do not support 150000 rate.
Moreover it also give some useful hint.
And also this one on not genuine ft232RL chips problems with windows :
in this post, the solution was to hold the the reset + power button (or on power off touch all the gpio pins  before). You could also eventually use the 4 pins hole next to the headphone jack (wire the reset or power button to the ground with a paper clip for example )
I've just looked through the posts you've recommanded.
I've flashed an os on the SD card I know has HDMI output (Armbian Buster) and did some more testing.

I've tried the power + reset solution by pressing both at the same time for 2 sec and doing a 2sec power followed by 2sec reset then pressing the power button once more to power on the device but without any result all no white led, nor any HDMI output.
When it comes to the power and reset pin holes next to the audio jack, I've tried jumping the power and ground as in this post (, it just powered off the device. From what I can understand those pins are the same as the buttons, unless I've misunderstood what they are used for.
For the `(or on power off touch all the gpio pins  before)` part, I'm not sure I get what you mean by that.

On the serial interface side of things. I didn't expect there could be fake FTDI IC, but after some research, I found my FTDI programmer might be a fake.
So far it worked just fine with lower speed devices like some other SBC and dev board, but maybe not with this board.
I've ordered a new serial interface with a genuine FTDI chip and will try to see if I can get any output out of the board once I'll receive it.
Okay as an update,
I've just received the new FTDI Serial interface I validated the serial number to make sure I don't have a fake chip,
I tested the serial interface on a ESP32 project board I have and it's working just fine.

But when I'm trying to use the serial interface with the Rockpro I still only get garbage from the board.
I made sure the interface was in 3.3v mode, and connected the ground to the ground pin of the board (pin 6) and connected the Rx pin of the interface to the Tx pin of the board (pin 8), and left the Rx pin (pin 10) of the board empty.
> But I still tried to see if I would get anything out of serial connection even without any SD card,
> and I just get the same goop as when the SD card is in.

If your report above is similar to the photo you presented in the first report,
It means the symptom that "Tx outputs a lot of garbage even though no bootable device is attached".

At least this isn't normal.
Even if there is a baud rate mismatch,
when resetting or powering on, garbage of about 1 or 2 characters appears.
It is a symptom of that degree at best. (If there is no hardware dameges)


"Some dirty data was unintentionally written to SPI-Flash."
It looks like that to me.

For the RK3399, SPI-Flash has the highest boot priority.
*) SPI-Flash-> eMMC-> SDcard
Therefore, if invalid data is written here,
that media will not be referenced even if a valid image is written to SDCard / eMMC.

SPI-Flash can be easily disabled with a jumper.
Does the above operation change the state ?
I recommend the above confirmation first.

The current situation is that you don't even have the minimum debugging tools,
which is a stalemate.
I finally received a replacement device from Pine,
I confirm that at first glance, the new device seems to be working as expected.

I'm now able to get serial output and it was able to make it boot more than once.
The old device was probably defective since I'm still using the same SD card and my new serial adaptor.
Thumbs Up 
Super ! Thanks for the update

Possibly Related Threads…
Thread Author Replies Views Last Post
  enble boot after power loss/restore dkebler 18 8,667 12-04-2023, 12:14 PM
Last Post: ok38
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 108 114,188 09-25-2023, 12:46 AM
Last Post: ChriChri
Bug Broken boot: What am I missing? mkosarek 1 549 09-08-2023, 08:14 AM
Last Post: wdt
  Unable to boot Armbian on new RockPro64 mooseball 5 3,976 07-14-2023, 08:59 AM
Last Post: rockjonn
  no boot white led flashing moserwi 7 3,959 05-18-2023, 10:46 AM
Last Post: wdt
  u-boot locked on pine64pro ljones 1 1,423 09-06-2022, 10:32 AM
Last Post: ljones
  Cannot get my board to boot deutschlmao 11 7,618 09-05-2022, 04:23 PM
Last Post: ljones
  U-BOOT Tutorial hazz 0 1,082 07-19-2022, 10:48 PM
Last Post: hazz
  Installation Debian on emmc: which U-Boot and where? vongillus 3 2,600 07-02-2022, 09:24 AM
Last Post: dkebler
  ROCKPRO64 PCI SSD SD-boot Install pspgarret 0 1,084 06-09-2022, 10:56 AM
Last Post: pspgarret

Forum Jump:

Users browsing this thread: 1 Guest(s)