how to make it run?
#1
I'm honestly confused. please help Sad

I've bought SOEdge to just try what it can do, in my clusterboard but i'm not even able to start it....
here if founds some images and link for a guide how should flash it to the eMMC. However there is no guide for flashing it on clusterboard, and i'm really not sure if i should connect the usb (which one) on the clusterboard with SOEdge inside to my computer or what....
  Reply
#2
I had a similar problem. Same situation, SOEdge module in a clusterboard.

I flashed the factory test build image on the wiki to an eMMC module using the USB-to-eMMC adapter available in the store. What resulted had no partitions and did not boot at all. I was not even able to read the eMMC's contents after flashing. So, I figured the USB-to-eMMC adapter is not the right way to go for this image.

Then I tried the method mentioned in the guide using a Rock64. Good thing I had one of those to try! But, alas, I got the same result. After flashing the image, there was nothing readable or bootable on the eMMC.

Then, I bit the bullet, set up an Ubuntu 16.04 virtual machine (the SDK suggests/requires it), and built an image using the SDK. After a rather long build, I wound up with a set of images that needed to be flashed to the eMMC. I followed the instructions in the SDK and flashed the images using the Rock64 again, and still nothing winds up readable or bootable on the eMMC.

I am clearly doing something wrong. All of my experience with eMMCs on the Pinebook and Rock64 (and many other non-Pine boards) is not helping me here at all. It seems like the flashing process is not doing what it is supposed to.

I am going to order a SOEdge baseboard soon. Maybe I need one of those too, just to get the modules up and running? Any clues would be much appreciated.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)