PCIe gen1 timeout - how to debug
(04-28-2021, 11:28 AM)LMM Wrote:
(04-27-2021, 12:24 PM)tosi Wrote: Hi everybody,

-- short version for the impatient :-)

I have 2 questions:
- when does the yellow LED go on/off on the ASM1062 board?
- what is the minimal setup of rockpro64 that should not show "gen1 timeout" errror but some entries in lspci etc?

-- long version

i have bought 
  • a rockpro64 2.1 board (builddate 2018-07-02)
  • according 60W power supply
  • nas case
  • asmedia 1062 pcie board
  • 14 TB Toshiba SATA disk
  • 512 MB Sandisk SATA SSD
i have ~5% chance in cold-boot (attaching power-barrel after ~1 h downtime) that uboot and/or linux kernel get the pciE devices to work.
In these cases I see activity on yellow LED mounted on the pcie-board (under the sata-ports). The activity starts early in the boot process

However, most of the time both u-boot as well the kernel complain:

rockchip_pcie pcie@f8000000: PCIe link training gen1 timeout!

resulting in no pci / SATA devices were found/listened.
I am now trying to get to the bottom of this and how to prevent it.
I have read many differrent advices (e.g. increasing timeouts.) in this forum and similar places. However neither the root-cause of this error nor  minimum setup is that should work is clear to me.

I have tried several combinations, including but not limited to:
- board w/o sata card
- board w sata-card, but no disks, 1 disk, both disk..
- board with sata card and power, but no sata cable
- board with sata card and cables.

with all of these combinations i can 
  • see the gen1 timeout on u-boot. 
  • When starting u-boot and issuing the


    command, i usually get "No such Bus" back.
I tried all different sort of U-Boot at the moment working on a self-compiled u-boot master (SPL 2021.07-rc1-dirty). 
Also trying to relax the timeout leading to the gen1 error message from 500 msec up to 25 sec didn't solve the problem yet.

I suspect there is either a timing and/or powering issue on the board. but i am a bit clueless how to debug further.

Any help or pointer is highly appreciated.


  I read in some pine64 posts that asmedia was rather difficult to set-up (searched in the forum).
  I use a pcie gen 2 overlay on Armbian and so far no problem with one of my nvme card which is recognized as gen2 but the second one has some difficulties to be recognized. I also have a Jmicron SATA card and no problem (though, for the moment, I only tested a small HDD). I also read that Marvell is also ok.


Messages In This Thread
PCIe gen1 timeout - how to debug - by tosi - 04-27-2021, 12:24 PM
RE: PCIe gen1 timeout - how to debug - by LMM - 04-28-2021, 11:28 AM
RE: PCIe gen1 timeout - how to debug - by tosi - 04-28-2021, 01:49 PM
RE: PCIe gen1 timeout - how to debug - by db579 - 03-10-2022, 05:06 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  PCIE interface power on too late Slark Xiao 0 727 11-29-2022, 11:56 PM
Last Post: Slark Xiao
  Anyone try an NVIDIA GPU in the PCIe slot? Paraplegic Racehorse 0 1,600 04-15-2021, 11:46 AM
Last Post: Paraplegic Racehorse
  Never ever mix up CPU board connector with 8-pin PCIE connector LMM 0 1,651 02-11-2021, 10:18 AM
Last Post: LMM
  PCIe Armbian and Ayufan for nvme ssd LMM 1 2,488 02-03-2021, 04:38 PM
Last Post: LMM
  fan continously runs on kernel 5.8 but I need to use 5. kernel for PCIe sata card GreyLinux 4 5,297 10-20-2020, 10:52 AM
Last Post: GreyLinux
  PCIe x4 mode - Lane 3 failure acdkyn 1 2,580 04-24-2020, 01:32 PM
Last Post: kuleszdl
  Considering buying and question on the PCIe slot MobileJAD 25 40,648 11-07-2019, 03:10 PM
Last Post: hmuller
  RockPro64 pcie Gpu Davidos 1 3,156 06-09-2019, 02:09 PM
Last Post: guannais
  login to GUI desktop hangs when PCIe SSD is plugged in grimace 3 4,900 04-24-2019, 04:24 PM
Last Post: Luke
  PCIe SSD drive still not working ?? dr_ju_ju 7 8,610 04-15-2019, 04:16 PM
Last Post: tllim

Forum Jump:

Users browsing this thread: 1 Guest(s)