RP64 Won't Boot After Power Down
(04-25-2021, 04:56 PM)ColPanic_ Wrote: Hi all,

I've been seeing this issue ever since I got my RP64, where the board sometimes just decides not to boot anymore after being powered down. I've always gotten it to recover eventually, but I really don't know how. The only consistent factors seem to be replugging the SD card and time. Maybe someone can help me out? I promise if I get this working, I'll post my project on here, with scripts and schematics Wink

- No red or white LED
- Green power LED is on, amber ethernet LED is blinking at a constant rate
- UART output only shows 

Quote:DDR Version 1.19 20190305

- Root and boot partitions on the SD card are OK, I can still mount them on a PC

What I've tried:
- 3 different SD cards: sometimes one of them works, but none seems to be more more reliable than the others
- Boot from USB disk: USB boot hasn't worked yet from this state
- Reflash the SD card image: sometimes this works, usually it doesn't
- Reflash u-boot: the u-boot flashing image has the same boot problem as the OS image. if it does run, then the RP64 boots normally again.
- Jumper the boot pins: no effect
- Jumper pins 23 and 25: no effect

My setup:
- Ayufan's OpenMediaVault image, running from an SD card
- U-boot. Only for troubleshooting this issue; I wanted to try booting from USB
- Powered from an ITX PSU. After the RP64 is shut down, PSU power is also killed

   Perhaps you have an issue with the sd card reader or the sd does not plug properly.
   You may try to
       - erase the SPI flash
       - boot another kernel (for example Armbian).

   May be it worth trying an emmc instead (the performance is really better than sd) or make the boot from USB work.
   When it boots you may also check dmesg from time to time if errors appear.

Looking forward to see your project.


One more thing I've just remember : I don't know why but sometimes I have to push the two button (power + reset) for launching the boot. If it still does not work I touch all the GPIO pins (when it is power off of course) and then power on.

Messages In This Thread
RP64 Won't Boot After Power Down - by ColPanic_ - 04-25-2021, 04:56 PM
RE: RP64 Won't Boot After Power Down - by LMM - 04-26-2021, 01:13 AM
RE: RP64 Won't Boot After Power Down - by LMM - 04-27-2021, 01:14 AM
RE: RP64 Won't Boot After Power Down - by LMM - 04-29-2021, 04:49 AM
RE: RP64 Won't Boot After Power Down - by gechu - 09-04-2021, 12:12 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  NAS Setup: Hdds PSU external power option Robotik 1 840 07-18-2022, 10:10 PM
Last Post: zer0sig
  NAS case HDD power cable failure (buck failure) ashleymills 1 932 04-01-2022, 11:25 AM
Last Post: ashleymills
  Power In Via DC Out actionhank 0 686 01-28-2022, 09:45 AM
Last Post: actionhank
  RockPro64 doesn't boot when PCIe to M.2 adapter is installed Cerberus 3 2,133 11-27-2021, 11:38 PM
Last Post: Cerberus
  No audio on HDMI after u-boot upgrade xlx 0 817 11-21-2021, 02:16 PM
Last Post: xlx
  RP64 TV box case with wifi Wizzard 2 2,415 03-10-2021, 12:23 AM
Last Post: Wizzard
  Carte PCIe bloquant le démarrage du Noyau / PCIe card blocking Kernel boot dml-pc 4 3,512 02-17-2021, 11:35 AM
Last Post: dml-pc
  How to add an external power button? foresto 6 6,881 02-05-2021, 10:38 PM
Last Post: foresto
  Won't boot with SATA card rjzak 4 4,347 01-09-2021, 05:56 PM
Last Post: kuleszdl
  Won't boot with 2.5GBe PCIe adaptor connected voltagex 1 2,243 10-20-2020, 12:22 PM
Last Post: xmixahlx

Forum Jump:

Users browsing this thread: 1 Guest(s)