PXE boot - unable to login
#1
Hi all,
  I try to boot over the network (PXE boot) and follow the tutorial https://forum.pine64.org/showthread.php?tid=6814 with the Armbian image. After some hours to understand at the end that iptables was blocking the tftp connection Angry I was able to boot but I cannot login : it is stuck when I enter the login or new password.
Do you have an idea of how to solve this issue ? root mount error ? NFS problem ?

LMM
  Reply
#2
(04-22-2021, 07:44 AM)LMM Wrote: Hi all,
  I try to boot over the network (PXE boot) and follow the tutorial https://forum.pine64.org/showthread.php?tid=6814 with the Armbian image. After some hours to understand at the end that iptables was blocking the tftp connection Angry I was able to boot but I cannot login : it is stuck when I enter the login or new password.
Do you have an idea of how to solve this issue ? root mount error ? NFS problem ?

LMM

I tried with both @ayufan  and @sigmaris  U-boot :

- Sigmaris U-boot stopped at booting level :
Code:
....
TFTP from server 172.21.200.1; our IP address is 172.21.200.31
Filename 'dtb-5.10.21-rockchip64/rockchip/rk3399-rockpro64.dtb'.
Load address: 0x1f00000
Loading: ######
         1.4 MiB/s
done
Bytes transferred = 75809 (12821 hex)
Moving Image from 0x2080000 to 0x2200000, end=3de0000
## Flattened Device Tree blob at 01f00000
   Booting using the fdt blob at 0x1f00000

- Ayufan stopped at login level
  Reply
#3
Now it works with a not "first boot" boot files. But only with ayufan u-boot.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  First boot - no fan, no display... is it broken? rantoie 1 114 04-28-2021, 04:41 PM
Last Post: rantoie
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 82 34,181 04-26-2021, 04:09 AM
Last Post: Maxpako
  Unable to Run GNOME or KDE due to "dmidecode" segmentation fault rrs64 3 1,366 03-15-2021, 06:42 AM
Last Post: Mishal22
  unable to boot from SDCard Charles Tarkowski 4 915 12-16-2020, 11:11 AM
Last Post: Charles Tarkowski
  Unable to synchronize Raid 0 NAS with OMV keuplat 0 417 11-10-2020, 05:47 PM
Last Post: keuplat
  Rockpro64 boot issues larsgn 14 6,623 10-21-2020, 07:54 AM
Last Post: quinterro
  RockPro64 eMMC boot euu 4 2,531 08-24-2020, 11:07 PM
Last Post: t4_4t
  RockPro64 so problematic! Boot issues PorterDon 1 1,325 06-04-2020, 12:25 PM
Last Post: dukla2000
  Failure to boot atcwells 1 1,130 05-10-2020, 03:06 PM
Last Post: atcwells
  RockPro 64 V2.1 Boot problem only DDR Version ... message nutilius 5 2,255 05-02-2020, 03:26 AM
Last Post: freeviv

Forum Jump:


Users browsing this thread: 1 Guest(s)